1. Download our Official Android App: Forums for Android!

Support Notifications in Calendar 12 hours out

Discussion in 'Android Devices' started by raffles158, Aug 3, 2011.

  1. raffles158

    raffles158 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 3, 2011

    Aug 3, 2011
    2
    0
    5
    Hi All

    I have a colleague that is using an HTC Desire S and has reminders set in his calendar. The problem he is experiencing is that whilst the phone is set to UK timezone and the date and time is correct, the reminder is 12 hours behind.

    Under the clock/weather widget he has the reminder showing with the date and the upcoming reminder in the calendar.

    The icon that shows the date is always 12 hours behind. For example at 11.59am this morning it showed as Aug 2, as soon as it changed to 12 noon, it changed to Aug 3.

    I have checked all the settings I can think of, and looked at the online manual but cannot see where this is getting it's time from.

    I have attached an image of the phone, not the clearest but you will see the calendar bit I am talking about.

    Any help would be greatly appreciated.

    Regards

    Raffles.
     

    Attached Files:


    Advertisement

  2. notebook

    notebook Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    732
    Joined:
    Jun 10, 2011

    Jun 10, 2011
    732
    169
    93
    I wonder if it's doing this due to an external setting.

    Verify that the country and time details used by Calendar are correct. E.g. if using Google's Calendar to sync with, then check the Calendar account settings online, by logging into the Google account on the web > Account settings > Calendar - Settings. Similarly, check the syncing sources of other calendars that Calendar might be using, i.e. Outlook, etc.

    I don't know if this will make a difference, but it's worth a try.
     
    raffles158 likes this.
  3. raffles158

    raffles158 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 3, 2011

    Aug 3, 2011
    2
    0
    5
    Hi

    Thank you for the quick response.
    The user does not have calendars set up with his GMail account. Although I did find another googlemail account which he has no idea how it got there.
    I have told the phone to stop syncing this account to see what happens. I cannot remove the account without a factory reset of the phone as it says other applications are using that account, and I haven't had chance to take the necessary backups of his data in order to reset it yet.
    He is going to let me know tomorrow if the changes I have made are sufficient for it to work correctly.
     
  4. notebook

    notebook Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    732
    Joined:
    Jun 10, 2011

    Jun 10, 2011
    732
    169
    93
    Two other things you might like to try...

    1.

    Menu > Settings > Date & time > uncheck Automatic

    Select time zone and select a time zone that you're not in and not one that represent the Calendar issues (i.e. 12 hours ahead/behind).

    Press Home screen, then go back to the above and check Automatic. This might reset the Calendar.

    You could also try the above, but include a soft reset (remove battery for 30 seconds) before going back and checking Automatic.

    2.

    Menu > Settings > Accounts & sync > Disable all syncs with calendars (e.g. press Google and uncheck the relevant boxes)

    Still in Accounts & Sync uncheck both Background data and Auto-sync.

    Menu > Settings > Applications > Manage applications > All (tab) > in Calendar, Calendar Storage and Calendar Widget press 'Clear data'. !!WARNING!! - This will erase all calendar entries, appointments, etc, so you'll want to make sure this data is backed-up and/or can be re-synced.

    Turn off phone and remove battery for 30 seconds (soft reset).

    After 30 seconds, replace battery, turn on phone, Menu > Settings > Accounts & sync > Enable the syncs you previously turned off and switch Background data and Auto-sync back on.
     
Tags:

Share This Page

Loading...