1. Download our Official Android App: Forums for Android!

Support Notifications ONLY for inbox, not junk?

Discussion in 'Android Devices' started by Vinnydude, Dec 2, 2011.

  1. Vinnydude

    Vinnydude Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    103
    Joined:
    Jun 3, 2011

    Jun 3, 2011
    103
    2
    36
    So I was waiting for an important email today and was getting extremely frustrated about getting excited every time i got an email only to find out it was junk.

    Is there a way to set it so that I won't receive a notification for something from the junk mail folder?
     

    Advertisement

  2. greggebhardt

    greggebhardt Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    671
    Joined:
    May 11, 2011

    May 11, 2011
    671
    56
    78
    Owner
    Jacksonville, FL
    It is YOUR job to set up spam filters. You need to go to your email provider and set up filter to stop spam. My filters catch about 9 out of 10 spam emails which would help you greatly.

    You got to check your spam box on occasion as sometimes it will stop what you want.
     
  3. Vinnydude

    Vinnydude Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    103
    Joined:
    Jun 3, 2011

    Jun 3, 2011
    103
    2
    36
    That didn't answer my question at all.
     
  4. jackolo

    jackolo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 13, 2011

    Apr 13, 2011
    1
    0
    5
    Edmonton AB
    Same issue. I just got my i727r and setup push notification for my Hotmail account. I keep getting notifications from Emails that are from the junk folder and not my actual inbox.
     
  5. Russell Ng

    Russell Ng Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,384
    Joined:
    Sep 29, 2011

    Sep 29, 2011
    1,384
    166
    143
    Male
    Engineer
    Kuala Lumpur
    I don't have this problem and using the stock email app. If you go to the email and turn into landscape mode, at the top left corner you can see which folder you want it to show. Mine shows Yahoo Inbox. Maybe your set it to show Yahoo Junk Mail.

    Can't think of anything else.
     
  6. Vinnydude

    Vinnydude Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    103
    Joined:
    Jun 3, 2011

    Jun 3, 2011
    103
    2
    36
    I have multiple email accounts so I have them set up in messaging. I get notifications when i get an email, junk or not junk. I want to be able to set this so i'm only notified when i get mail in my inbox, NOT junk :)
     
  7. mebct76

    mebct76 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 9, 2011

    Dec 9, 2011
    1
    0
    5
    I'm having the same issue. My spam filter works great but this phone keeps syncing it. All day long I get *DING* "new email" but its not in my main inbox, its in my spam folder. The one folder I don't want to hear about. On top of that when I get an email that isn't necessarily spam that comes into my inbox, if I delete it without opening it to mark it "read" then 2 minutes later I get *DING* new email...because I now have an unread email in the trash. Its pi$$ing me off! Why can't it work right out of the box like my iPhone did. :mad:
     
  8. FBGordon

    FBGordon Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 9, 2012

    Nov 9, 2012
    3
    0
    5
    Male
    Florida
    Did you ever get it to stop? My Note 2 started doing it last week when I accidentally went to the Junk folder through my general email app. Now it acts like my Junk folder is something I want notifications from. I tried to go through the app's settings menu, no dice.
     
  9. Kasser

    Kasser Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    108
    Joined:
    Feb 3, 2012

    Feb 3, 2012
    108
    2
    36
    My S2 just started doing this after working perfectly for months. As mentioned above it's because i went to the junk folder once and now it syncs and notifies me of every pissing email.

    Last time this happened to me i deleted the account and set it up again.
     
  10. FBGordon

    FBGordon Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 9, 2012

    Nov 9, 2012
    3
    0
    5
    Male
    Florida
    Okay, so I just chatted with "Shirly" from Samsung support. If in your email settings you have an Incoming and Outgoing settings menu, you can probably fix it from there. I don't have that on my phone for some reason.

    So the only way to fix it is to delete the email account from your email app, then add it again. And whatever you do, don't go into your Junk folder from your email app!
     
  11. bktbktbkt

    bktbktbkt Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 17, 2013

    Mar 17, 2013
    1
    0
    5
    I've had my Samsung Galaxy S2 for 2-3 months. I set up my e-mail (hotmail) as microsoft exchange active sync when I first got the device. Until last week, I was ONLY receiving notifications on my device for mail that went to my inbox. I was NOT receiving notifications on my device for mail that went to any of the other folders, including the JUNK folder and a handful of other folders I created. Last week, I began receiving notifications for e-mail that is sent directly to my JUNK folder. When I open the notification, it shows e-mails I know to be from junk senders. When I tap on the notification, it takes me into my regular inbox and the message is NOT there, because it is in the JUNK folder. I can find no settings on the device or in the hotmail account to stop from getting notifications for JUNK mail which is sent directly to the JUNK folder. It does NOT have anything to do with how I have my hotmail account set up as everything was just the way I wanted it. Until a week ago, which is when the JUNK mail notifications began, I never received notifications for mail sent directly to the JUNK folder and does NOT appear in the regular inbox folder. The junk mail is still sent to the JUNK folder, only now my device is notifying me when something goes to the JUNK folder. As far as settings go in hotmail I have it set to "Exclusive - Everything is sent to the junk email folder except messages from your contacts and safe senders, Hotmail service announcements, and alerts that you signed up for." On my device, I have it set up as "Microsoft Exchange ActiveSync." Settings on the device for this account include only: Account name, Add signature, Default account (send e=mail from this account by default), Always Cc/Bcc myself, Forward with files, Period to sync email, sync schedule, size to retrieve emails, period to sync calendar, security options, In case of sync conflict, Auto resend times, Email notifications (you either select it with a check mark or deselect it), ringtone and Vibrate. I am using Android version 4.0.4, Kernal version 3.0.8. On T-Mobile network. Sorry this is so long, but it seems as though some who are replying do not adequately understand the problem. I wanted to include adequate information. If anyone knows how to stop getting the notifications for junk mail so that they are only received for inbox, your help is greatly appreciated.
     
  12. note2use

    note2use Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 18, 2013

    Mar 18, 2013
    1
    0
    5
    Thanks for your through post.....I'm having this same problem on my 2 week old Samsung note 2. Up until a day or so ago I only got notified of new "inbox" emails now I'm getting new "junkmail" notification too.

    Quite annoying.

    Verizion network, Samsung note2... other wise pretty much exactly the same
     
  13. StarMenace

    StarMenace Android Enthusiast
    Rank:
    None
    Points:
    58
    Posts:
    290
    Joined:
    Dec 29, 2009

    Dec 29, 2009
    290
    18
    58
    This just started happening yesterday on my Galaxy S3. Prior to yesterday I only received notifications on new items in my inbox. This is very frustrating. Anybody figure out a fix for this yet?
     
  14. StarMenace

    StarMenace Android Enthusiast
    Rank:
    None
    Points:
    58
    Posts:
    290
    Joined:
    Dec 29, 2009

    Dec 29, 2009
    290
    18
    58
    I figured out a workaround, not really a fix but it works. I removed the problematic email account completely then re-added it. I'm no longer getting notifications from my junk mail folder.
     
    trueblu8 likes this.
  15. trueblu8

    trueblu8 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    8
    Joined:
    Oct 28, 2011

    Oct 28, 2011
    8
    1
    6
    Until they come up with a fix, StarMenace's method is the only one that works.
    And as someone has said, whatever you do don't go into that junk folder again,
    at least not using the email app.
     
  16. volaveloce

    volaveloce Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 16, 2015

    Jul 16, 2015
    1
    0
    5
    Male
    Try Manage Accounts
    Select your email account
    scroll to the bottom - More Settings
    Folder Sync options -
    Select Junk and then set the Sync schedule to Manual
    Worked for me so far.
     
  17. pgomory

    pgomory Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    May 20, 2011

    May 20, 2011
    2
    0
    5
    THANK you volaveloce. How elegant!! The best I had heard before (and I used the technique on my last phone) was to re-create the account and then NEVER open the junk folder. That also worked.
     

Share This Page

Loading...