1. Download our Official Android App: Forums for Android!

Support Nova prime performance issue

Discussion in 'Android Devices' started by thaKing, Nov 16, 2014.

  1. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    Is anyone else noticing performance issues with Nova Prime? After unlocking the phone, any action I perform takes roughly 5 seconds. For example, unlocking and clicking on an app (Chrome). After 5 seconds, it loads. Everything from there runs just fine. It's just after unlocking.

    If I reboot the phone, then performance isn't an issue. I can unlock, and launch an app immediately. As time goes on, it takes 2 secs, then 3, then up to 5 secs to launch an app.

    Anyone notice this? Any tips to fix it?
     

    Advertisement

  2. MLSS

    MLSS Android Expert
    Rank:
    None
    Points:
    413
    Posts:
    2,245
    Joined:
    May 20, 2013

    May 20, 2013
    2,245
    1,486
    413
    Male
    Director of a non profit
    Nelsonville, Ohio
    Nope! I haven't had any issues...
    What version of Nova Prime are you running?
     
  3. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    3.2. Wonder what options I have selected that might cause this lag? I only keep open a few apps at a time - apps I use all the time: Chrome, email, text, facebook, phone, maybe one or two others, depends. The rest, I close out after I use them so they're not sitting there.
     
  4. bonerp

    bonerp Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,154
    Joined:
    Apr 12, 2010

    Apr 12, 2010
    1,154
    136
    143
    Project Manager
    UK
    turn off animations etc (dev options and I believe in Nova itself) and see what the does
     
  5. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    Window, Transition and Animator Duration were already turned off. In Nova, not sure which animations I should be looking for. Nothing looked out of the ordinary in Nova.
     
  6. LaTuFu

    LaTuFu Android Expert
    Rank:
    None
    Points:
    173
    Posts:
    1,286
    Joined:
    Nov 10, 2009

    Nov 10, 2009
    1,286
    258
    173
    Project Manager
    Virginia
    Did you remember to disable S-Voice at the home screen when you first got the phone? If this wasn't set up/disabled in the early stages of setting up the phone, that could be one problem.
     
  7. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    Not sure if I did or not, but let me see if this is what you're referring to:

    Under settings I found S-Voice. When I click on the setting, it wants to go through the setup to control my device. So I'm guessing it is not setup.
     
  8. LaTuFu

    LaTuFu Android Expert
    Rank:
    None
    Points:
    173
    Posts:
    1,286
    Joined:
    Nov 10, 2009

    Nov 10, 2009
    1,286
    258
    173
    Project Manager
    Virginia
    Yep, that's it. Try disabling that in the setup process (it sounds like you're not using it) and see if it clears up the problem.
     
  9. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    I disabled it, we'll see how that goes.
     
  10. KOLIO

    KOLIO Guest
    Rank:
    None
    Posts:
    0
    Joined:

    Have you enabled Developer Options:

    Samsung Galaxy Note 4 Tips & Tricks How to Enable or Turn On Developer Options, USB Debugging - YouTube

    Disregard his final statement regarding enabling developer options (On/Off),that in of itself,(w/99.999999% certainty) WILL NOT slow down the phone.

    Anyway,once there,you'll see some (3)options to speed up,or,turn off all animations.

    Some do not want to even get into developer options & that is fine.

    However,be assured that changing the abovementioned settings WILL NOT cause any harm to your phone whatsoever.

    If there are any other ?'s regarding Developer Options,we'll start another thread specifically for dev ops.
     
  11. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    S-Voice is disabled and no effect. When I unlock the phone, any action I take right away has about a 5 second delay.

    Yes, dev options is enabled and all animations are set to off. See post #5 above. :D
     
  12. KOLIO

    KOLIO Guest
    Rank:
    None
    Posts:
    0
    Joined:

    Oops,thought y'all were referring to settings within NOVA....... sorry 'bout that.

    Any d/l apps that you suspect that may be slowing things down?

    EDIT:

    Have you tried a cache partition wipe:

    Wipe cache partition: Samsung Galaxy Note 4 (N910) | T-Mobile Support
     
    thaKing likes this.
  13. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    I have the same, but fewer, apps as I had on my (rooted) S3. Speed was never an issue. But, that's not to say an app isn't causing this.

    Should I only be concerned about the active apps? For example, right now I only have Chrome and Facebook running and I see performance lag.

    When I click on the window switcher button (is that what it's called?) and then the pie chart, it says I am using 2.34GB of 2.72GB RAM - which seems high to me.

    Edit: I see you added the cache wipe. I'll give that a try and report back. Thanks! :)
     
  14. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    I did a cache wipe so we'll see how that works. Two things of note:
    1) After the wipe, when I select reboot, right under the Android it says "Error".
    2) My boot animation and audio have changed since the wipe. Weird!
     
  15. KOLIO

    KOLIO Guest
    Rank:
    None
    Posts:
    0
    Joined:

    That is weird.

    As for the boot animation,what did you see before & after the partition wipe?

    In what way has audio changed?
     
  16. twospirits

    twospirits AF's janitor
    VIP Member
    Rank:
    None
    Points:
    923
    Posts:
    6,184
    Joined:
    Oct 4, 2009

    Oct 4, 2009
    6,184
    5,047
    923
    Male
    Database Programmer, Sprint Advocate
    Queens, NY
    I had to do two things,..
    1-Set the Developer settings
    Swipe down from Notifications> Settings> Developers Options
    Scroll down and set all three scales to 0.5x
    (Windows Animation Scale, Transition animations scale and Animator duration scale)

    2-Set the Nova Settings..
    Nova Settings> Look and Feel> SCroll Speed
    Set to Faster than light
    go back and select Animation speed
    set to Faster than light


    TS
     
    thaKing and KOLIO like this.
  17. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    I will have to confirm *exactly* with my wife's N4, but pre-wipe the animation was Samsung Note 4 with no audio (that's what I have to confirm with my wife's N4). Now, I get Samsung that goes through a rainbow-like transition and then the ATT white screen with the ATT song. Never had the ATT white screen or audio.
    Would dev options of 0.5x be better than off? I can change those from off if it matters. I have updated Nova settings per your suggestion.
     
  18. KOLIO

    KOLIO Guest
    Rank:
    None
    Posts:
    0
    Joined:

    I'm not on the stock T-MOBILE ROM anymore,but,I believe my boot animation & accompanying audio was intermittent:

    Sometimes I'd see the T-MOBILE logo & the familiar T-MOBILE Jingle that accompanied it.Other times all I'd see was the SAMSUNG & NOTE4 animation w/o any audio.Thought it was just me & that was before I rooted/ROMMED.
    Didn't give it any thought until now..........

    Anyhoo,back to the NOVA issues,how's things looking now?

    FWIW,I think the best settings for animations are exactly as TwoSpirits stated, .5 for all three settings.

    Setting it to zero just doesn't give a smooth look/feel.
    The .5 settings is pretty much universally recommended in most forums/blogs/etc.. as it seems to be the sweet spot for animations/transitions.
     
    thaKing likes this.
  19. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    The boot animation/audio is quite intrigueing, but I honestly don't care about that. :p I'll be rooted as soon as this g** d****d ATT bootloader issue is resolved!

    I updated all settings as listed above. Modified animation to 0.5x for all. And I still experienced lag time. This frustrated me and I made more observations and tests.

    1. If my phone was locked and when opened I was on my homescreen, the lag was present.
    2. If I unlock my phone and an app was open, the lag was not present.
    I noticed that this morning. So, I got to thinking something has to be going on when I open my phone to the homescreen. I had a couple of widgets and one was a weather widget (weather live). I removed the widget and the lag appears to be gone.


    I'm guessing that opening to the homescreen caused the widget to update time/weather/forecast. When opening to an app, the widget was not updating.


    Keeping my fingers crossed that removing the widget fixed the lag. Whew! Thanks for providing tips to try. Appreciate it!
     
    KOLIO likes this.
  20. LaTuFu

    LaTuFu Android Expert
    Rank:
    None
    Points:
    173
    Posts:
    1,286
    Joined:
    Nov 10, 2009

    Nov 10, 2009
    1,286
    258
    173
    Project Manager
    Virginia
    I know this may sound like exactly the thing you want to avoid, but you may need to do a factory wipe and start over with this.

    I'm sure you know this, but you shouldn't be having this kind of stutter at all with the phone, let alone with Nova.
     
  21. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    Even if removing the widget fixes it? I removed it about an hour ago and have yet to notice any lag.
     
  22. twospirits

    twospirits AF's janitor
    VIP Member
    Rank:
    None
    Points:
    923
    Posts:
    6,184
    Joined:
    Oct 4, 2009

    Oct 4, 2009
    6,184
    5,047
    923
    Male
    Database Programmer, Sprint Advocate
    Queens, NY
    hmmm that weather app wouldn't be the 1Weather one is it? I thought I read somewhere (either here or on xda) that the app causes major lag which is why they recommend uninstalling it.

    I'll see if I can find that thread.

    TS
     
  23. thaKing

    thaKing Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    246
    Joined:
    Aug 3, 2012

    Aug 3, 2012
    246
    25
    53
    Lex Vegas
    No, it's actually called "Weather Live". It's an app that has widgets with it.
     
  24. MLSS

    MLSS Android Expert
    Rank:
    None
    Points:
    413
    Posts:
    2,245
    Joined:
    May 20, 2013

    May 20, 2013
    2,245
    1,486
    413
    Male
    Director of a non profit
    Nelsonville, Ohio
    Are you using the Nova Prime beta?
     
  25. MLSS

    MLSS Android Expert
    Rank:
    None
    Points:
    413
    Posts:
    2,245
    Joined:
    May 20, 2013

    May 20, 2013
    2,245
    1,486
    413
    Male
    Director of a non profit
    Nelsonville, Ohio
    Your issue seems like it has more to do with waking up than with Nova.......

    I think the delay may be happening because your phone is still waking from sleep.

    If you lock your phone and then immediately unlock it does it happen?
     

Samsung Galaxy Note 4

The Samsung Galaxy Note 4 launched in 2014 as the company's flagship phablet. It has a 5.7-inch screen with 2560 x 1440 resolution, 3GB of RAM, and an impressive 16 megapixel camera.

Share This Page

Loading...