1. Are you ready for the Galaxy S20? Here is everything we know so far!

NPS won't find phone on a brand new Spica?

Discussion in 'Android Devices' started by bsnalex, Jun 4, 2010.

  1. bsnalex

    bsnalex Lurker
    Thread Starter

    I've just got the Spica i5700. It's my first android phone and i thought i was doing everything right. I downloaded NPS, as it is newer that Kies and Kies didn't work well on my computer anyway.

    So I hooked my phone in via USB. It "found" the microSD (showed an E:\ on the top right) however, when I tried to explore it it said "please insert a disc into E:\". Windows explorer as well is asking me to insert a disc into drive E:\

    So what this effectively means is I can't move files or contacts back and forth on the phone, nor can I update the firmware. BTW, can anyone tell me if Spica runs anything higher than Android 2.1? I want to update to 2.5 because apparently flash is only supported on 2.5 and up.

    Please help, I really like this phone and it's the only thing keeping me from enjoying it.

    Thanks in advance :)

  2. bsnalex

    bsnalex Lurker
    Thread Starter

    Anyone? Please?
  3. Rogdor

    Rogdor Newbie

    Two possibilities:

    A. Is your phone in download mode? If you're updating firmware, it needs to be in download mode rather than USB storage mode. To put your Spica into download mode, power it down, then hold: Volume Down + Camera + Power Button.

    B. You may have the wrong USB drivers (even tho USB Storage tends to work regardless). You might want to try a different version of NPS. Some versions come with the USB drivers for the i5700 (Spica) for different regions. Try searching around to find NPS v1.5 since I think that's worked for most people. Uninstall your current drivers first before the new install.

    And finally, Android is currently at 2.1. There are experimental versions of 2.2 but a full 2.2 release hasn't been finalized for any phone yet (Nexus One has the closest beta). Official releases of 2.2 will include Flash (some phones have Flash lite meanwhile), expected in about a month or so. There is no 2.5 yet, 2.3 isn't even expected until fall this year.

    AFAIK I know, there's no easy-cooked 2.2 Firmware for the Spica yet-- and it will probably be months before you see one. Who knows maybe someone will manage it without waiting to see if Samsung does it. So far, I think we're all depending on mods derived from the Samsung beta firmwares.

    I have to say, don't expect to run Flash on the Spica. I love my Spica personally, but it's probably underpowered for Flash, which has reportedly run slowly on even the faster phones.
  4. bsnalex

    bsnalex Lurker
    Thread Starter

    Thanks, Rog, I'll give those a try this evening (at work now so can't really). I think it probably said Android 2.2 but the text was so small i may have read 2.5 accidentally.

    If flash doesn't work well, I wonder what the prospect of using Skyfire is.

    This download mode, will i need to toggle between it everytime I want to connect to the computer?
  5. bsnalex

    bsnalex Lurker
    Thread Starter

    Problem solved. It was a PICNIC <<blush>>
  6. starborne

    starborne Lurker

    May I know what option you did? I just bought Spica with 2.1 and installed the kies that came along the box. It also did not recognize the phone just the cd card.

    Did you use NPS 1.5? There is now an NPS 7.

    Thanks in advance.

Samsung Galaxy Spica Forum

The Samsung Galaxy Spica release date was November 2009. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1500mAh battery.

November 2009
Release Date

Share This Page