1. Are you ready for the Galaxy S20? Here is everything we know so far!

NV Flash -Full factory reset

Discussion in 'Android Devices' started by xmr405o, Jan 9, 2011.

  1. xmr405o

    xmr405o Android Expert
    Thread Starter

    This is the "when all else fails method". I learned this from Roebeet and Sprdtyf350 over at XDA. I'm basically transferring their instructions over here. So if you want to find the thread of reference, google NVflash full restore.

    Here's another guide to NVflash

    NVFLASH (thanks to goodintentions from XDA)

    Files you'll need:

    You will need to download some files. Bekit provided these in his drop box. Here's the link..

    Dropbox - nvflash_gtablet - Online backup, file sync, and sharing made easy.

    Before doing anything with these files, create a folder on your desktop. I called mine NVflash.

    From the link above, I downloaded these two files... "nvflash_windows_20100500.zip" and ""nvflash_gtablet_2010110500.zip".

    First extract the windows zip files into that folder you created. You are going to do the same with the gtablet zip. However, the gtablet zip has the files in a folder so you're going to want to take all the files and manually transfer it to that newly created folder on your desktop.

    For windows, you will need to install additional drivers so your computer will recognize your gtablet when it's in APX mode. You can find it here.

    xda-developers - View Single Post - [STICKY][ROM] nvflash FULL restore, using bekit's original image (Instructions)

    APX mode:

    Now put your Gtablet in APX mode by turning off the device then turning it back on by holding the volume - and the power button. The viewsonic screen should appear and your tablet should go blank as if it turned back off.

    Now plug your gtablet into your computer using a USB cable
    Your computer should recognize the new APX device and prompt you to install the drivers.

    Driver Installation: (Windows only)

    I chose to Install from a list or specific location.
    I then checked Include this location
    Find the file location where you installed the USB drivers


    With your tablet still connected, go to the folder you created where you put all those files. Find the batch file nv_flash bat and double click and you should see your device starting to flash.

    It'll reboot and you should be back to stock.

    After that, you can start all over and flash clockwork and ROM if you like.

    Edit: 1/31/11

    Found this post in XDA and it's really helpful. It tells you how to flash Clockwork Mod automatically while performing a NVflash. With this extra step, you can revive your gtablet and have clockwork recovery ready to go so you can reflash a custom ROM. rcgabriel is a regular at the gtablet forum in xda and he is super helpful.


  2. jsteinerats

    jsteinerats Newbie

    :(I am fairly new to all of this. I tried following these instructions. I can't get my windows 7 netbook to recognize the tablet in APX. Any workds of advise:thinking:
  3. xmr405o

    xmr405o Android Expert
    Thread Starter

    Did you put the G-tablet in APX mode? You should do that prior to connecting it to your PC. So you need to turn off your device, and turn it back on by holding down the power button and the volume - (down). You should see the viewsonic screen come on then turn back off. That's normal. After you see the black screen, plug your device into the PC. Watch your PC, to the bottom right you should see a pop up saying APX. On my XP PC, a dialog box pops up saying that a new USB device and it give me the option to insert a disk or browse the PC to install the drivers manually.

    Then follow the rest of the instructions to install the appropriate drivers.

    Edit: I found this video in Youtube. I couldn't view it because I'm at work and they block youtube. But maybe this might help.

  4. vectorman

    vectorman Newbie

    Just to clarify: do you mean that all the files from Windows.zip and gtablet.zip are mixed together in the same folder, with no separating sub-folders?
  5. xmr405o

    xmr405o Android Expert
    Thread Starter

  6. vectorman

    vectorman Newbie

    Thanks for the clarification!
  7. xmr405o

    xmr405o Android Expert
    Thread Starter

    I think the nvflash_gtablet zip had the contents in a folder. So after you extract that zip, open the folder and copy the contents into the same folder you extracted the nvflash_windows files.
  8. vectorman

    vectorman Newbie

    Yeah, that's what I did, so all the files are in there together like one big happy family!

    I don't have a need for nvflash yet, but I want to have it waiting in the wings just in case. This is my first exposure to Android, to rooting and modding, and I'll probably mess something up at some point. This will be my fail-safe. So far, I've been able to flash the TnTLite Enhancement Pack, TnTLite 4.1 and currently, VEGAn 5.1. So far everything has gone without problems, thanks to the dedicated devs and helpful members such as you. I appreciate all that you do.
  9. xmr405o

    xmr405o Android Expert
    Thread Starter

    You're a smart person to have this fail safe ready because it looks like the ROM development is starting to pick up for the gtablet. The more ROM flashing the dirtier our file systems can get. :p
  10. jsteinerats

    jsteinerats Newbie

    So, I finally got it to flash. Now, any time I turn it off, the grab will not turn back on. I tried a factory reset, but, it does not turn back on or, boot in to recovery. Help! I have a couple days before I get my receipt to try and fix:thinking:

  11. xmr405o

    xmr405o Android Expert
    Thread Starter

    Might be a stupid question but is the gtab charged? I'm also confused when you say "any time you turn it off, the gtab will not turn back on"? Does that mean the gtab is able to power on but shuts off when it goes to sleep? Regarding recovery, remember once you perform a nvflash, your gtab goes back to its original state meaning you do not have a custom recovery like clockwork.
    So try holding your power button for 15 seconds without touching the volume controls and see if your gtab turns on. Your gtab might still be in APX mode.
  12. jsteinerats

    jsteinerats Newbie

    It is on and functioning after nvflash. I was doing a factory reset, because the superuser app was still there. It will not reboot. I will completely recharge it and try it tomorrow. Thanks for the info :eek:
  13. jsteinerats

    jsteinerats Newbie

    Held the power button for upwards of a minute. No luck. I am at a loss. Could it be a bad file somewhere?:mad:
  14. xmr405o

    xmr405o Android Expert
    Thread Starter

    Ok, the initial firmware had issues where the device would not power up. One suggestion is to let the battery run completely out then recharge. Check this out.

    [Q] g tab will not power up - xda-developers
  15. jsteinerats

    jsteinerats Newbie

    Just a quick update. I gave up and took my Gtab back to sears. Couldn't find the time to play with it. Told the manager I just wanted a trade. He told me I was outside the 30 day return, but, he would honer it since it was a gift. So, got a ne gtab to start from scratch. At least, I know what NOT to do.

    Thanks to the community for all the suggestions:D
  16. calsnook

    calsnook Newbie

    Hey xmr405o, I also emailed solid orange, I need to return the Gtab, it doesn't work for me re;word processing.
    How do I get back to stock, (good enought to pass a bootup on return). You guys have been great!
  17. xmr405o

    xmr405o Android Expert
    Thread Starter

    Awww that's too bad. Yeah, word processing on a tablet isn't very efficient. Anyways...this should be easy for you since everything needs to be done on a PC.

    Did you download the files that I have on my original post? The files are located on Bekit's dropbox. There's a link. There's two files you need to download. Prior to downloading, create a folder where you'll extract these files into. Doesn't matter what you call it but I called mine NVflash.

    Both of these files need to be on the same folder. They are all files.

    Try to follow my instructions and let me know if you have any questions.
  18. cranky_dan

    cranky_dan Well-Known Member

    It seems the file that is referenced here is not posted any longer. Does anyone have it? I have just bought a boot-looping viewsonic g-tab that needs love.

    cranky Dan
  19. xmr405o

    xmr405o Android Expert
    Thread Starter

    Edit: Before you NVflash, did you check to see if your gtab already has Clockwork installed? I'm not sure where you got your gtab, so if it's used, maybe clockwork is already on your device. Repartitioning your internal SD card might get you out of bootloop without having to NVflash.

    Technically you only need the Drivers and blades from XDA posted it here. It appears you don't need to install the entire SDK.

    xda-developers - View Single Post - [STICKY][ROM] nvflash FULL restore, using bekit's original image (Instructions)
    cranky_dan likes this.
  20. cranky_dan

    cranky_dan Well-Known Member

    I have not gotten the gtab yet. I'm expecting it in two or three more days. And after all the positive remarks I've read *almost everywhere* about a rooted, rom-modded gtab, I am totally stoked to get it happening.

    I've also had an Eken M001 for the last year. It's underpowered, has a lousy touchscreen (resistive), doesn't do video, and has Android 1.6.

    I am SO ready to play...
    Thanks for your 1) post, 2) help, xmr405o.

    Oh and BTW, your sig kills me. I work with a buncha people that have android devices and one lady with iPhone & iPad. I'm thinking of using your sig as mine when I respond to her emails. XD

    xmr405o likes this.
  21. xmr405o

    xmr405o Android Expert
    Thread Starter

    Np problem,cranky! :). My wife doesn't get my sig. :( :pHaha.

    Also....be careful when using NVflash. :D
  22. cranky_dan

    cranky_dan Well-Known Member

    Got the gtab. No, It did not have clockwork backup and it did need the memory repartitioned. Repartitioning was the key to fixing its bad behavior probs.

    Now running TNT lite 5 and clockwork backup.

    Damn, it's fast.

    Thanks again xmr405o!

    Dan :D
  23. bcurran3

    bcurran3 Lurker

    So I did all this and bricked my Gtab. I copied on CW .08 first and initialized it. Then did the above instructions and I can not get the tab to power on. It is fully charged. I did this yesterday and then just did it again. Office Dept is going to look at my VERY funny when I return the 2nd one. I'd prefer to avoid the embarrassment and just make this one work. Can anyone help?
  24. xmr405o

    xmr405o Android Expert
    Thread Starter

    Ok, you might be still in APX mode and don't know it. Try holding down the power button only for 15-20 seconds to see if your tablet powers up.

    What did you exactly copy? Just the recovery.img file, right? Did you go into the gtablet.cfg file and edit it to say recovery.img rather than partition9?
  25. cranky_dan

    cranky_dan Well-Known Member

    xmr405o is right. I bought a bricked G-tablet on ebay, and brought it back to life with the nvflash thread. But it wasn't all roses.

    It took me about two and a half hours. I kept 1) not knowing what to expect, 2)forgetting a step, and 3) inducing typos.

    You *can* do it. Good luck.

Share This Page