1. Are you ready for the Galaxy S20? Here is everything we know so far!

OFFICIAL CWM 6.0.2.7 and CWM Touch

Discussion in 'Android Devices' started by junkie2100, Dec 29, 2012.

  1. junkie2100

    junkie2100 Android Expert
    Thread Starter

    USE AT YOUR OWN RISK, NO ONE WILL BE HELD RESPONSIBLE FOR DAMAGE TO YOUR PHONE BUT YOU!!

    Unleashed PrePaids - Unleash the Power of Your Prepaid Phone!!! - Warp Sequent

    OFFICIAL CWM 6.0.2.7 and CWM Touch

    Also available on ROM Manager

    INSTALLATION
    rom manager now has it in their database, so that is the new auto install method
    otherwise
    make sure you have the zte drivers installed, the ones linked to below
    make sure the phone is in usb debugging mode and plugged in
    you will also need to get adb and fastboot
    put the cwm img file in the same place as you put adb and fastboot
    then open up command prompt and do a CD command to the directory they are in
    for example if theyre in c:\androidstuff\clockworkmod the command would be
    cd
    c:\androidstuff\clockworkmod

    this cwm can be installed using a regular fastboot method(this is what the installer uses)
    adb reboot bootloader
    fastboot flash recovery (name of the img file)
    fastboot reboot

    or the DD method(aka the adb method)
    adb push (name of the image file) /sdcard/cwm.img
    adb shell
    su
    dd if=/sdcard/cwm.img
    of=/dev/block/mmcblk0p13

    but if you dont know what any of this is i recommend you use the autoinstaller method

    CREDITS
    superr
    (did the compiling and made this all possible)
    shinru2004 (helped find the nasty partition trick zte played on us)
    playfulgod (provided the initial source to start from, and got it official with a touch variation)
    robertech (helped debug the bash script for my auto installer)

    DOWNLOADS
    CWM
    CWM TOUCH


    AUTO INSTALL
    NEW Auto Installer with Touch and Stock options for Windows, Mac, and Linux
    https://www.dropbox.com/s/kulqj5d6f6ij5my/CWM_installer.zip

    yes, its just that simple now, but we would PREFER you learn to do it yourself ;)

    RETURN TO STOCK
    here is the stock recovery for all those interested
    https://www.dropbox.com/s/qu6iti9jn4hl7kw/stockrecovery.img
    same method for installation as the cwm


    CHANGELOG
    2b
    fixed the data and cache partition mount points




    MAKE SURE YOU INSTALL THE ZTE OFFICIAL DRIVERS FROM ZTEUSA.COM!!!
    FASTBOOT WILL NOT WORK WITH PDANET DRIVERS


    http://166.78.74.38/media/wysiwyg/ZTE-WarpSequent/ZTE_Warp_Sequent_USB_Driver_EXE_-_4.28MB_.zip

    P.S. dont worry, i just now figured out how to change thread names it hasnt changed since the second beta release
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Robertech

    Robertech Android Enthusiast

    flashing this now :D


    works great, great work guys!
     
  3. Guspeed

    Guspeed Android Expert

    Wow, you guys are awesome!!!
    What a night last night for you guys!!!

    Thank you so much for your hard work and love for the ZTE Sequent ;)
     
  4. boricuakiller

    boricuakiller Android Expert

    ok so it work im asking cause i never root but to get this to work whats the first step the second and the third sorry for asking but someone can show me some light or make a video or something
     
  5. benjiu3

    benjiu3 Member

    how would you guys recommend i install this? using the fastboot method?
     
  6. Guspeed

    Guspeed Android Expert

    Yep, fastboot!
     
  7. benjiu3

    benjiu3 Member

    alright cool. but what are the button combinations to boot into fastboot mode??
     
  8. Guspeed

    Guspeed Android Expert

    There's not a button combination...
    Leave your phone on, connect it to your PC and go to fastboot thru adb.

    "adb reboot bootlader"
     
  9. SuperR

    SuperR Android Expert
    Recognized Developer

    Ok, so I am running Ubuntu Linux and I am trying to flash the cwm recovery Junkie2100 and I built last night. I can get the phone into fastboot no problem. Fastboot detects the device and I can even issue fastboot reboot-bootloader with success. When I issue fastboot flash recovery recover.img it says "sending 'recovery' (6164 KB)..." forever and does not complete. If I close the terminal and pull battery, the phone reboots with no issues and the stock recovery is still intact. Any ideas?
     
  10. junkie2100

    junkie2100 Android Expert
    Thread Starter

    ive run into issues with fastboot mode myself. there is another way though
    adb push (imagefile.img) /sdcard/cwm.img
    adb shell
    su
    dd if=/sdcard/cwm.img of=/dev/block/mmcblk0p13
    reboot recovery

    also gotta make sure you update your rules file in linux, adb while the phone is running normally has one set of vendor and device codes, but fastboot mode has another set so you have to do the lsusb again and set it back up, then you gotta do it again for adb while in recovery. it became such a pain in my ass i actually went and wrote a program to do it automatically which i can upload if you like but it was built for ubuntu 11.04 so i cant promise it will be compatible with other versions
     
    SuperR likes this.
  11. junkie2100

    junkie2100 Android Expert
    Thread Starter

    so has anyone tested the sdcard partitioning yet? or anything i havent already mentioned as working for that matter?
     
  12. junkie2100

    junkie2100 Android Expert
    Thread Starter

    oh and whenever you get the chance you should upload our device tree superr that way anyone who wants to work on a cyanogenmod can use it to start from. that is of course unless we dont end up getting on another mission and doing it ourselves lol
     
  13. SuperR

    SuperR Android Expert
    Recognized Developer

    I will try out your program if you don't mind, however I did not set up any rules for adb to begin with. It seems to be working fine. But that means I have no idea how to do it for the fastboot part.

    I will get the device tree uploaded asap. Should it go in our new thread entitled cm10 development :)
     
  14. SuperR

    SuperR Android Expert
    Recognized Developer

    I will try your adb method, thanks for the tip

    I will as soon as I get it flashed :)
     
  15. junkie2100

    junkie2100 Android Expert
    Thread Starter

    hmm... well looks like i cant share my program with you, its kinda trapped in my old ubuntu files, i had set it up inside windows on my old computer which fried the other day so untill i can break open these .disk files i cant access any of that data on this new one i got. ill work on that tho if it comes to it, but yea if it just worked off the bat with adb and everything you should be fine honestly, just make sure you always sudo, and if you sudo fastboot devices see if it gives you question marks or an actual serial number and device name
     
  16. junkie2100

    junkie2100 Android Expert
    Thread Starter

    fuggin wubi. locking my stuff up, im downloading ext2read now which supposedly supports opening those files gimme a sec
     
  17. junkie2100

    junkie2100 Android Expert
    Thread Starter

    https://www.dropbox.com/s/ryk3c8s5lepxv46/android_driver_installer.sh
    there you go, simple menu interface to install android drivers in linux
    got really bored and pissed at the manual installation method one day...
    keep in mind it is built for ubuntu 11.04 so it is not guaranteed to work on any other distro
    it will have to be set as executable and dont with a sudo command


    oh and it will see all devices made by known android vendors, for instance it sees my dell keyboard, so that is why it pops up the menu for you, you should be able to figure out which one it is on the list, and it should work on pretty much any android device, i decided not to just make it work on the one since i have 2 samsungs, a zte, and an htc, i programmed every vendor i found on the internet into the script

    and to modify it for your distro you can look up the rule file names and entries on google compatable with your version and then edit accordingly, the important part that you dont want to touch is the variables and menu functions, the
    51-android.rules
    99-android.rules
    and
    echo "SUBSYSTEM='usb', SYSFS{idVendor}='[$vendorid]', MODE='0666'" >> /etc/udev/rules.d/51-android.rules
    echo "SUBSYSTEM='usb',ATTR{idVendor}='[$vendorid]',ATTR{idProduct}='[$deviceid]',SYMLINK+='android_adb'" >> /etc/udev/rules.d/51-android.rules
    echo "SUBSYSTEM='usb',ATTR{idVendor}='[$vendorid]',ATTR{idProduct}='[$deviceid]',SYMLINK+='android_fastboot'" >> /etc/udev/rules.d/51-android.rules

    those are all distro specific so you can replace that as necessary just remember that where you put the vendor and device id in the entries you use $vendorid and $deviceid in their place to enable the automation and dont remove
    >> /etc/udev/rules.d/51-android.rules
    from any of those just modify it to put it in the correct rules file
     
  18. Robertech

    Robertech Android Enthusiast

    sudo fastboot flash recovery <file location>


    works every time
    ubuntu 12.10 ;)

    (without the sudo command mine would hang at "waiting for device")
     
  19. junkie2100

    junkie2100 Android Expert
    Thread Starter

    i was using an older version of ubuntu so i had to manually create my rules file, i dunno how the new ones do it i havent tried yet since i upgraded my pc and put ubuntu 12 on there, i just know that my old computer had alot of issues with fastboot mode because it had usb 1.1 only, that doesnt give the bootloader enough power to function properly
     
  20. SuperR

    SuperR Android Expert
    Recognized Developer

    Well, I was using sudo and it just gets stuck at "sending 'recovery' (6164 KB)...". Without sudo, you are right Robertech, it hangs on Waiting for device.

    Thank you for the script. I will look into it after a while. For now, I am going to try the adb method to see if it works for me :) Thanks everyone!
     
  21. SuperR

    SuperR Android Expert
    Recognized Developer

    on ubuntu 12.10 fyi
     
  22. SuperR

    SuperR Android Expert
    Recognized Developer

  23. junkie2100

    junkie2100 Android Expert
    Thread Starter

    as far as i can tell from a quick google search, the script should work as is in ubuntu 12.10
    if not then ill see what i can do but make sure to only run it when the phone ISNT connecting properly, if you use it when the phone IS connected properly the thing might mess up your configuration, and you have to be in the mode you want to fix connection for obviously, you cant fix a fastboot connection while in adb mode
     
  24. SuperR

    SuperR Android Expert
    Recognized Developer

    just tried using the recovery installer. It said it did it, but then when I booted into recovery it was stock :(
     
  25. junkie2100

    junkie2100 Android Expert
    Thread Starter

    i wouldnt necessarily use that myself, depending on how it functions it may flash the wrong partition. see if you can get the adb method to work
     

ZTE Warp Sequent Forum

The ZTE Warp Sequent release date was September 2012. Features and Specs include a 4.3" inch screen, 5MP camera, 768GB RAM, Snapdragon S2 processor, and 1650mAh battery.

September 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...