1. Are you ready for the Galaxy S20? Here is everything we know so far!

OK google everywhere

Discussion in 'Android Devices' started by Bobtheg2015, Feb 1, 2016.

  1. Bobtheg2015

    Bobtheg2015 Lurker
    Thread Starter

    How do I enable OK google everywhere on my moto g 2015. I think Motorola disabled it on purpose. My language is English u.s. and I just can't see the options.
    Screenshot of my options:
    http://i.stack.imgur.com/kYETX.png
     



    1. Download the Forums for Android™ app!


      Download

       
  2. acejavelin

    acejavelin Android Expert

    Are you in Settings->Google->Search&Now->Voice->"OK Google" detection ?

    Because mine looks WAY different than that... On XT1540 US with Marshmallow OTA.

    [​IMG]
     
  3. Bobtheg2015

    Bobtheg2015 Lurker
    Thread Starter

    I have the8/1gb model (only one sold in canada) xt1540. And yes that's the settings I went through to get there. Please help if you know the fix!
    I also have android 6.0

     
  4. acejavelin

    acejavelin Android Expert

    I don't know, but even Google's discussion forums agree it should work (it isn't something Motorola could just turn off even if they wanted too, easily at least)... I have the 2GB RAM version, it seems to work in every 2GB version, but lots of users have reported issues with the 1GB Moto G and other 1GB RAM phones (not just Moto's)...

    Have you gone to https://www.google.com/settings/accounthistory/audio and made sure to turn on voice searches and commands?
     
  5. tube517

    tube517 Android Expert

    I have a different phone but I have the same screen as the OP. I have a rooted LG G Stylo (Metropcs) running 5.1.1. Katana ROM
     
  6. Bobtheg2015

    Bobtheg2015 Lurker
    Thread Starter

    I haven't rooted my phone. And I checked multiple times that its turned on.
     
  7. tube517

    tube517 Android Expert

    I'm not sure why our screen doesn't have the other options. I've had it in my previous phone. Are you using the stock launcher? I'm using Nova and I don't think that affects it.
     
  8. acejavelin

    acejavelin Android Expert

    I am stock as well, just have the 2GB version... Sorry, but I don't know why it doesn't work or the fix. I would suggest opening a thread in the official Google Product Support and looking here: https://support.google.com/websearch/answer/6031948
     
  9. bcrichster

    bcrichster ROMinator
    Moderator

    Try updating the Goggle app.. It worked for me when changing from one OS to the other
     
  10. tube517

    tube517 Android Expert

    I've updated, uninstalled then reinstalled fresh. Force stopped, rebooted phone. Cleared cache and data. Cleared my cache partition, nothing.
     
  11. bcrichster

    bcrichster ROMinator
    Moderator

    Oh wow.. Do you have a custom recovery & can you flash Gapps packages?
     
  12. tube517

    tube517 Android Expert

    Yes, I have TWRP. Not sure if I can flash GAPPS packages. Never tried on a stock based ROM
     
  13. bcrichster

    bcrichster ROMinator
    Moderator

    It's certainly worth a try but remember to make a backup first. Get the appropriate Gapps for your OS on ur SD then reboot into recovery and wipe both caches. Next you install the Gapps.zip and reboot system
     
  14. Blair1966

    Blair1966 Lurker

    Have you had any luck with this? I am having the exact same problem and went through the exact same procedures as you with Motorola tech support. Now I've done a factory reset and have to set everything up again, even though it didn't solve the problem. I went back to where I bought the phone and the girl happened to have a 3rd Gen and a 1st Gen and pulled up the OK Google settings and she noticed the same thing. She hadn't noticed it before.
     
  15. tube517

    tube517 Android Expert

    No luck. My phone still does not have the complete settings
     
  16. flubberdubb

    flubberdubb Lurker

    This happened to the galaxy s6 awhile back. Google or Samsung removed the features but then they were readded maybe similar case here
     

Motorola Moto G (3rd Gen) Forum

The Motorola Moto G (3rd Gen) release date is unknown..Features and specs are not yet known.

unknown.
Release Date
0
Reviews
Loading...

Share This Page

Loading...