1. Are you ready for the Galaxy S20? Here is everything we know so far!

OnePlus One - charging problem

Discussion in 'Android Help' started by Wanitto, Mar 7, 2016.

  1. Wanitto

    Wanitto Newbie
    Thread Starter

    Dear experts,

    I have a OnePlus One currently running Android 5.1.1 and CyanogenMod 13. I am having problems with charging the phone. I will try to explain as much of the problem as possible, please do excuse any incorrect or inaccurate use of language.

    HISTORY

    Was running Oxygen OS, using the stock charger and cable, and started having charging issues: (1) charging would be incredibly slow, (2) charging would connect/disconnect while plugged in, (3) battery would not last long - but that is the least of my worries.

    ATTEMPTED FIXES

    Changed cables and chargers multiple times in different combinations - this would fix the issue for a couple days until it came back (which is the weirdest thing). I bought the expensive Belkin charger and cable - issue persisted.

    I have also changed the battery to a new one with absolutely no difference - the original battery seems to work just as well, or as badly, as the new one.

    I have wiped my phone and installed CyanogenMod 13. This fixed the connecting/disconnecting issue (2). But the charging speed is still incredibly slow.

    SYMPTOMS

    I know that this OnePlus One came with a charger capable of dispensing 2.1A. I downloaded Ampere (presumably an app which tells you how much the phone is actually receiving from the charger), and tested it on different charger/cable combinations. The minimum on any of them is around 160mA, and the maximum on any of them is 380mA. The charger/cable combination which seems to work best is the belkin cable with the stock Oneplus charger.

    QUESTION

    In any case, considering the phone should be charging at a maximum of 2.1A, th 380mA is ridiculous.

    Is it a software issue with a software fix? If so, what do I need to do? (I'm a pretty intermediate user, if I don't understand something, I'll google it)

    Or is it a hardware issue? Possibly the charging port on the phone? If so, what do I need to change? (as long as it's googlable, i'll probably manage with technical stuff)

    THANKS FOR THE HELP

    Apparently, I need to specify if phone is rooted. It's running CyanogenMod 13, so it can be, and it also can not be. Flashing SuperSU for permanent rooting didn't work. I have TWRP Recovery installed as well (which is how I installed CM 13). I have absolutely no issues with 'flashing' another 'rom' as I havent yet installed anything on it.
     


    #1 Wanitto, Mar 7, 2016
    Last edited: Mar 7, 2016
  2. Well we can only guess from out here on the internet, but it could possibly be a problem with the port. Sometimes this is as simple as dirt or other foreign matter getting into the port and affecting the contacts, with this in mind you can try blasting the port with a canned-air duster to remove any dirt/lint/dust. If that doesn't help try some contact cleaner spray (available at electronics stores).
    If the problem persists after cleaning the port there may be an internal hardware issue. Unfortunately OnePlus does not have a good track record with their customer service and repairs so sending it in may not be a great idea.
     
  3. Wanitto

    Wanitto Newbie
    Thread Starter

    Alright. Didn't think of that, thanks. I've cleaned it. As far as I can tell, nothing has changed. Ampere is still displaying the low charging current. If it was a cleaning issue, why would flashing CyanogenMod fix one of the issues (the disconnecting/reconnecting issue)?
     
  4. Probably not, although it could just be an unrelated coincidence. But anyway I was just suggesting something simple to try, too bad that didn't help.
    Since you've already done a wipe and OS reload we know a reset isn't going to help, so I'm afraid that does point more towards a hardware problem. Given the potential pitfalls of sending it off to OnePlus for diagnosis and repair it may just be time to look at a new phone.
     
  5. Wanitto

    Wanitto Newbie
    Thread Starter

    :(
    Sad times when a one-year old phone is worthless.
    If it is indeed a hardware issue, might it be something replaceable, such as the charging port? (of course, I understand the risks)
     
  6. Sure that's possible, although of course no way to tell without real diagnosis (or part-swapping).
    I don't know how user-serviceable the OnePlus is or if parts are available, you should be able to find out.
    Try checking in with the OnePlusOne forum here, maybe you can get some more specific assistance-
    http://androidforums.com/forums/oneplus-one.2570/
     
  7. Wanitto

    Wanitto Newbie
    Thread Starter

    Cool. Thank you. The charging port is moderately easy to replace and cheap and available to buy online - I've already considered this option, but thought it was best to make sure there wasn't an alternative fix.

    I guess this is "solved ", unless someone else out there has any suggestions?
     
  8. Jfalls63

    Jfalls63 Android Expert

    Could it be a issue with the kernel in the custom ROM? You could flash back to stock and see if charging issue is still present.
     
  9. mikedt

    mikedt 你好

    AFAIK the OnePlus One does NOT have fast charging capabilities, that was actually one of the criticisms of it in reviews. So if you're expecting to see 2.1A, not going to happen. Frankly 380mA sounds about right for say an 6-10 hour overnight charge. The OnePlus One's very close cousin, Oppo Find 7 does have fast charging, however that's proprietary to Oppo phones and chargers only, known as VOOC.
     
  10. Even without fast charging it should do better than that with a proper 2A charger. My S5 with standard USB2 will charge at to 11-1200ma and I'd think the OP1 should be able to do the same.
     
  11. Wanitto

    Wanitto Newbie
    Thread Starter

    Thanks for the replies.

    Regarding flashing back to the stock ROM. Which one would that be? The phone shipped with some version of CyanogenMod, and if I understand correctly OxygenOS is what OnePlus now ships its phones with (at least the One). OxygenOS is probably the closest to 'stock' as can get, I think, and that's where the issues began.

    As for fast charging: true. The phone was never really fast, but used to get to 100% in a couple hours. It's not the 'Fast Charging' thing. I could, for example, switch the phone off and charge it for 15 minutes and that would give me at least an hour or two of extra battery life. To get an hour or two now, I have to do the same with phone off, and then keep it plugged in while i use it.

    Unfortunately I hadn't tested the charging current when the phone was new. I'll research and come back with update.
     
  12. DivenParker

    DivenParker Lurker

    Nice. Thank you. The phone was never really fast, but used to get to 100% in a couple hours.
     
  13. Wanitto

    Wanitto Newbie
    Thread Starter

    DivenParker, have you been having the same issue?
     
  14. nafiz

    nafiz Lurker

    Hey There, Have u been managed to solve the issues. I am here suffering the same !!
     
  15. Wanitto

    Wanitto Newbie
    Thread Starter

    No sir. I haven't yet had the guts to change the hardware, but I'm still having the problem - while the phone still generally works really well.
    Do try some of the things above though like cleaning the port, factory reset etc.

    Latest thing I did was to install Boeffla-kernel through which one can force change the charging current (from 300mA to 2000mA for example). Sounded promising... I feel like it helps a tiny bit, but I still have major issues.

    Please post any of your attempted fixes on here! I'm not giving up on this phone yet.
     
  16. nafiz

    nafiz Lurker

    Just buy a new oneplus one cable... case dismissed!!
     
  17. Wanitto

    Wanitto Newbie
    Thread Starter

    So that fixed it for you did it?
     
  18. Ibrahim Ratul

    Ibrahim Ratul Lurker

    I'm suffering the same problem too...were you able to solve the problem?
     
  19. Ibrahim Ratul

    Ibrahim Ratul Lurker

     
  20. Ibrahim Ratul

    Ibrahim Ratul Lurker

    I'm also suffering from the same problem...were you able to solve your problem
     
  21. Kevo345

    Kevo345 Lurker

    I have been having a similar issue. I have to plug in the charger multiple times until it starts charging. If by any chance the cable is removed, I have to repeat the process.
     
  22. Ibrahim Ratul

    Ibrahim Ratul Lurker

    Well, I bought a new data cable...and it worked for me :| download the app ampere and chq before buying the cable...if it reaches 700-700+ then the cable is all ok
     
Loading...

Share This Page

Loading...