1. Are you ready for the Galaxy S20? Here is everything we know so far!

OpenGL Error upon firing Emulator

Discussion in 'Android Development' started by lupin92, Sep 25, 2019.

  1. lupin92

    lupin92 Lurker
    Thread Starter

    Hey whatsup guys!

    I opened android studio this morning and was notified about a 271MB update for the emulator, i installed the update and i'm receiving the following error since then when i fire the emulator:

    Code (Text):
    1.  
    2. 9:43 PM   Emulator: Warning: QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled ((null):0, (null))
    3. 9:43 PM   Emulator: WARNING: change of renderer detected.
    4. 9:43 PM   Emulator: checkValid: hw configs not eq
    5.  

    I'm running mx-linux and my laptop has hybrid GPUs.(intel + Nvidia GTX 760M)

    things i've tried so far and had no results:
    1 - reinstalling the emulator.
    2 - tried to run emulator via terminal with both GPUs.

    I gotta mention that I have run emulator before this update on this Os and laptop without any problems.

    any idea why that happens and how can i solve it?
    thanks in advance.
     


    #1 lupin92, Sep 25, 2019
    Last edited: Sep 25, 2019

    1. Download the Forums for Android™ app!


      Download

       
  2. lupin92

    lupin92 Lurker
    Thread Starter

Loading...

Share This Page

Loading...