1. Download our Official Android App: Forums for Android!

General OpenGL working on Galaxy (II5)

Discussion in 'Android Devices' started by Pieter, Nov 6, 2009.

  1. giladgaron

    giladgaron Member
    16

    Sep 17, 2009
    40
    1
    16
    Update:
    After removing the backup libhgl.so file completely, mounting/remounting the system/lib folder and rebooting my phone,
    the 3D acceleration works!

    Cool.
     

    Advertisement

  2. spottyelephant

    spottyelephant Android Enthusiast
    63

    Jul 31, 2009
    550
    17
    63
    Im going to do this as soon as i get home from work, but first can i please just confirm the exact steps. Im petrified of corrupting something in my phone.

    - Have phone on and connect usb
    - Ensure debugging mode is ticked in settings, but do NOT mount the phone in the usual manner by pulling down the top bar and tapping "select to copy/paste files"
    - Open adb.exe and enter these two commands, and these two only:
    adb remount
    adb push [location of file] /system/lib/libhgl.so
    - Close adb.exe, disconnect usb, reboot phone.

    It's the second step im a bit confused about; whether to have the phone mounted or not before adb remount.
     
  3. pasxal

    pasxal Member
    15

    Nov 2, 2009
    47
    0
    15
    If u have problems with adb you can paste the file in the location using a file browser. I used root explorer.
     
  4. Rastaman-FB

    Rastaman-FB Android Expert
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    did you remount with ADB?
     
  5. Rastaman-FB

    Rastaman-FB Android Expert
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    dont mount the phone

    put the file in the tools folder
    do
    adb remount
    adb push libhgl.so /system/lib/libhgl.so
     
  6. giladgaron

    giladgaron Member
    16

    Sep 17, 2009
    40
    1
    16
    nope, I remounted with Root Explorer. the whole process was ADB free.
     
  7. Rastaman-FB

    Rastaman-FB Android Expert
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    didnt know you could remount with that. will have to check it out

    well done in getting it sorted though, so i guess the missing link was the remounting
     
  8. spottyelephant

    spottyelephant Android Enthusiast
    63

    Jul 31, 2009
    550
    17
    63
    It works :D:D:D

    Time to finally play speedforge which i bought the day it came out and have been looking longingly at its icon since!!
     
  9. danimar

    danimar Member
    16

    Sep 26, 2009
    31
    1
    16
    works like a charm through SU File Browser's terminal too, I was lazy to connect the phone to the computer :D

    Thank you very much for the tip!!
     
  10. Skin1980

    Skin1980 Newbie
    15

    Nov 25, 2009
    13
    0
    15
    i'm sure you know it..... with the new recovery from Drakaz (4.3), and the new rom, the "Restore libhgl.so" is integrated..... just download the htc file, rename and then put it in sdcard.....

    see how to install the galaxo hero 1.1 or galaxo 1.1 on HDBlog.it forum
     
  11. crixalis

    crixalis Member
    15

    Apr 24, 2010
    35
    0
    15
    Bucharest
    For me is the same result, before update libhgl with neocore I have 25 fps, after update 25 fps.
    I use galaxo 1.6.3.3
     
  12. Rastaman-FB

    Rastaman-FB Android Expert
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    thats becuase there isnt a graphics issue with 1.6 or 1.5 after ik4 update.

    the issue before as 0fps and broken graphics as there was no hardware accelleration due to samsung breaking it

    what fps are you expecting?

    i get 32.5fps with no sound using galaxo 1.6.3.3 oc @ 652 mhz (on demand)
    i get 27.9fps with sound on
     

Share This Page

Loading...