1. Download our Official Android App: Forums for Android!

Root Optimus Elite root with an apk

Discussion in 'Android Devices' started by giantpune, Sep 6, 2012.

  1. giantpune

    giantpune Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    452
    Joined:
    Jun 13, 2012

    Jun 13, 2012
    452
    476
    88
    It seems that people are having some trouble with rooting this phone. So here's an apk that will hopefully work right from the phone. So that means to fiddling with drivers, adb, compiling software, or any of that fun stuff. So far this has only been used on about 3 phones. Of those 3, all of them made it out alive and are probably still working. So now it is time for more of an open beta type deal.

    Why are there 2 apks provided? Do I need to install both?
    Poot-debug.apk is the miracle worker here. In order for it to work, it needs some libraries provided by Ministro.apk. If ministro is already installed, you can skip installing it again. If you don't have access to the googleplay app store, there is an apk for ministro attached to this post.

    What does Poot do?
    So, you got the Poot-debug.apk installed and ministro installed from somewhere. Start up Poot. After it gets some libraries using ministro, you should see a screen with a button at the top that says "Press here to poot" and a big white log window. Press that button and cross your fingers. It will try to do some haxxory and gain root access. Then it will try to remount the filesystem, write the su binary, and clean up after itself a little bit. in the log window, lines starting with "[+]" show good things that are happening. Lines that start with "[-]" show something that didn't work as expected. Assuming everything worked as it should, Poot will have written an su binary in /system/xbin. This binary goes with the Superuser app (not the SuperSU one). You'll want to install Superuser from the play store to finish the process and allow apps to use the su binary. There will be 2 more buttons pop up at the top of the screen that are links to the google play store for the free versions of a couple useful programs. You probably want to install the superuser one first, and then the rootcheck so you can verify that stuff is working.

    What devices does this work on?
    So far, it is only tested on a few versions of the Optimus Elite and the VM Venture. The bug it exploits has been around since 2009, and I found it in the source code for several other models. But I don't have access to any phones except the OE. At any rate, it shouldn't do anything bad. There is some error checking in place and in the event that something doesn't go right, it should fail at least somewhat gracefully without setting anything on fire.

    For now, you can consider this an open beta test. I assume it will work. But it comes with no guarantees or warranties, expressed or implied.



    [​IMG] [​IMG]



    Extra downloads:

    Poot.apk with support for PCD Venture / ARM5 http://www.sendspace.com/file/dgid06

    Poot.apk with support for One Touch 910 /ARM5 http://www.sendspace.com/file/6golr5

    Poot.apk with support for Cherry w100 http://www.sendspace.com/file/oq37ui
    *The cherry w100 version isn't 100% done and working, but it does work well enough to get the su binary installed. You have to reboot your phone each time you try the exploit.

    Poot.apk vith support for h866c (get ministro from the play store, not from this post). http://www.sendspace.com/file/k9b3ks
     

    Attached Files:


    Advertisement

  2. Beno3000

    Beno3000 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Jul 1, 2012

    Jul 1, 2012
    15
    0
    15
    Will download and try this in a few hours and report back.
     
  3. kwknott

    kwknott Android Expert
    Rank:
    None
    Points:
    253
    Posts:
    1,520
    Joined:
    Mar 19, 2012

    Mar 19, 2012
    1,520
    729
    253
    More greatness from Giantpune.. You know of course I'll have to return to stock just to try this :D
     
  4. Hashtag

    Hashtag Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    573
    Joined:
    May 28, 2012

    May 28, 2012
    573
    184
    93
    Male
    High School
    Carl Junction, Missouri
    YES!!! I've been waiting for this to be released for like a month now. It's incredible. And amazing. And spectacluar. And very....giantpunesque :p
     
  5. ktb83

    ktb83 Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    653
    Joined:
    Jun 10, 2012

    Jun 10, 2012
    653
    212
    93
    I was considering creating an APK based on your method. I'm sure a lot of people will appreciate your effort. Well done. Thanks!
     
  6. Android311

    Android311 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    275
    Joined:
    May 30, 2012

    May 30, 2012
    275
    36
    43
    Bus Boy/Table Set Up
    California
    Your amazing!!
     
  7. Dark One

    Dark One Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    786
    Joined:
    Jan 15, 2012

    Jan 15, 2012
    786
    188
    93
  8. Curtis1973

    Curtis1973 Android Expert
    Rank:
    None
    Points:
    353
    Posts:
    2,187
    Joined:
    Jul 1, 2012

    Jul 1, 2012
    2,187
    1,658
    353
    Male
    Greenville,SC USA
    nice work,this makes rooting much easier for users to come who wont have to go the way we did. very nice work.
     
  9. totalrecarl

    totalrecarl Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    183
    Joined:
    Feb 29, 2012

    Feb 29, 2012
    183
    39
    43
    Does this method leave ##DIAG# enabled? Also, will it let you know what your MSL is? Until we get a solid recovery, I strongly recommend that people leave ##DIAG# enabled and have their MSL on hand. If you brick, you can at least recover with the J-Case method.
     
  10. giantpune

    giantpune Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    452
    Joined:
    Jun 13, 2012

    Jun 13, 2012
    452
    476
    88
    This method doesn't enable or disable the diag mode. It is completely different from the already existing methods we have for rooting the phone.
     
    jamoosh and Artine like this.
  11. birkita

    birkita Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 6, 2012

    Sep 6, 2012
    1
    0
    5
    It just works :) Thank you for returning control of my phone.
     
  12. mcgraham89

    mcgraham89 Member
    Rank:
    None
    Points:
    18
    Posts:
    63
    Joined:
    Jan 5, 2012

    Jan 5, 2012
    63
    15
    18
    Nice Job GiantPune. Very Cool of you to create this for people.
     
  13. DsyMnapTic

    DsyMnapTic Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,119
    Joined:
    Apr 29, 2011

    Apr 29, 2011
    1,119
    204
    153
    The rocky mountains
    Dude you are the baddest Mammajamma to walk the face of the earth! I almost feel guilty because of the ease of just rooting my phone. Mad props for that one bro. Thanks for your time and effort !


    I'm allowed to get rid of the two apks now right?
     
  14. pilot03

    pilot03 Member
    Rank:
    None
    Points:
    16
    Posts:
    74
    Joined:
    Sep 1, 2012

    Sep 1, 2012
    74
    8
    16
    Didn't work on mine.
     
  15. MacFett

    MacFett Android Expert
    Rank:
    None
    Points:
    223
    Posts:
    3,236
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    3,236
    740
    223
    Male
    Worshipping Cthulhu
    Sietch Tabr
    Took longer to install poot than it took to root it. Thank you.
     
  16. jengler77

    jengler77 Member
    Rank:
    None
    Points:
    36
    Posts:
    61
    Joined:
    Dec 17, 2011

    Dec 17, 2011
    61
    6
    36
    Worked Awsome!!!! Did two phones in about 10 mins.
     
  17. xaqm238

    xaqm238 Member
    Rank:
    None
    Points:
    16
    Posts:
    61
    Joined:
    Jun 1, 2012

    Jun 1, 2012
    61
    6
    16
    Will this work after the OTA comes down? Been hesitant to put the OTA on because of the rerooting possiblity.
     
    jamoosh likes this.
  18. giantpune

    giantpune Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    452
    Joined:
    Jun 13, 2012

    Jun 13, 2012
    452
    476
    88
    If you do want it to work on yours, you're going to have to be more detailed than that.
     
    andrea50mason likes this.
  19. pilot03

    pilot03 Member
    Rank:
    None
    Points:
    16
    Posts:
    74
    Joined:
    Sep 1, 2012

    Sep 1, 2012
    74
    8
    16
    Understandable. Downloaded both ministro and root-debug on the root of my sd card. Installed ministro first and then installed root-debug. It loaded up the libraries then went forward to the root option. Selected and showed everything went through just like your screenshot. Went on to add SuperUsers and then it hung up at the point to verify if it would work. Attempted again and it just showed the root screenshot, but selected to install rootcheker instead. It told me root not achieved. Root not completed. :(
     
  20. MacFett

    MacFett Android Expert
    Rank:
    None
    Points:
    223
    Posts:
    3,236
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    3,236
    740
    223
    Male
    Worshipping Cthulhu
    Sietch Tabr
    I have the OTA update and it rooted mine just fine.
     
  21. Beno3000

    Beno3000 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Jul 1, 2012

    Jul 1, 2012
    15
    0
    15
    ditto here.
    I have zv5.

    Did a factory reset, dled the apks. ran poot. completed successfully. Dled Superuser and root checker. Root checked asked for su access and at that point i knew i was rooted even before it showed the "successful" result.

    Quick, easy, works.
     
  22. giantpune

    giantpune Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    452
    Joined:
    Jun 13, 2012

    Jun 13, 2012
    452
    476
    88
    If you get to the point where your screen looks like the screenshot in the first post, and there are no lines that start with a "[-]", then it most definitely worked. You may have an issue similar to what hashtag had.

    The su binary was getting correctly written in as "/system/xbin/su", but he had run some other failscript previously that placed a different "su" somewhere in $PATH. So when apps try to use that su binary, they get the one installed by the failscript and not the proper one. I had him fix it by removing the broken "su" from every folder in $PATH.
     
  23. tommymel

    tommymel Newbie
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    Sep 7, 2012

    Sep 7, 2012
    10
    1
    16
    hey i did exactly as you instructed and i got all +'s exact screen as ou posted but i do not have root any suggestions?
     
  24. giantpune

    giantpune Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    88
    Posts:
    452
    Joined:
    Jun 13, 2012

    Jun 13, 2012
    452
    476
    88
    I added in another button that will check for situations like the one hashtag had. It looks at all the directories in $PATH to see if there is something called "su" in it. Then it does "ls -l ..." for that file so you can see the properties like the date it was created and the owner and all that crap. If it says anything besides "/system/xbin/ is the first su found" like in the screenshot above, then you may have problems. This app writes it only to /system/xbin. Any other one ended up where it is from something else you did.
     
    Android311 and Hashtag like this.
  25. taco1425

    taco1425 Member
    Rank:
    None
    Points:
    15
    Posts:
    41
    Joined:
    Sep 2, 2012

    Sep 2, 2012
    41
    0
    15
    it worked on my phone thanks
     

Share This Page

Loading...