1. Are you ready for the Galaxy S20? Here is everything we know so far!

Outgoing email only work with WiFi - Charter.net email - Samsung s3

Discussion in 'Android Devices' started by AthenCharterUser, Oct 29, 2014.

  1. AthenCharterUser

    Thread Starter

    I have configured my phone to use mobile.charter.net . While I can receive email, I can't send email unless I am connected to WIFI. I
    spent 1.5 hours on the phone with Charter support. I was told that Charter Call Center only supported laptops . Mobile devices aren't
    supported except for the information below c/p from Charter WebSite.
    Does mobile charter email work for you without WiFi? If yes, what settings are you using and what email app? THANKS in Advance.
    Note: gmail works. I can send/ receive email without WIFI enable.

    Mobile Email Settings

    Username: (Make sure you enter @charter.net after your username or you will be unable to login)
    Password: The password you use to login to your email account
    SSL: This setting should be on for both SMTP and IMAP
    Protocol: IMAP
    Incoming Email Server: mobile.charter.net
    Port: 993
    Outgoing Email Server: mobile.charter.net
    Port: 587

    1. Download the Forums for Android™ app!


  2. soljer710

    soljer710 Lurker

    Same issue here. I have 3 email accounts on my phone, gmail, hotmail, and work email. I only have this issue with my work email account which is a pop3 server. Weirdest thing - can receive email messages on on mobile network, but can't send. The other 2 accounts no issues. I use Sprint as provider.

    If anyone can help would be much appreciated.
  3. svim

    svim Extreme Android User

    Have you tried using port 465 instead of 587 in your outgoing (SMTP) settings?

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date

Share This Page