1. Download our Official Android App: Forums for Android!

Support painfully slow when going to any secure (i.e. https) site

Discussion in 'Android Devices' started by ks8971, Feb 19, 2011.

  1. ks8971

    ks8971 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 19, 2011

    Feb 19, 2011
    2
    0
    5
    Howdy

    I've recently picked up the HTC Desire from TELUS (which coincidently is an AMAZING phone) and seem to be having an issue when going to any secure site (i.e. online banking, web interface for gmail, etc.). It is painfully slow for any secure page both before and after I've provided any sign in credentials (by painful its around 60 seconds for a page to load).

    Its the stock phone with no changes made to the ROM, same problem regardless of the browser and only when I'm on the TELUS HSPA network (if I'm connected with wifi there's no problem).

    Have called TELUS and was told as long as I can eventually get the page to load there's not an issue (or at least not an issue they're willing to address).

    Thoughts or suggestions?


    THX
     

    Advertisement

  2. avenuePad

    avenuePad Member
    Rank:
    None
    Points:
    38
    Posts:
    98
    Joined:
    Dec 2, 2010

    Dec 2, 2010
    98
    14
    38
    Nova Scotia, Canada
    Do you use the Gmail application, or the actual Gmail page from your browser? Depending on your bank, you might be able to get application for that as well. But as for Gmail, it shouldn't take 60 seconds. You could also try another browser, like Dolphin HD, just to troubleshoot. See if changing the browser does anything, for better or worse. Dolphin HD is a great browser anyway.
     
  3. ks8971

    ks8971 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 19, 2011

    Feb 19, 2011
    2
    0
    5
    The gmail app works fine, if I use the web its slow as previously described

    Yes there is an app but thats not really the issue. There is clearly a problem with going to secure pages with the HTC browser when on the TELUS network. There are other sites I need to log into and its a royal pain in the a$$ to have to wait a minute everytime a new page loads.

    I've played with dolphin in the past and honestly wasn't very impressed. That said I have been playing around with the Opera Mini and its moderately faster than the HTC browser.
     
  4. mixpix

    mixpix Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    123
    Joined:
    Mar 16, 2010

    My Milestone (Telus) has always been like this. Takes far longer to load https websites. It also affects my TD app, which is basically just a web app.
     
  5. Blue1k

    Blue1k Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    608
    Joined:
    Oct 1, 2009

    Oct 1, 2009
    608
    190
    93
    Teacher/Web Design
    Cloverdale, BC
    Same for me on my Fascinate. CIBC pages take 45s to load. On wifi the same https pages take 2 seconds.

    Something is up here.

    Looking into it. Anyone else have any ideas?
     
  6. Chris19000

    Chris19000 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 23, 2011

    Jun 23, 2011
    2
    0
    5
    Okie doke - have had the same issue since day one with my Fascinate. Have been frustrated that secure sites work fine on tethered pc but not in any android browsers.. Until today. Saw this: slow https sites with Milestone Android on Telus and though I couldn't do what this fellow suggested (wouldn't allow me to edit the existing telus sp connection), I made a new "telus sp" connection and put the same apn in (sp.telus.com) and left everything else blank, saved it, selected it, and blammo! Secure sites now load faster than you can say "Powder Toast Man!". Disclaimer though, I know nothing about apn settings so might want to figure out what the risks are of using this connection with clear settings before you use it.
     
  7. Chris19000

    Chris19000 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 23, 2011

    Jun 23, 2011
    2
    0
    5
    2 months + and still no issues with this method. Secure sites still load as fast as ever and everything is still great running Gingerbread on my Telus Fascinate. Cheers,
     
Tags:

Share This Page

Loading...