1. Download our Official Android App: Forums for Android!

General Pandora Stops After Locking Phone

Discussion in 'Android Devices' started by mj_b90, Dec 30, 2009.

  1. mj_b90

    mj_b90 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    105
    Joined:
    Dec 26, 2009

    Dec 26, 2009
    105
    20
    58
    Whenever I turn on Pandora then lock my phone, it will finish the current song then stop. So I have to keep the phone awake, or keep unlocking it to keep Pandora playing. Has anyone else run into this issue, and does anyone know of a remedy?
     

    Advertisement

  2. droid-dohrk

    droid-dohrk Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    90
    Joined:
    Dec 17, 2009

    Dec 17, 2009
    90
    2
    16
    Are you using wifi or 3g?

    If I'm on wifi, it will sometimes turn off wifi after a few minutes and then the music stops. But, that has only happened a few times since I received the phone. Usually, it just keeps playing.
    Some people have changed the Wifi Sleep policy to Never, but I leave it at When screens turns off, and my music will keep playing. If I'm not playing music, the wifi will turn off. So, I think Pandora should keep the phone awake even when you press the End call.

    If I'm on 3g, I don't think it has ever stopped.

    I'm testing right now with 3g on. I started it, the music came on, I pressed the End call to make the screen go off. It's played 3 songs just fine.

    Tunewiki works the same for me, it keeps playing like 99% of the time when you press the End call.

    Rick
     
  3. mj_b90

    mj_b90 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    105
    Joined:
    Dec 26, 2009

    Dec 26, 2009
    105
    20
    58
    I'd never noticed before since I usually only use it at home with wifi. But you're right it's only under wifi. Where can I change the Wifi sleep policy you mentioned? I don't think I've seen that yet.

    Thanks
     
  4. droid-dohrk

    droid-dohrk Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    90
    Joined:
    Dec 17, 2009

    Dec 17, 2009
    90
    2
    16
    Menu > Settings > Wireless controls > Wi-fi settings > Menu > Advanced > Wi-Fi sleep policy

    Also, I think if you leave the phone on the charger, it doesn't turn off wi-fi for me.
     
  5. mj_b90

    mj_b90 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    105
    Joined:
    Dec 26, 2009

    Dec 26, 2009
    105
    20
    58
    I changed that to never sleep and that took care of the issue. Thanks for the help!

    Now I've just got to hope that changing that setting won't hit my battery too hard.
     
  6. findapollo

    findapollo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 6, 2010

    Jan 6, 2010
    1
    0
    5
    Mine was already set to 'Never' for Wifi sleep but shortly after the screen times out, Pandora stops. Thought Pandora was supposed to prevent from sleeping? It doesn't. Can anybody explain how to fix this?
     
  7. nicorellius

    nicorellius Lurker
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jan 4, 2010

    Jan 4, 2010
    9
    0
    5
    I'm using the HTC Eris and I was having the same problem. In fact, I'm testing it now... With only the wireless on (no mobile network), the Pandora stream would go off every single time after each song when the device was locked. I would have to unlock and go to the Pandora app and hit pause/play or hit next to get it going again... I saw this post and decided to turn on the mobile network as well as keep the wireless on to see what happens...

    I just realized I hadn't changed my sleep policy. I changed it to never and Pandora works great. I don't think changing the mobile network setting matters. In fact, I would imagine that via wireless Pandora would work better.

    Thanks for the help!
     
  8. Tarasasaurus

    Tarasasaurus Newbie
    Rank:
    None
    Points:
    16
    Posts:
    16
    Joined:
    May 31, 2010

    May 31, 2010
    16
    1
    16
    This issue is really pissing me off. Anyone know a solution?
     
  9. Jakaro

    Jakaro Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    601
    Joined:
    Apr 16, 2010

    Apr 16, 2010
    601
    55
    78
    Casino Surveillance
    North Idaho
    Mine is also set to Wi-fi never turning of and its pissing me off as well, its effing useless... god damn it i want to listen to more than half a song.!!!
     
  10. Hiroshika

    Hiroshika Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    166
    Joined:
    May 30, 2010

    May 30, 2010
    166
    24
    38
    I noticed the same issue when i turned always on data off. Turned it back on and it worked.
     

Share This Page

Loading...