1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Partially Solved] Calling all Ubuntu experts - Unity desktop help required

Discussion in 'Computers' started by SUroot, Sep 24, 2011.

  1. SUroot

    SUroot Extreme Android User
    Thread Starter

    Hi there, I need some urgent help.

    My 11.04 installation broke during routine updates using update manager.

    On boot I get an error "could not update ICE authority" and when the standard desktop loads, it looks more like the 10.04 one. I get another error saying that /home/dan/.config permissions denied so it cannot load my desktop properly.

    When I launch Terminal I get an error about permissions being denied to .bashrc

    If I CTRL, ALT +F2 I get to TTY and it all operates as normal.

    I tried:
    Code (Text):
    1.  
    2. sudo chmod 644 /home/dan/.dmrc
    3. sudo chmod 755 /home/dan
    4. sudo chown dan: /home/dan
    5. sudo shutdown -r now
    6.  
    Which seemed to go without a hitch but my issue still remains.

    I can boot to the live CD and access all the directories including /home, /usr etc.

    Does anyone know how I can fix this from here?
    I want to keep my data, thats a given, but I really would like to keep all my packages too. It really does seem like a broken permissions issue, but I am still ubuntu / linux noob.

    I am a wintel systems engineer though so I am happy to try complex solutions to repair this but as I still don't understand all the commands, I will need some guidance.

    My last resort is to reinstall ubuntu from live CD without formatting home and keeping the same username, but that will lose all my android building set up etc etc.

    Any suggestions gratefully appreciated...
     

    Advertisement

  2. SUroot

    SUroot Extreme Android User
    Thread Starter

    After:
    Code (Text):
    1.  
    2. Could not update ICEauthority
    I get:


    Code (Text):
    1. "There is a problem with the configuration server. (/usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256)"
    Then desktop starts and get permission denied to:
    Code (Text):
    1.  
    2. /home/dan/.config/monitors.xml
    This is also posted here:

    http://ubuntuforums.org/showthread.php?t=1849363
     
  3. SUroot

    SUroot Extreme Android User
    Thread Starter

    Update:

    Partially resolved.

    I installed Unity 2D and noticed Nautilus seemed to be missing (or broken). reinstalled Nautilus. Now I can access everything.

    Just got to somehow fix unity 3D

    Tried unity --replace.

    It almost works when in unity 2d, I can see the old unity bar etc overlapping unity 2D. I can kill 2D temporarily and the terminal keeps running, until 2d starts again and it hangs.

    I cant replace via tty or recovery root shell as I get a warning about display settings


    Edit> never mind. All fixed. Thanks for reading
     
Loading...

Share This Page

Loading...