1. Are you ready for the Galaxy S20? Here is everything we know so far!

PC not detecting Galaxy S2

Discussion in 'Android Devices' started by Aros888, Dec 28, 2011.

  1. Aros888

    Aros888 Lurker
    Thread Starter

    I've had my Samsung Galaxy S2 since late November and the phone's been treating me well. Except for the occasional restart I'd have to do every once in a while, I've loved it. Not to stray too far off-topic, but it's so much better than my iPhone. :D

    Anyway, I left to go to the movies tonight and put some music on my phone for the drive there using the USB storage option for the Galaxy S2. I plugged it in, enabled the USB storage option from the pull-down menu, clicked and dragged the sound file to the phone. I disabled the option, turned off my computer and left. When I came back, I wanted to put more music on my phone but all plugging it in did was start charging it. I noticed my computer said something like "One or more USB devices have malfunctioned.."

    I've researched this and can't find a working solution. I tried my mom's USB cable, but that didn't work for me either. I've tried all different USB ports on my computer and uninstalled the root hubs. The phone shows up in device manager as "Unknown Device", and I've looked up the model to see if there's a driver and I can't find one (SGH-T989).

    Anybody know how to help me? :)?

    EDIT: Okay; I somehow, by messing around with the USB ports on my computer, have gotten it to recognize it and offer the USB mass storage option from within the pull-down menu for about half a second randomly.. one time it was just flashing.

    EDIT2: Now it's working for whatever reason! All I did was check the hard disk for errors last night and now it's magically working.. I'd still like to know what the problem was in the first place..

    EDIT3: It's not working AGAIN! I don't even understand this anymore.. Yeah, Kies Air works, not Kies itself.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. pasqo83

    pasqo83 Well-Known Member

    A few options really.

    A) DLL file was corrupted and is now working after you did a scan disk.
    B) The driver device wasn't pointing to the device therefore it would not start the phone correctly, again after the scan it fixed itself.
    C) The driver was conflicting itself with another device, again the scan disc done the job.

    Those are the only things I could suggest as the scan disc has obviously assisted in making sure the files were pointing correctly to say "Im an S2, recognise me baby" - well something like that :p
     
  3. medina191

    medina191 Lurker

    help i am having a similar issue except when i connect mine it doesnt do anything except flicker on and off about "usb connected" and when it manages to stop long enough so i can touch it, my computer says its an unkown device yet it was just working fine for a week and i am thinking it maybe a virus or something please help..........................
     
  4. medina191

    medina191 Lurker

    surprisingly it still connects via kies so i have no idea wtf is happening to this thing
     
  5. Aros888

    Aros888 Lurker
    Thread Starter

    It's not working AGAIN! I don't even understand this anymore.. Yeah, Kies Air works, not Kies itself.
     
  6. pasqo83

    pasqo83 Well-Known Member

    TRY THIS:

    Click This link, install (Make sure Kies and your phone is not plugged in) and then start Kies up again and it will work.

    Samsung_Mobile_Driver_V1.3.800.zip
     
  7. sidthekid

    sidthekid Lurker

    Still same issue after installing the driver...

    If i right click the unrecognized drive, this is what it says:
    Windows has stopped this device because it has reported problems. (Code 43)
     
  8. Xerses

    Xerses Well-Known Member

    Try the following, it sounds like a Windows issue and this might solve it:

    1) Make sure the phone is not connected and Kies Air is off.

    2) Uninstall Kies (Control Panel, Uninstall a program or Add/Remove Programs)

    3) Reboot and run a CHKDSK (If you don't know how, follow steps 4 - 9, if you know how then skip to 10)

    4) Open Windows Explorer, right click on your C drive, select Properties.

    5) In the Properties window, select the Tools Tab.

    6) Click on the "Check Now" button in the Error-checking section.

    7) When the dialog pops up, make sure there is a check beside "Automatically fix file system errors" and click the Start button

    8) When another dialog pops up indicating that it can't scan because it is use, click on "Schedule disk check". Click OK on the properties window and reboot your computer.

    9) Let the PC scan and fix any errors by not touching the keyboard or mouse when the computer is rebooting. You will see a screen where the disk will be checked.

    10) When back in Windows, fully booted and at your desktop, uninstall the Samsung USB drivers that you have installed (Control Panel, Uninstall a program or Add/Remove Program)

    11) Delete the Samsung install directory (default is C:\Program Files (x86)\Samsung if installed on a 64bit PC and C:\Program Files\Samsung on a 32bit PC)

    12) Reboot for good measure.

    13) Download and install the latest version of Kies (includes USB drivers). It can be found here: What's new for Software & Manual SAMSUNG

    14) Reboot for good measure.

    15) When back in Windows and fully loaded at the Desktop, start Kies and connect your phone making sure your phone is ON.

    This should solve the issue, but may not. It will take about 15 minutes to do depending on the speed of your computer, so it is worth a try. Hope this helps.
     
  9. Mirox

    Mirox Lurker

    with mine, I just downloaded the drivers off the Samsuing website, along with Kies and it fixed the issue
     
  10. Drrmahajan

    Drrmahajan Lurker

    1. When the phone is upgraded to Android 2.3.4 and above (mine is 2.3.6) Kies stops recognizing the phones and USB connection / Serial port connections etc get reset on the phone
    2. Even if proper drivers are there on the laptop (mine is Windows 7 64bit) they are not recognized
    3. Device Manager shows "unknown device"
    4. Updating the driver also does not result in any help
    5. solution lies in the phone
    a. key in the dialer *#7284#
    b. it has 4 option there..
    UART (MODEM/PDA)
    USB (MODEM/PDA)
    c. For USB. select the PDA.if it already selected to PDA. reselect it by select MODEM and then PDA again.. Only change the USB setting.. andthen press back. try reconnect (thanks to napi1 @ androidforums.com/samsung-galaxy-s2-international/447145-sgs2-kies-not-syncing-os-2-3-5-a.html#post3484588)
    6. The Laptop will start recognizing the required drivers and install them
    also
    Phone is not recognized by laptop when it is in USB debug mode, MyPhoneExplorer does not recognize when it is not in Debug mode
     
    GeekBoyWonder and suvarghyadutta like this.
  11. dferrell3

    dferrell3 Lurker

    Drrmahajan (and napi1),

    Amazing, worked just like a charm. I just recently had the same issue with trying to transfer files from my computer to me phone (and by recent, I mean an hour ago), and your solution worked. Thanks.
     
  12. Bingo....I just upgraded from Froyo to Gingerbread 2.3.6 today and my phone stopped being shown in either Kies or in My Computer...got very worried. Googling led me onto this site and voila...this remedy worked like magic.

    Thanks to all.
     
  13. rooby

    rooby Lurker

    I googled the problem and even youtubed it... and tried every other method but it didnt work.. gave a final shot at this blog and ur steps worked!!

    Thank you very much!~:D
     
  14. rooby

    rooby Lurker


    Thank you!!! it worked
     
  15. roughneck224

    roughneck224 Lurker

    I am having the same problem. I have the Samsung Galaxy S2 model number SGH-T989 for t-mobile. I have uninstalled Kies and the samsung usb driver. I have reinstalled all of it. Rebooted my computer, turned off the phone and turned it back on. I keep gettin the message: USB Device Not Recognized. One of the USB devices attatched to this computer has malfunctioned, and Windows does not recognize it. Any other ideas? Maybe its my phone. I have updated every USB driver on my computer and they all seem to be working fine. I even did a factory reset on my phone. Plz help.
     
  16. barkaati

    barkaati Lurker

    Hello Pal... Thanx for the Help... i tried it the first time and it worked.... later on when i connected my phone again to the USB.... it dint work
    i tried going through the steps again but it doesnt work anymore

    Plz advice
     
  17. mills2533

    mills2533 Well-Known Member

    Another solution is to check out Universal Naked Drivers from XDA forum.
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...
Similar Threads - detecting Galaxy
  1. melani78
    Replies:
    2
    Views:
    255
  2. Daddyroid
    Replies:
    4
    Views:
    2,468
  3. RU2022
    Replies:
    3
    Views:
    801
  4. JSS1900
    Replies:
    8
    Views:
    2,115
  5. hzare
    Replies:
    1
    Views:
    890
  6. Yamil_alv
    Replies:
    1
    Views:
    3,064
  7. Bhavin Lathia
    Replies:
    4
    Views:
    2,873
  8. Rasil1127
    Replies:
    2
    Views:
    3,116
  9. App Update
    Replies:
    1
    Views:
    880
  10. kiranmatrixlee
    Replies:
    0
    Views:
    2,518

Share This Page

Loading...