1. Check out our companion app, Forums for Android! Download from Google Play

Root Phone app lags/freezes after root

Discussion in 'Android Devices' started by coangr, Jan 12, 2013.

  1. Mikestony

    Mikestony ~30% Carbon Black ±
    Moderator
    3,118

    Sep 10, 2010
    28,241
    21,541
    3,118
    Male
    N/W Indiana
    In my opinion, yes. :) Now you know what fixed it, if it happens again.
    But why it happened, I don't know.
    And perhaps try a different rom:)

    Edit: Atmazzz be da man!
     

    Advertisement

    ocnbrze and Atma like this.
  2. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Yes, I would root. :D

    Instead of installing the older CWM recovery with Odin, download this TWRP file and use Odin to install it like you would CWM. Then flash the superuser file and confirm you have root. Then go back to TWRP and do a backup.
     
  3. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    Knowing what fixes it is great, but I thought I deleted everything that was bloatware on the phone, so I guess I'll have to do some trial and error.

    thanks guys!!
     
  4. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    I'm back :p

    So, I tried to root the phone again, and CWM said the phone was rooted in recovery, but I don't have access. :s
     
  5. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    So you used Odin to install cwm, then you flashed the superuser file? But an app says you don't have root?
     
  6. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    *touches nose* Exactly. What's up with that?
     
  7. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Try flashing superuser again. Sometimes you have to go back and do it again.

    Which guide are you using?

    Also, I would recommend using the TWRP recovery if you're thinking about flashing ROM's. The newer jelly bean ROM's sometimes don't work well with the older version of CWM and you can get a boot loop after flashing.
     
    coangr and ocnbrze like this.
  8. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    I'm using this guide. I don't understand -- I've done it a few times now, the root is just not clicking. Superuser appears, but no access.:thinking:
     
  9. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    ocnbrze and coangr like this.
  10. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    ocnbrze, Mikestony and Atma like this.
  11. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    OK, so it's back. I reviewed all apps through the provided link above prior to deleting them (to ensure I wasn't removing an imperative component.) It worked for a couple days, but today, it started to lag again.

    After rooting, I did install a couple apps, I wonder if they caused it. AdAway and Beats Audio Installer.

    Frustrating that it does this after I customize the phone again lol
     
  12. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    The only way to know for sure is uninstall them. I haven't tried Beats but I've never had a problem with AdAway.

    If that doesn't fix it, maybe its something you are deleting. What link are you using to delete the bloat?
     
  13. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    I don't know if Beats can be uninstalled like the other apps, but I could be wrong. It is, however the only common link between the issue. I used a different ad-removal app prior. As for the link, I used the ones you suggested in your tutorial.

    I'd give you the full list of bloatware I removed, but I didn't bother to back them up, given they were safe the remove. They included the usual's though, Email, Buddies Now, Telus House, AcuWeather, Kies Air, Mini Diary, Music Hub, Readers Hub, Samsung Apps, Social Hub, and a couple others I believe.
     
  14. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Did you make a nandroid after you rooted? Before you installed apps?
     
    Mikestony likes this.
  15. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    coangr and Mikestony like this.
  16. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
  17. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    correct. a flashable .zip is flashed thru recovery. make sure to do a nandroid backup before flashing it just in case.
     
    coangr and Atma like this.
  18. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    I don't know if I'd have the patience of being a software tester lol - there are so many possibilities here. Removing it hasn't worked. I don't know if one of the rooted apps is causing it or if a "normal" app has caused it in combination of rooting. hmmmmm I guess it's back to flashing the stock again :eek:
     
  19. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    If you flash the stock, don't forget a nandroid after rooting. :) I would recommend using TWRP instead of the older CWM if you're still using it.

    Also, bloat you're deleting. You might try using Titanium to freeze an app first to make sure it isn't causing the lag you're getting.
     
    coangr likes this.
  20. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    I'll give TWRP a shot, but (as sad as it sounds) I don't have the $7ish bucks at the moment to buy the Pro version yet :eek:
     
  21. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Pro version of what? :thinking: TWRP recovery is free. Or if you prefer, there may be a zip of a newer CWM you could flash over the older version.
     
  22. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    i think he is talking about TB, titanium backup pro key;)

    and i like twrp on my phone(evo 4g lte). its a great recovery.
     
    Atma likes this.
  23. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    Sorry, pro version of TiBu. What's the benefit of using these other versions, though?
     
  24. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Ahh .. ok I gotcha.

    The newer recoveries work better. The older CWM has a chance of causing bootloops with the newer JB roms.
     
    ocnbrze likes this.
  25. coangr

    coangr Well-Known Member
    Thread Starter
    16

    Nov 3, 2011
    47
    8
    16
    Newmarket, Ontario
    I'm running version 5.0.2.6 on my S2. What's the newest version?
     

Share This Page

Loading...