1. Download our Official Android App: Forums for Android!

Support Phone battery problems on rooted phone

Discussion in 'Android Devices' started by kikofosho, Jul 14, 2011.

  1. kikofosho

    kikofosho Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    49
    Joined:
    May 14, 2010

    May 14, 2010
    49
    0
    15
    Palo Alto
    Hey everyone.

    I went on a 2 month trip and left my Eris at home. When I came back and charged it overnight, it worked fine. However, I quickly noticed that everything was not ok. My battery completely drains in less than three hours. It is constantly in the awake state. I downloaded the "Advanced Task Killer" even though I never needed it, and I found that my phone is constantly "awake." What should I do?

    My phone is rooted via the 1-Click Method, and I haven't flashed a ROM or whatever. Do I do the swipe thing?
     

    Advertisement

  2. doogald

    doogald Android Expert
    Rank:
     #52
    Points:
    483
    Posts:
    6,699
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,699
    1,929
    483
    Well, first I would check for the screen timeout in settings->display (I think.)

    You can also try recalibrating the battery. Get the phone fully charged. Keep it plugged in, and then shut down the phone and restart in Recovery. Go to the wipe menu, and choose "Wipe battery stats". Restart the phone, and then unplug it. Let the phone run on battery for as long as you can, but don't let it get to zero. Recharge it fully and hopefully it will be better.

    Also, do know that Li-ion batteries do tend to lose life after about 18 months of heavy use, so it may be that the battery needs to be replaced. Keep that in mind if the recalibration doesn't seem to help.
     
    kikofosho likes this.
  3. kikofosho

    kikofosho Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    49
    Joined:
    May 14, 2010

    May 14, 2010
    49
    0
    15
    Palo Alto
    Thanks for the advice! I will try this! I get to the recovery screen by pressing the power and volume up button s simultaneously, correct?

    Also, I mentioned that my phone is in the "awake" state all the time. Is this a cause for concern?

    Thanks!
     
  4. doogald

    doogald Android Expert
    Rank:
     #52
    Points:
    483
    Posts:
    6,699
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,699
    1,929
    483
    That's right.

    Well, did you check that screen timeout setting?
     
  5. kikofosho

    kikofosho Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    49
    Joined:
    May 14, 2010

    May 14, 2010
    49
    0
    15
    Palo Alto
    I did check it. First it was at one minute, but a couple days ago I switched it to 15 seconds and it still is awake all the time.

    My phone is charging now so that I can recalibrate the battery.
     
  6. kikofosho

    kikofosho Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    49
    Joined:
    May 14, 2010

    May 14, 2010
    49
    0
    15
    Palo Alto
    I fear that the recalibrating did not do much. The battery continues to die very quickly. I've also noticed that the awake time was still 100%.

    I turned off my "Background Data" auto sync, and it seems like this seemed to fix the "awake" problem. However, now I have to manually refresh to get emails. This sucks.
     
  7. KingOfGreen

    KingOfGreen Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    842
    Joined:
    Nov 3, 2010

    Nov 3, 2010
    842
    179
    93
    Chandler, Az
    Check to see what apps are running on a fresh boot, you may have an app runnin that wont let the phone sleep.
     
  8. kikofosho

    kikofosho Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    49
    Joined:
    May 14, 2010

    May 14, 2010
    49
    0
    15
    Palo Alto
    I checked what is using my battery, and the things are "cell standby," "android system," and "phone idle."
    The apps on my task killer say "clock," "circle battery widget," "messages," "footprints," "market," "gmail," and "task killer."

    I turned on my background data, and killed "footprints." I also noticed that my phone is alway syncing. I looked at what was up, and it was still working on my google contacts. I stopped it, and am now waiting to see what my phone does.
     
  9. doogald

    doogald Android Expert
    Rank:
     #52
    Points:
    483
    Posts:
    6,699
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,699
    1,929
    483
    If you have all Google contacts on the phone:

    settings->applications->manage applications. Go to Contacts Storage. Tap, and then "clear storage". When you re-allow background data, sync will repopulate your contacts and that problem should go away.
     
  10. kikofosho

    kikofosho Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    49
    Joined:
    May 14, 2010

    May 14, 2010
    49
    0
    15
    Palo Alto
    I think it worked! Thank you so much!!!
     
  11. kikofosho

    kikofosho Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    49
    Joined:
    May 14, 2010

    May 14, 2010
    49
    0
    15
    Palo Alto
    confirmation: it works! thank you!
     

Share This Page

Loading...