1. Download our Official Android App: Forums for Android!

Phone Contacts Syncing with Google

Discussion in 'Android Devices' started by rswheaton, Oct 24, 2009.

  1. rswheaton

    rswheaton Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    183
    Joined:
    Oct 13, 2009

    Oct 13, 2009
    183
    9
    36
    I cannot remember where you can change the setting so your phone will not sync with your entire gmail contact list. Please help
     

    Advertisement

  2. rswheaton

    rswheaton Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    183
    Joined:
    Oct 13, 2009

    Oct 13, 2009
    183
    9
    36
    Someone PLEASE!!! This should be really simple and I am going nuts trying to find it.
     
  3. UTnick

    UTnick Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    104
    Joined:
    Oct 20, 2009

    Oct 20, 2009
    104
    7
    36
    settings > data synchrozination > google > uncheck Contacts
     
  4. rswheaton

    rswheaton Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    183
    Joined:
    Oct 13, 2009

    Oct 13, 2009
    183
    9
    36
    I see that option... but I am looking for the option to just sync your contacts and not all the millions of email addresses from everyone who has ever emailed you.
     
  5. romeosidvicious

    romeosidvicious Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    270
    Joined:
    Oct 13, 2009

    People -> Groups -> Menu -> Sync Groups will let you choose what groups to sync.
     
  6. brawand

    brawand Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Oct 23, 2009

    Oct 23, 2009
    4
    0
    5
    machinest
    kentucky
    i use insight broadband and cant get email to work. work fine with last phone.
     
  7. sr1982

    sr1982 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    153
    Joined:
    Oct 4, 2009

    Oct 4, 2009
    153
    1
    36
    This might be a dumb question, but.... I have my "People" set up with all the contacts I wish to have. I don't want google to automatically update me with more people who I email. By doing what you stated above, that should keep my "people" contact list as is, right?

    If so, thank you so much, I am sick of going into my gmail or people and deleting people who I just email one time and never talk to again.
     
  8. brandiem09

    brandiem09 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    14
    Joined:
    Oct 17, 2009

    Oct 17, 2009
    14
    6
    16
    student
    Florida
    Go into Google Mail on your computer, remove all of the contacts that you don't want to sync with your phone from the "My Contacts" list.
    Your phone will only sync "My Contacts"
     
  9. romeosidvicious

    romeosidvicious Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    270
    Joined:
    Oct 13, 2009

    By default the phone is set to sync "All Contacts". The instructions above show how to get the screen to change that because it's not in a very intuitive place at all. Which is one of my very minor gripes about the phone. Configuration of the stock features is all over the place. In fact two people, one who is even familiar with the Hero, asked this question within hours of each other. It's also not a smart move to have the phone default to "All Contacts". In one account, not the one I associated with the phone, I have 4 years of e-mail and contacts resulting in almost 4k contacts. I can only imagine the headaches that would have caused if I had associated it with that account.
     
  10. QuiQNeZZ

    QuiQNeZZ Member
    Rank:
    None
    Points:
    36
    Posts:
    47
    Joined:
    Oct 14, 2009

    Oct 14, 2009
    47
    1
    36
    Herndon, VA
    I had the same issue at first, of not being able to see the "My contacts" group which gmail does NOT automatically add emails to for you (which by the way is a stupid feature that they need to at least give you an option to turn off). The only group that would show up is the "All contacts" group. Well what I did was as a person from this forum suggested and basically clear out your gmail account info then clearing out the data from the "People" app. Then go to sync your contacts again and it'll prompt you to enter your gmail account username and PW again just like when you originally set the phone up. After that the "My contacts" group started showing up and I was able to sync JUST that group and uncheck the "All contacts" group.

    This procedure also fixed the same type of issue I was having with not all of my calendars that I had setup on google calendar to be able to be sync'd on my phone. So I cleared the data out on my calender app, then my google account AGAIN. And it low and behold, my extra calendar that I have linked to google then started showing up on my phone for me to sync with.

    So now I have my calendars and contacts and email all setup JUSt like I want them.
     
  11. hake0305

    hake0305 Member
    Rank:
    None
    Points:
    15
    Posts:
    45
    Joined:
    Oct 13, 2009

    Oct 13, 2009
    45
    0
    15
    So I put all the contacts I want the "People" to sync with on my gmail account, and I am trying to sync the phone so the phone will update and remove all the email addresses that I don't want, but I am running into problems.

    From People>Menu>Sync Exchange contacts, I enter my gmail address and password but it states "Authentication failed. Please verify username and/or password."
    I have email address: hake0305@gmail.com
    Server address: gmail.com
    Domain: (Nothing)
    Username: hake0305
    Password: my correct password
    "This server requires and encrypted SSL connection" is checked.

    What is wrong with these settings that it is not connecting? It has connected before, as it is updating every sent/received email to my People contacts.
     
  12. deviouskoopa

    deviouskoopa Member
    Rank:
    None
    Points:
    15
    Posts:
    41
    Joined:
    Oct 15, 2009

    Oct 15, 2009
    41
    0
    15
    undergrad researcher
    Blacksburg, VA
    This could be a completely wrong answer to your problem, as I don't fully understand, but I think you're putting your Gmail account info into the wrong place. Instead of Sync Exchange, I just put my info into the Google Account with Contacts checked (by default).

    On another note, does anyone know why "My Contacts" is the only group that shows up in the sync? I want to sync friends and family groups instead of one big group. It synced a custom-named group "Places" that I made just fine...
     
  13. pdragon

    pdragon Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    395
    Joined:
    Oct 15, 2009

    Sync Exchange is for syncing with a Microsoft Exchange server, not Gmail or a normal email address.
     
  14. pdragon

    pdragon Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    395
    Joined:
    Oct 15, 2009

    Outside the All Contacts group, the premade groups in Google do not sync for some reason. Any custom made groups will synch, though. I solved this by creating my own groups called My Friends, My Family & My Coworkers. Moved the contacts in the premade groups to these groups and everything syncs fine now.
     
  15. deviouskoopa

    deviouskoopa Member
    Rank:
    None
    Points:
    15
    Posts:
    41
    Joined:
    Oct 15, 2009

    Oct 15, 2009
    41
    0
    15
    undergrad researcher
    Blacksburg, VA
    Oh okay, good idea. Thanks a lot.
     
  16. gogogadgetscott

    Rank:
    None
    Points:
    25
    Posts:
    8
    Joined:
    Oct 22, 2009

    Oct 22, 2009
    8
    0
    25
    Any idea why this is? Thanks for the tip!
     
  17. natrixgli

    natrixgli Member
    Rank:
    None
    Points:
    36
    Posts:
    39
    Joined:
    Oct 30, 2009

    Oct 30, 2009
    39
    1
    36
    Normally you wouldn't use Exchange/ActiveSync to connect to Gmail if you just have one Google account.

    However you can use the Exchange sync feature if you want to add a second Google account, since Google does support the Exchange ActiveSync protocol. You just use the server 'm.google.com' and your full email address as your username.

    This will also work with Google Apps if you or your company have a domain set up with Google.

    -n8
     
  18. troyboytn

    troyboytn Well-Known Member
    Rank:
    None
    Points:
    35
    Posts:
    100
    Joined:
    Oct 25, 2009

    Oct 25, 2009
    100
    0
    35
    Knoxville
    I had to do that trick as well. Any way, those lists did resync to gmail as well.
     
  19. patiomae

    patiomae Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 11, 2009

    Nov 11, 2009
    1
    0
    5
    I have the Samsung Moment on Sprint. After getting my contacts setup through Google Contacts on the PC, I couldn't get "My Contacts" to show on my phone, only my "Favorites" or "Starred in Android". I did the following to fix:



    From contacts tab on phone, hit menu. Then you have option to edit sync groups. I had to select "my contacts".
     
  20. cirehawk

    cirehawk Android Enthusiast
    Rank:
    None
    Points:
    36
    Posts:
    278
    Joined:
    Oct 31, 2009

    Oct 31, 2009
    278
    8
    36
    Southern California
    Would you be able to point me to step by step procedures to do that? I'm a little unclear on a couple of steps.
     
  21. QuiQNeZZ

    QuiQNeZZ Member
    Rank:
    None
    Points:
    36
    Posts:
    47
    Joined:
    Oct 14, 2009

    Oct 14, 2009
    47
    1
    36
    Herndon, VA
    First thing you wanna do is diconnect your sync to gmail on all the apps that you're using it for like contacts, and calendars and google voice if you're using that. I don't use google voice but I guess you could use the same method as follows for all the apps.

    Open up "People" app, go to groups/menu/sync groups/ and uncheck all the groups in there to disable the syncing of them to your phone.
    Go to menu/settings/applications/manage applications and look for the "People app". Select it and hit "Clear data" and "Clear cache".

    Do if you wanna do the same for the calendar Open up the Calendar app. Hit menu/calendars and unselect all the calendars. Then do the same steps above but for the Calendar app.

    Last step is to clear the gmail account info you have strored on the phone by going to menu/settings/applications/manage applications and looking for com.android.providers.user and select clear data on that.

    Reboot your phone and then go to setup either your gmail, or to the "People" app then groups/menu/sync groups and you should be prompted to enter your gmail account info again. Once you do that you should then be able to see all your contact groups to sync with. Just select "My contacts" so you don't get all those extra one time email addresses added to your phone.

    Repeat for your calendar to make sure all your calendars are being sync'd.
     
  22. cirehawk

    cirehawk Android Enthusiast
    Rank:
    None
    Points:
    36
    Posts:
    278
    Joined:
    Oct 31, 2009

    Oct 31, 2009
    278
    8
    36
    Southern California
    Thanks for the instructions. The only part that didn't really work as you described was the com.android.providers.user app. I never got an option to clear data (it was already at 0.0), so I was never prompted again to enter my gmail info. At any rate, this still didn't fix the issue of my sports calendars not being synced.
     
Tags:

Share This Page

Loading...