1. Check out our app, Forums for Android! Download and leave feedback here!

Support Phone contacts will not sync with Google

Discussion in 'Android Devices' started by zimonline, May 15, 2010.

  1. zimonline

    zimonline New Member
    Thread Starter
    5

    Oct 14, 2009
    2
    0
    5
    Hi All.
    My sister has just got a Tattoo. no Mum not a real one :)

    Phone Info:
    UK --> Vodafone --> Tattoo --> Android 1.6

    I am having the following problem. If I add a contact to her phone the contact type is Phone and it won't sync with gmail-->contacts. When you are adding the contact under contact type the only options are Phone or Sim.

    Google sync is On
    It syncs contacts added to Google fine
    I have tried to change the contact type when I add a contact.


    The Q in short is how can we add contacts to the phone that will sync with google?

    Many Thanks
     

    Advertisement

  2. samski

    samski Active Member
    15

    Apr 9, 2010
    31
    0
    15
    well the answer is to choose type: google when you add a contact but i cant understand why it isnt giving you that option....

    try clearing cache and data from the people app (it wont delete you contacts, that are stored in the 'contacts storage' app
     
  3. zimonline

    zimonline New Member
    Thread Starter
    5

    Oct 14, 2009
    2
    0
    5
    Many Thanks but I have tried that also done a factory reset. No Joy :(
     
  4. samski

    samski Active Member
    15

    Apr 9, 2010
    31
    0
    15
    sounds like it is time to contact htc customer support. i havent had a reply from them in a while, but hopefully you will get a good person dealing with your problem


    googling turned up this, but i doubt it is your solution as it sounds like you have google contacts set to view as you can see contacts you have added online....

    ooh one final thing you could try is seeing if it is a 3rd party app causing the problem (unlikely).... turn the phone off and then turn it on again while holding menu... safe mode should appear in the bottom left corner of the screen..
     
  5. pevans_om

    pevans_om Active Member
    16

    Feb 23, 2010
    25
    1
    16
    Perhaps a silly question, but...

    Have you configured your gmail account properly? you can get mail through the gmail app etc.?
     
  6. clast14

    clast14 New Member
    5

    May 24, 2010
    1
    0
    5
    I, have a similar problem.

    Using i5700 (Galaxy Spica), Android 2.1

    I can get all my gmail, calendar and contacts synced fine, except - when I update my google contact using my phone, and do a sync, the gmail contact overwrites what I did on my phone. In short, the phone is not updating the gmail contact.
     
  7. pikebhoy

    pikebhoy New Member
    5

    Sep 12, 2010
    1
    0
    5
    Same thing for me using HTC Desire.

    Using the phone I added another work number to a google contact (using the custom option). Tried syncing down to my google account but the new entry wont go into my contact on google.

    Hasn't overwritten up the way on my phone contact so far......
     
  8. conviction

    conviction New Member
    5

    Jan 1, 2011
    2
    0
    5
    I also have that problem, LG GT540 android 2.1
    Come on man! there's gotta be a solution, this is google!
     
  9. mkarplus

    mkarplus New Member
    5

    Sep 20, 2011
    1
    0
    5
    LG GT540 android 1.6 worked fine.
    Upgraded to android 2.1 and contacts do not sync.

    Changed unit to a brand new one and the same happened : 1.6 worked fine, 2.1 did not sync.

    Any tips? thanks!
     
  10. triboy

    triboy New Member
    6

    Dec 2, 2011
    1
    2
    6
    i had the same problem, then it hit me, sure enough look on your phone, go to people / contacts, and select export, on mine it came up with gmail or phone...simple, I had been saving a number of my phone originated contacts on my phone, so they never synched...I did not realise this.

    Solution, export to SD card, all the phone contacts. Close. Go to people / contacts, select import from SD card, it will ask you to where. Select gmail account. Synch.

    Voila, now synch with your gmail account and there they all are. Hope this helps. Should have guessed it would not be google's fault all the time
     
    RaulNo1 and thornev like this.
  11. saunjay1

    saunjay1 New Member
    5

    Dec 20, 2011
    1
    0
    5
    I was having this same issue on my Galaxy S2 then I started messing around in the menus. From the contacts list I went to Menu -> More -> Settings. There I found a setting that says "Save new contacts to" and for me it was set to phone, so I changed it to gmail, issue resolved. :)
     
  12. westaustin

    westaustin New Member
    5

    Sep 8, 2010
    1
    0
    5
    Various
    Austin
    Where do you see that menu? I have a Galaxy (ver. 2.2.1) and I've looked in the phone menu, Gmail menu, and contacts menu, but there's nothing like that to be found.
     
  13. thornev

    thornev Well-Known Member
    53

    Nov 20, 2011
    309
    98
    53
    Hudson Valley, NY
    Oh great. Now every contact is duplicated on my phone. How do I remove duplicates without deleting one by one?

    UPDATE - figured it out... People > select dropdown arrow to left of Add > uncheck "Phone" > press capacitive back button. Now I see only Google contacts. Hopefully all new contacts I add on the phone now get synched to Google.
     
  14. Gary12345

    Gary12345 New Member
    5

    Feb 1, 2012
    1
    0
    5
    They explained exactly where they found it: Contacts -> Menu -> More -> Settings -> "Save new contacts to".
     
  15. jwbarrientos

    jwbarrientos New Member
    5

    Jun 20, 2012
    2
    0
    5
    In my HTC explorer there's an option called "move your phone contacts to google" (or so, don't remember well).

    Left it running, I'll post the situation later.
     
  16. jwbarrientos

    jwbarrientos New Member
    5

    Jun 20, 2012
    2
    0
    5
    It didn't work?
     
  17. I found it was because I had not ticked the "my contacts" box in the list of contact types - family friends etc...
     
Tags:

Share This Page

Loading...