1. Download our Official Android App: Forums for Android!

Support Phone freezes during app installs?

Discussion in 'Android Devices' started by dcoaster, Jun 23, 2010.

  1. dcoaster

    dcoaster Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    82
    Joined:
    May 15, 2010

    May 15, 2010
    82
    15
    18
    Does anyone else have a problem with their EVO freezing for 15 to 20 seconds when they try to install apps?
     

    Advertisement

  2. Rob_A

    Rob_A Android Expert
    Rank:
    None
    Points:
    113
    Posts:
    825
    Joined:
    May 28, 2010

    May 28, 2010
    825
    216
    113
    New York
    Mine does for about 10 seconds now. Just started this week. Maybe because I have so many apps?
     
  3. eric3316

    eric3316 Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    461
    Joined:
    May 9, 2010

    May 9, 2010
    461
    96
    53
    NC
    I think this is normal. Happens with all of the apps I install. Also did this on my HTC touch with an Android Rom I had running.....
     
  4. dr g

    dr g Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    589
    Joined:
    Jun 7, 2010

    Jun 7, 2010
    589
    187
    93
    The system seems to get quite busy while downloading and installing an app. Be patient for a bit and let it finish.
     
  5. dcoaster

    dcoaster Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    82
    Joined:
    May 15, 2010

    May 15, 2010
    82
    15
    18
    Still... I think it's ridiculous that one of the most powerful phones out there comes to a complete halt for 5+ seconds just to download and install an app.
     
  6. leegseegs

    leegseegs Member
    Rank:
    None
    Points:
    16
    Posts:
    46
    Joined:
    Jun 7, 2010

    Jun 7, 2010
    46
    8
    16
    I agree. I got the same problem on my Evo. Also, I have the issue where when you try to manage your applications in settings, it takes 10-20 seconds for the list of apps to appear. This NEVER happened with my Nexus One. EVO seems a bit laggier than the N1 as well. I'm suspecting that Sense UI is causing all this lag?
     
Tags:

Share This Page

Loading...