1. Are you ready for the Galaxy S20? Here is everything we know so far!

phone ia stuck in bootloop,even recovery not working

Discussion in 'Android Devices' started by xfilestl, Aug 10, 2012.

  1. xfilestl

    xfilestl Newbie
    Thread Starter

    Hi all. I have an evo4g I got from a friend. I'm pretty sure he never tried to root it but Idk how else it could have gotten to this state. When I got it it was stuck in bootloop. When i tried to get into recovery that would bootloop also.I thought maybe I could root it and install a rom to get it working but Im having troubles. It is hboot 2.18 which I managed to unlock, I tried flashing a new recovery, it appeared that it worked because it said "done" or something to that effect and it did not report any error messages,but still when I choose recovery from hboot it goes into bootloop. I flashed the pc36img thing also and now it boots up to the stock sense rom, just to the part where you're supposed to swipe the screen down to load the home page but then it reboots again. If anyone has any ideats please let me know.thanks in advance!!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. xfilestl

    xfilestl Newbie
    Thread Starter

    I forgot to clearly state that its not rooted. Its s-on
     
  3. argedion

    argedion The TechnoFrog

    Try doing a RUU. Hopefully Ocean or one of the many others will give you a link. I'm on phone or I would. Think this may be your best bet
     
  4. scotty85

    scotty85 Extreme Android User

    what PC36IMG did you flash?

    first thing i would try is running an RUU. it may be the same thing you did with the PC36IMG,or it may be newer. running it as a .exe files seems to sometimes work when hboot flashed fail.

    download this: Shipped ROMs

    and run it as administrator on your PC. if it does not fix your boot loops,you prolly have some sort of hardware failure :(

    if the RUU fails with some sore of error,we may need to run a few fastboot comands to see what build you are on. are you up for that?

    if you place the phone in hboot,or select fastboot fromthe hboot menu,i assume that it does not reboot in these modes?
     
  5. Granite1

    Granite1 Zercron Encrusted Tweezer

    If its S-ON the PC36IMG method won't work. Bootloader is still locked down. Need the .exe RUU run from a PC.

    You said the phone boots to sense, then bootloops when you unlock it. It almost sounds like the corrupt NV issues we had with CM8. But if it boots to sense somewhat, I think we can get it. :)

    Please, boot to hboot and post back what is on that screen in its entirety.

    Hboot # alone sometimes won't be enough. If the radio doesn't match sometimes the RUU will fail. Seems screwey, I still don't know why this is. An RUU should overwrite the radios too.

    EDIT: Scratch the above I'm thinking of the unrevoked S-ON tool with the radio matching. :)

    I'll check back in a while when I'm on a pc. Still at work.
     
    xfilestl, scotty85, tube517 and 4 others like this.
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    you are sort of right granite. a ruu is a rom upgrade utility. all its job is to update the device. however, if the radio or software version is new or newer then what the ruu has then it will fail to update. so it will depend if the phone is on 5.07(the latest ota) or 4.67(the previous ota). if it was on 4.67 then the ruu that scotty gave should work. if it is on 5.07 then it will not. i do not think that there is a ruu out for 5.07 yet.
     
    xfilestl, scotty85 and Mikestony like this.
  7. xfilestl

    xfilestl Newbie
    Thread Starter

    Ok guys,

    I tried the RUU and it did not work. The phone has image version 4.67.651.3 which was the same thing the ruu was trying to update it to. I received an "unknown error" when I ran the RUU and it told me to get the correct update and try again, so I am posting my bootloader info as requested.

    *** UNLOCKED ***
    SUPERSONIC EVT2-3 SHIP S-ON
    HBOOT-2.18.0001
    MICROP-041F
    TOUCH PANEL-ATMEL224_16AB
    RADIO-2.15.00.12.19
    DEC 21 2011 12:50:32

    fastboot and fastboot USB do not send me into the bootloop but recovery does
     
  8. scotty85

    scotty85 Extreme Android User

    You'll need to relock to run the ruu.

    with the phone in fastboot,Enter in a cmd window:
    Fastboot oem lock

    Then start the .exe
     
  9. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    before u re-lock it lets try and get you a recovery.

    try this one:PC36IMG.zip

    its amon ra 2.3 that is configured to work with 4.67 and an unlocked bootloader.
     
    xfilestl likes this.
  10. xfilestl

    xfilestl Newbie
    Thread Starter

    Updated the pc36img, bootloader reads *** relocked *** ran the ruin again and I thought it was going to work but when it was around 90% done I got an error [152] I think. When I looked at the phone there was an error updating the radio,but that's not what stopped the update, the updater kept updating the other items after that until it got to the partition. The "partition update fail" caused the update to quit. I'm running the update recovery tool but this time the update is just hanging. I've been letting it hang for 20 minutes so I'm going to try a few more times but I doubt it will work, I'm only going to post anything else if IT DOES work so if I don't post anything else assume it failed.
     
  11. Rxpert83

    Rxpert83 Dr. Feelgood

    Erroring out on a radio install is never a good sign :thinking:
     
  12. iTz Frosty

    iTz Frosty Lurker

    Hello I have just joined as I noticed you guys are currently working on this. I am stuck with bootloop as in blinks a white screen and shuts back off when i attempt both recovery and normal boot. Cannot get anywhere I have tried RUU three times each time is a 171 error cannot find device.. PLEASE HELP THIS IS A WORK PHONE :/!!
     
  13. xfilestl

    xfilestl Newbie
    Thread Starter

    I feel like the internal memory is bad, especially after seeing.g the partition error. If we can't get this thing working it's no sweat, I can use the kickstands and camera lens since MY phones kickstands wont close and my lens is scratched making my camera useless. If I can get it up and running though it would be awesome to have a phone to just experiment on and try things out before I try them on my real phone. Not to mention every one of you knows how important it is to me ego to turn a brick into a smartphone lol.
     
  14. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    hey guys so gonna do this multi quote style
    if it says relocked then the ruu's will not work. you need to have the bootloader unlocked to use the ruu's
    welcome to the forums!!!!!!!!!!!
    so as not to hijack this thread lets create a new one for you. it will be easier for us to help you individually. but please provide us with as much info as possible. we need to know things like, what did you do to get this way?, what is your hboot and baseband(info found in the bootloader)?, are you unlocked, locked, s-off or s-on?

    try and unlock the bootloader again and then try the PC36IMG file i linked in my previous post.
     
    xfilestl likes this.
  15. xfilestl

    xfilestl Newbie
    Thread Starter

    I did that update with bootloader unlocked. It didn't doanything that I noticed.
    I tried the ruin unlocked and it didn't work
    Relocked bootloader as Scotty suggested and ruin almost completed
    Pretty sure I am bricked now. Can't boot at all,normal or bootloader both bring me to a black screen with HTC in the middle and a triangle with an exclamation mark inside of it on all 4 corners of the screen.
     
  16. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    that is actually a good sign. try hooking up the phone to the pc and run the ruu again. the screen you are seeing is what you get when you accept an ota.
     
    xfilestl likes this.
  17. iTz Frosty

    iTz Frosty Lurker


    Ok I just posted one.
     
    ocnbrze likes this.
  18. xfilestl

    xfilestl Newbie
    Thread Starter

    OCNBRZE,
    I tried. I let it sit for about 30 mins with no apparent progress
    It didn't give an error butthe progress bar on the ruin wasn't moving
     
  19. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    ok lets try this then power off then press both vol up and vol down while holding the power button. hopefully you can access the stock recovery. if so there should be a wipe cache option. select that, not sure if you can but lets try it.
     
    xfilestl likes this.
  20. xfilestl

    xfilestl Newbie
    Thread Starter

    No dice,
    Is there a way to wipe the cache from a command prompt?
     
  21. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    you have to be rooted to do that, unfortunately.

    well i'm stumbed at the moment.
     
    xfilestl likes this.
  22. xfilestl

    xfilestl Newbie
    Thread Starter

    the weird thing is this phone was supposedly working fine, the man upgraded to a different phone for his wife, the phone sat around for a while and then he gave it to my stepdaughter and when she charged the phone it started the bootloop. When I started fiddling with it there were no signs that he had tried to root the phone, and from what I understand he isnt the type that would have even tried to root it if he even knew what root means. Thats why I feel like it is a hardware issue, specifically the internal memory. Why else would ruu not be able to partition it? Maybe the phone was exposed to strong magnetic forces, or maybe it is just defective equipment..who knows
     
  23. scotty85

    scotty85 Extreme Android User

    multiquote for me too! :D

    depends on the PC36IMG. if its an unsigned boot,system or recovery image,then you must be unlocked(and the main version on the android info text document must be the same or higher than the phones current main version).

    however,to flash official,signed by htc software/firmware(PC36IMG or .exe) the bootloader must be locked or relocked. running the .exe or flshing a PC36IMG of "rom.zip" wont work if your unlocked

    this is RUU mode. your basically stuck in it because the utility did not complete.

    open your cmd window and use this command to get back to fastboot:
    fastboot reboot-bootloader

    yes(it will work with s-on phones)
    fastboot erase cache

    this^

    im sorry my friend,i believe your phone is toast. ive never seen something with a "radio update fail" work again :(. the radio does not live in flash memory,and a bad flash can bork up that partition beyond simply reflashing it to repair it.

    once youre back in fasboot and out of RUU mode,you can re-unlock with the original unlock token if you still have it. take the image out of the PC36IMG ocn linked,and put it into your adb/fastboot folder. you can try permantly install a recovery:
    fastboot flash recovery recoveryname.img

    or you can try and boot the recovery directory into phone memory:
    fastboot boot recoveryname.img

    if you can get recovery running,you can try whtever tricks ocnbrze had up in his sleeve when asking you to try install it in post #9.

    have you tried a factory reset from hboot?

    after youve tried that,make sure you are starting the .exe in fastboot

    -power on into hboot
    -select fastboot from hboot menu
    -start .exe

    you also may need drivers,if youve never installed htc sync. try installing these drivers from revolutionary

    last and not least,make sure youve got htc sync,and any other program capable of comunicating with the phone disables when youre trying to run the .exe

    then,if youre still having trouble,i can upload the rom.zip and give you instructions to flsh it.
     
  24. hvrc

    hvrc Android Enthusiast

    bringing this one back from the dead as i recently acquired sprint htc evo 4g and it is having the same problems, bootloops during normal boot and recovery, hboot and fastboot are fine, tried ruu, it is giving me error 120, battery under 30%, when it has been charged till the light is green, and have tried a different battery?! exact same info on hboot screen as op........i dont like the looks of this
     
  25. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    what ruu have you tried? do you know what radio you are on? please give us more details. can you get to recovery? if so which one? what rom and kernel were you on before all of this happened?
     

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
0
Reviews
Loading...
Similar Threads - phone stuck bootloop
  1. ByPedro
    Replies:
    8
    Views:
    274
  2. Oguz Kaan
    Replies:
    3
    Views:
    263
  3. Herman Jacobs
    Replies:
    6
    Views:
    933
  4. dilipl
    Replies:
    13
    Views:
    2,892
  5. ramennoodels
    Replies:
    2
    Views:
    3,988
  6. Junaid433
    Replies:
    2
    Views:
    1,489
  7. elfrost
    Replies:
    4
    Views:
    3,150
  8. xaphar
    Replies:
    4
    Views:
    2,384
  9. xXZenGrimWolfXx
    Replies:
    8
    Views:
    2,994
  10. Celestite
    Replies:
    9
    Views:
    2,810

Share This Page

Loading...