1. Download our Official Android App: Forums for Android!

Support Phone is dialing the wrong numbers, but not anyone else in my contacts. Goes to random foreign code.

Discussion in 'Android Devices' started by themessenger, Feb 18, 2011.

  1. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    This just started today and I haven't installed any new apps, or updates or anything. I'm running the 2.2.1 Kernel 2.6.32.9 lg-electronics@balto #2

    For example, earlier today I tried calling someone named Derek. I clicked on the contact and the number that was called was 011-181-26600736. This is only if I click on a contact from the contacts list. This only happens with facebook contact numbers. Numbers that are entered in manually, from the call log, or manually dialed work just fine.

    In the call log, the normal contact number shows like I had called it, when in fact during the call it showed a number like 011-181-26600736 and sent me to the Verizon recording saying to push some buttons to get info on adding long distance/foreign calls.

    Anyone have any ideas?
     

    Advertisement

  2. Viper05

    Viper05 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    127
    Joined:
    Dec 20, 2010

    Dec 20, 2010
    127
    7
    36
    East Coast
    Sounds like a really crazy bug there. Do you have your phone rooted? The first thing I would try is removing the Facebook App and Reinstalling it from the market place.
     
  3. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    Not rooted. Fully stock. After the pushed update of 2.2 I went ahead and did the factory reset and my phone has been loads better. Getting about 2 days out of the battery life now, instead of charging mid day everyday and my camera issues were fixed as well.

    I'll uninstall facebook and reinstall.
     
  4. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    Ok viper, I did as you suggested and uninstalled/reinstalled facebook. The only options available to me were uninstalling the updates. The full app uninstall was greyed out. It didn't fix the bug either. Google searches turn up nothing even similar to my problem. I'm totally lost and it's a very annoying bug.
     
  5. fullhouse233

    fullhouse233 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    27
    Joined:
    Nov 26, 2010

    Nov 26, 2010
    27
    7
    16
    CNC Machinist
    USA, South Dakota
    Do you by chance have google voice installed? I noticed my phone do the same stuff with google voice. I just uninstalled it and re installed and it worked fine.
     
  6. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    fullhouse, i surely do not. i'm at a total loss here. i even set facebook (after the update reinstall) to not sync and then back to sync all and it still has the same problems.
     
  7. kahmikahze

    kahmikahze Newbie
    Rank:
    None
    Points:
    15
    Posts:
    36
    Joined:
    Jul 3, 2010

    Jul 3, 2010
    36
    0
    15
    try going into the phone book itself and making sure those phone numbers do not have ones in front of them, i.e. only the 10 digit number.
     
  8. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    normal numbers. It only does this on numbers pulled from facebook. I've been testing it out since it randomly started happening. If i had to manually enter their name and number into the phone there's no problem. There's also no problem if a facebook contact calls me and i call them back from the call log. This bug has only happened from the contact list.

    EDIT: Upon further inspection there seems to be a "+" sign before the numbers, so they are formatted like this : +1 (xxx) xxx-xxxx. This + is probably causing the problems, right? I'm just confused because I never noticed it before, and I'm not sure if it's there by default, I just know you use the + to dial a country code, which I thought 1 was for the US anyway.

    I also checked in the facebook contacts folder and they are formatted the same way in there as they are in the phone's contact book.
     
  9. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    anyone have an idea why a "+" would be added to all my facebook numbers?
     
  10. death2all110

    death2all110 Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    1,996
    Joined:
    Jun 25, 2010

    Jun 25, 2010
    1,996
    1,210
    313
    Male
    Systems Administrator Windows/Unix
    Illinois, US
    Yeah, facebook does it, so it auto-dials country code if you're outside of the country. I dont use facebook, but i know this isn't a "bug" its a "feature".

    Just a heads up for you, your contacts may not sync with google anymore since facebook syncs the contacts now. and there is no real "easy" way to get the contacts back. so if you delete your facebook account. you lose your contacts.

    Thats why google pulled facebook syncing from the nexus s and later devices with the 2.3.3 update. Facebook uses it's own API instead of Google's, and though Google made an exception for them, they got tired of Facebook doing things like syncing its own way. So now facebook has to change the way contacts are handled and make it interface with the contacts API google made before they allow facebook sync back on the later devices.

    For anyone who wants to argue this isn't true: http://www.engadget.com/2011/02/22/google-disables-contact-sync-in-facebook-for-android-only-nexus/

    Also, this seems terrible right now, but if facebook complies, the contact sync will be much smoother.

    YMMV
     
  11. cajones1

    cajones1 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 25, 2011

    Feb 25, 2011
    2
    0
    5
    This just started happening on my Mom's Ally as well. And of course, I get the support call from her :) So as an example, she has a contact entry for my Dad in her contacts with his cell number formatted as normal (no +1 in front). Well the Facebook sync is bringing down the same number from his facebook info and adding it to his contact entry as +1-xxx-xxx-xxxx. The Ally is using this as his primary number and seems to be ignoring the same number from the manually entered contact info. And as the other posters have mentioned, clicking on the +1-xxx-xxx-xxxx number to dial it results in a failed call cause the Ally formats the number as +011-xxx-xxx-xxxx in the phone app and Verizon doesn't like that. And of course, you can't edit the facebook portion of the contact.

    My Mom is not technical and has nothing added to her phone. No Google Voice, no third party apps beyond Angry Birds for her grandson to play, no root, etc. Purely a stock phone.

    Guess I should also mention that I have a Motorola Droid, but it seems to handle the contact numbers a little differently in that I do see the two contact numbers for my Dad in my contacts, the regular format xxx-xxx-xxxx plus the one from facebook +1-xxx-xxx-xxxx. However, unlike the Ally, the Droid seems to use his regular format number instead of the facebook one.
     
  12. TT1080i

    TT1080i Member
    Rank:
    None
    Points:
    18
    Posts:
    71
    Joined:
    Jul 12, 2010

    Jul 12, 2010
    71
    19
    18
    for me it's google voice that adds the +1
    I am using google voice for visual voice mail and other items.
    And if I miss a call that is "not in my phone book" it logs it with a +1 before the number. Because it is being delivered by google and not verizon.
    So In order for me to redial I must dial with out the 1.
    And if I save as a contact I edit the number delting the +1....
    then all works fine....
    And the next time that number calls. Since it is already in my phone book the "1" never comes into play
     
  13. xOPtimUsZErOx

    xOPtimUsZErOx Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jan 13, 2011

    Jan 13, 2011
    13
    1
    16
    Digital Film Maker
    Lubbock, TX
    i'm having this same issue but it is happening to all of my contacts...not just contacts that are from facebook. Has anyone found a fix for this i'm running a stock 2.2 ally. It is really making me contemplate rooting the phone but i have no means to do so since there are no programs for mac to do so. :(
     
  14. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    Well I rooted the other day, flashed Velocity, which did not come with facebook. I downloaded it, resync'd my contacts and it's still doing it. It's SO FRUSTRATING because it has basically ruined the phone part of my cell phone. It wasn't always doing this, something had to change to cause the malfunction. I really wish someone could find a fix for this bug.
     
  15. companionlink

    companionlink Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    137
    Joined:
    Feb 9, 2010

    Feb 9, 2010
    137
    16
    38
    I'm not positive this will work in your case, but I've seen it help with similar issues: there's an app in the Marketplace called Prefixer (link) that can essentially adjust the phone number on the fly, based on rules you set up. It doesn't really get rid of the bug that's there with your FB contacts, but it at least patches it in a way. At the end of the day it's free, so it's worth a try. Hopefully it will address the problem for you!

    - David Z
     
    audio2u and themessenger like this.
  16. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    David, I tried prefixer but I can't get it to work. I'm not sure if it's because of the phone, but I'd say it's probably user error. I tried the remove + rule, but it didn't work. I'm guessing I just set it up incorrectly. Could you maybe give some instructions on exactly how it should be set up if you use the app?
     
  17. companionlink

    companionlink Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    137
    Joined:
    Feb 9, 2010

    Feb 9, 2010
    137
    16
    38
    Unfortunately, I personally don't have enough experience with the issue/app to be able to offer specific setup help :/. I have seen it fix the "Facebook issue" before, however, which is why I suggested trying it here. Have you tried starting from any of the templates found on the Prefixer website here? The setup of a rule has the potential to be somewhat confusing. They do have a pretty solid help page though, which may be able to offer some assistance in setting up a rule that works for you.

    Hopefully this will help! Perhaps someone who's used Prefixer more extensively can chime in?


    -David Z
     
  18. adh

    adh Lurker
    Rank:
    None
    Points:
    6
    Posts:
    8
    Joined:
    Mar 4, 2011

    Mar 4, 2011
    8
    1
    6
    I'm having the same issue. Yesterday, my Droid 2 Global suddenly started inserting +1 before all the numbers synced from Facebook. I haven't changed any settings or anything. And now I basically can't make legit calls unless I manually dial the numbers. Will try uninstall/reinstall of Facebook.
     
  19. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    Ok, I had it set up incorrectly. Unfortunately, the rule templates on the 253 below site that David linked to is to ADD the + sign for international callers. I'm assuming that this is the reason the + sign problem has been popping up for us American callers because they were trying to fix a problem for international callers. Anyway, here is how to fix the problem (At least for me)

    Download Prefixer


    Menu > Add rule > Outgoing calls

    When number matches ".*" (that is "period asterisk") > hit ok and scroll down to actions

    Remove Characters > \+ (forward slash+)

    That fixed it for in my calls! Thank You David! I have never had a problem with my texts getting through to my facebook calls, and unfortunately if you do I do not think prefixer will fix that problem for you.

    I also added the same rule, but for the incoming calls. I didn't really have a problem with the + sign being on my call log since prefixer automatically fixes the outgoing call with the previous rule when I go to call them back, but I just didn't ever want to see that damned + sign again!! lol
     
  20. adh

    adh Lurker
    Rank:
    None
    Points:
    6
    Posts:
    8
    Joined:
    Mar 4, 2011

    Mar 4, 2011
    8
    1
    6
    I tried uninstalling/reinstalling FB with no change. I'd rather not have to install some other program to fix a problem caused by Facebook. I'm worried I'll forget about pre-fixer and it'll cause other problems later. I'm just not that savvy. Any other idea?
     
  21. themessenger

    themessenger Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Dec 29, 2010

    Dec 29, 2010
    86
    8
    16
    I've been using it for two days and it's caused no problems. I've even shut off my phone.
     
  22. mickey72

    mickey72 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jan 23, 2011

    Jan 23, 2011
    3
    0
    5
    I had this issue and removed my facebook account. Then I added it back but chose not to sync my facebook contacts.
     
  23. audio2u

    audio2u Newbie
    Rank:
    None
    Points:
    36
    Posts:
    42
    Joined:
    May 3, 2010

    May 3, 2010
    42
    5
    36
    Audio engineer and photographer
    Sydney
    Woohoo for prefixer!
    I'm in Australia, and have noticed that some (but not all) of my mobile contacts had had the leading zero (our mobile numbers are formatted as 04xx-xxx-xxx) replaced with +61 (Australia's country code).
    This causes the call to connect, but not to the party you're actually trying to call!
    I didn't realise, until reading this thread, that it was a Facebook issue.
    But thankfully, Prefixer has done exactly like it said on the box!
    To ADH, I can understand your thinking of not wanting (or liking) to install an app to fix someone else's problem. Fair point.
    But the great thing about Prefixer is that you can turn any rule you've constructed on or off, on a whim.
    So, you create a rule to replace +61 with a zero, and if at some point you find that you need that rule to be ignored, you simply go apps/prefixer and turn that rule off temporarily (or until you want it back on).
    I found it fairly simple to work out,
    YMMV.
    Thanks companionlink for the tip!
     
  24. companionlink

    companionlink Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    137
    Joined:
    Feb 9, 2010

    Feb 9, 2010
    137
    16
    38
    Glad to hear it has helped! :) Now if Google/Facebook would just fix this strange bug in the first place...


    - David Z
     
  25. AssertiveBard

    AssertiveBard Member
    Rank:
    None
    Points:
    16
    Posts:
    89
    Joined:
    Dec 25, 2010

    Dec 25, 2010
    89
    6
    16
    Dayton, TN
    I'm having the same exact problem, except it isn't with out of country numbers. This is really aggravating.
     
Tags:

Share This Page

Loading...