1. Are you ready for the Galaxy S20? Here is everything we know so far!

Phone is refusing to root!

Discussion in 'Android Devices' started by Corvette, Dec 20, 2011.

  1. Corvette

    Corvette Newbie
    Thread Starter

    So I've become fed up with Gingerbread on my X. Ever since I got it via the OTA pushed update, the phone has been GARBAGE. Most of the time it's just so slow, it's unacceptable. It freezes very often and takes several seconds to process, scrolling menus and live wallpapers are often choppy, and text messaging has become nearly impossible because of absurd keyboard lag. When the phone was running Froyo, it was GREAT! Everything was perfect. But now it's ruined.

    So I've opted to root the phone and install a custom rom that's Froyo based. But for some reason it seems that the phone is refusing to root. I've tried 'one click root' and 'script v7' on my Windows XP PC, both of which are supposed to root the Droid X so long as it hasn't been rooted before (which it hasn't).

    But with either application, I get the same result. It 'runs exploit', the phone turns off and goes into bootloader, and then stays there. It never reboots. If I reboot manually, it boots normally and goes into Gingerbread, but the phone still isn't rooted.

    What do I need to do?

    To recap:

    Droid X, running OTA Gingerbread 2.3.3, never been rooted before.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. trophynuts

    trophynuts Extreme Android User

    Welcome to AF and lets get you fixed up. Start here
     
  3. Corvette

    Corvette Newbie
    Thread Starter

    Thanks. Followed the instructions in that thread and I'm having the same problem.

    - I downloaded and unzipped all the necessary files.

    - I used RSD Lite to flash the phone with '.602 SBF', which was successful.

    - I successfully entered recovery mode, deleted the cache and user data.

    - I successfully rebooted the phone.

    - I programmed the phone by dialing 1 (it requires you to before you can use OS)

    - I skipped google sign in and enabled USB debugging.

    - I connected the phone to my Windows computer.

    - I started Pete's Motorola Root Tool and selected ROOT.

    - The root tool completes step one (exploit) and then proceeds to reboot the phone. The phone reboots, but goes straight back into the bootloader screen as though it didn't reboot.

    - I have to disconnect the cable, reboot it manually. When I reboot manually, the OS starts (it's still Gingerbread, not sure if it's supposed to be Froyo since sbf?) and from what I can tell, the phone still isn't rooted. I am lead to believe it is not rooted because after installing Bootstrap and attempting bootstrap recovery, it gives me this error:

    Error running exec().
    Command: [su, -c, ./data/
    data/com.koushikdutta.
    droid2.bootstrap/files/
    surunner.sh] Working
    Directory: null Environment:
    null
     
  4. Corvette

    Corvette Newbie
    Thread Starter

    I am very persistent. So I tried other methods after I failed with the one that seems to be most popular.

    I SBF'd back to 2.2 Froyo and then used Z4Root to gain root access. I now have rooted Froyo, and I have Rom Toolbox Premium which seems to be a great root app that allows you to search roms and install them, etc. but it appears that the one entitled 'Liberty Froyo' is corrupted, since Clockwork says it's 'bad' and aborts the reflash.

    It's my understanding that I cannot flash a Gingerbread based ROM because I'm now running a Froyo kernel, so can someone direct me to a good, reliable Froyo rom that I can install and have no problems with?
     
  5. festerw

    festerw Member

    Try deleting the file and downloading again, if it still doesn't work Apex 1.4 is a great option.
     
  6. UrsusVIIILXXXVII

    UrsusVIIILXXXVII Android Enthusiast

  7. trophynuts

    trophynuts Extreme Android User

    the .602 sbf is gingerbread.



    Also if you want to stay on Froyo that is fine however you may run into snags here and there just because Froyo nor its Roms aren't supported any longer by most Devs. That doesn't mean that a Froyo Rom won't work it just means if there is an issue with it that it isn't going to get fixed.
     
  8. cougar214

    cougar214 Android Expert

    corvette use script 7 again to root the phone. You may have better results. Other than the root issue how is the phone running?
     
  9. Corvette

    Corvette Newbie
    Thread Starter

    Thanks! I'll check on the list and download a few Froyo roms, move them onto my SD card and see if they'll flash.

    Thank you. I figured as much... but most apps that I need will all work on Froyo because they were developed in Froyo. I'm not the type that stays current with all the most cutting edge apps. I need my phone to do a few important things, and I need it to do them well. ADW launcher, Handcent, Opera, American Express, Alarm Clock Plus and my various widgets should all work on Froyo. Or at least I hope.

    Actually I did try this before I went Froyo, and script 7 also did not work. In fact I tried both of Pete Souza's root tools (the old psouza4 tool and the new one) and script 7 as well.



    Question. Now that I'm on Froyo again, do I have to worry about Verizon pushing another Gingerbread OTA update? If so, is there a way I can avoid this? Also, can I not even load a rom and just stay on stock Froyo without fear of losing it?
     
  10. cougar214

    cougar214 Android Expert

  11. Idunno

    Idunno Android Enthusiast

    All you have to do is unplug the usb cable in between reboots so it doesn't go into bootloader. I ran into this same issue.
     

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
0
Reviews
Loading...
Similar Threads - Phone refusing root
  1. joshhumble
    Replies:
    4
    Views:
    264
  2. godlovingman
    Replies:
    7
    Views:
    323
  3. Rgarner
    Replies:
    4
    Views:
    364
  4. Bobgto65
    Replies:
    8
    Views:
    404
  5. Jeff Jot
    Replies:
    11
    Views:
    384
  6. limone99
    Replies:
    16
    Views:
    360
  7. Cindy Bennett
    Replies:
    15
    Views:
    430
  8. ByPedro
    Replies:
    9
    Views:
    516
  9. Oguz Kaan
    Replies:
    3
    Views:
    353
  10. nickdalzell
    Replies:
    15
    Views:
    555

Share This Page

Loading...