1. Download our Official Android App: Forums for Android!

Support Phone keeps switching back to 3G when on WiFi at home

Discussion in 'Android Devices' started by jetfactor, Apr 1, 2011.

  1. jetfactor

    jetfactor Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    96
    Joined:
    Feb 28, 2011

    Feb 28, 2011
    96
    7
    16
    When I'm at home and connected to WiFi, my optimus v should stay connected to it and not bother going back to 3G ever, correct? That was the case with my old phone until I dropped it in water and got a replacement.

    This new phone, for whatever reason, swaps back to 3G when the screen sleeps even though it should be staying on. Last night I figure that was a source of battery drain where it didn't need to be. What's up with this? As soon as I wake my phone up and slide it open to home screen it instantly goes back to WiFi. Why isn't it just staying?

    I put mangelow's Network app on it to have a quick toggle from CDMA/EVDO and tried a few different settings, and still didn't solve the problem.

    Any ideas?

    Thanks!
     

    Advertisement

  2. Starfire70

    Starfire70 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    3
    Joined:
    Mar 6, 2011

    Mar 6, 2011
    3
    3
    6
    Did you change you WiFi Sleep Policy to never sleep or leave it at default which turns WiFi off when the screen goes out?

    Go to Settings > Wireless & networks > Wi-Fi settings > Press your Menu Soft Key and select Wi-Fi sleep policy and change it to Never.

    Then your WiFi will stay on when the screen times out.
     
    Jenny Z, MacFett and jetfactor like this.
  3. greg4android

    greg4android Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    565
    Joined:
    Mar 10, 2011

    Mar 10, 2011
    565
    36
    68
    Retail
    Middle Tennessee
    Turn Mobile Data OFF in the networking profile. Its the last item on the list (scroll down). Uncheck Mobile Data, 3G will be turned off.
    I never seen a need to have 3G on when I was on wi-fi. waste precious battery resources.

     
  4. digitaljeannie

    digitaljeannie Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    109
    Joined:
    Mar 26, 2010

    Mar 26, 2010
    109
    28
    43

    I agree. It sounds like the OP needs to change the Sleep Policy to "Never".
    Tho, after you hit the Menu button, select "advanced" and then select "Wi-Fi Sleep Policy"
     
  5. jetfactor

    jetfactor Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    96
    Joined:
    Feb 28, 2011

    Feb 28, 2011
    96
    7
    16
    thank you, you're completely right. I totally forgot I did that with my original phone.
     
  6. smankins

    smankins Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    215
    Joined:
    Mar 9, 2011

    Mar 9, 2011
    215
    29
    43
    3G will automatically shut off when WiFi is turned on and it will come back when you shut down WiFi. I don't know if this is what you want but I thought I would throw it out there.
     
  7. MacFett

    MacFett Android Expert
    Rank:
    None
    Points:
    223
    Posts:
    3,236
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    3,236
    740
    223
    Male
    Worshipping Cthulhu
    Sietch Tabr
    Thanks for this.
     
Tags:

Share This Page

Loading...