1. Check out our companion app, Forums for Android! Download from Google Play

Support Phone keeps write-protecting microSD card

Discussion in 'Android Devices' started by MSmart, Sep 3, 2012.

  1. MSmart

    MSmart New Member
    Thread Starter

    Sep 3, 2012
    Washington, D.C.
    Yesterday, I rebooted my phone. That is, turned off the phone and held the power + T keys. I have a 16 GB SanDisk MicroSDHC that was working perfectly up until then. Then, when I put it into my computer to add files and such, it locked up and said something like "Please insert disk into drive H:".

    I tried formatting it with Windows and a program from SDcard.org, but no luck because apparently, the card is write-protected. I've checked the switch a million times, and the problem is not the reader itself; it worked fine with another card of the same brand.

    I was successful in formatting and adding files in Puppy Linux 5.3.3, but the moment I put it back into my Gravity Smart, it becomes write-protected and formatted all over again. But it's not doing that with this other card I have. What gives?


Share This Page