1. Are you ready for the Galaxy S20? Here is everything we know so far!

Phone not recognized by computer, HELP!!

Discussion in 'Android Devices' started by sammyj1516, Sep 14, 2011.

  1. sammyj1516

    sammyj1516 Lurker
    Thread Starter

    Please help....Im beginning to think I shouldnt have been allowed to buy this phone!

    When I connect my phone to the PC it wont register the device as a phone its just showing that a camera has been recognised not a phone. Do I need to get a SD card before the PC will recognise it or does my software on the PC need sorting out? Also how do you get Samsung Kies onto the PC.

    Im starting to think I should have stuck with my iphone despite loving the S2. This is driving me mad cus I just cant figure out this problem.

    Any advice would be greatly appreciated! (If you can use simple terms, that would be helpful) :)
     

    Advertisement

  2. Hawker

    Hawker Android Expert

    Have you installed the dreaded Kies software yet?
     
  3. sammyj1516

    sammyj1516 Lurker
    Thread Starter

    No where and how do I get that?? Should i have had something in the box with the phone??
     
  4. Sydney99

    Sydney99 Android Expert

    available on samsung website
     
  5. sammyj1516

    sammyj1516 Lurker
    Thread Starter

    Right thanks......I'll get the husband onto it later, theres less chance of things going wrong that way x
     
  6. Hawker

    Hawker Android Expert

    Its Kies, Sammy. Unfortunately there is EVERY chance it will go wrong! :(
     
  7. Remeniz

    Remeniz Android Enthusiast

    I tried Kies out but you just dont need it. It's pretty much 'bloatware'.

    Go into Settings then Wireless and network then USB utilities then press Connect storage to PC...... and follow the instructions.

    You'll need the USB lead handy and a spare USB socket on your PC but it's much easier to connect this way.
     
  8. petey1001

    petey1001 Lurker

    I have this same problem. My previous HTC was always recognised by the computer as a storage medium. The S2 only shows up as a GT-I9100 camera. I go to Settings/USB utilities and get "USB mass storage" Tap button below to copy files between the computer and SD card, the button saying Connect storage to PC. I tap and the message is connect USB cable, which I do - all going well so far.

    Next screen tells me I have connected via USB. On the computer screen pop up two Removeable Disk icons which, when clicked on, say Please insert a disk into drive X. The button on the G2 screen is Turn on USB storage Clicking that gives no difference to the computer icons, as only a Turn Off USB storage button is there.

    I am trying to figure out how to load music onto the thing. I tried it when I had no SD card, and today with a 32Gb Sandisk. Is that the problem? Do I have to format the card? If so, how?

    Hoping someone can help.
     
  9. rakesherajan

    rakesherajan Lurker

    Do not Plug in your usb before doing these steps

    Go into Settings then Wireless and network then USB utilities then press Connect storage to PC, now plug in usb n in few seconds it ll connect. Believe me it works.

    Though replying late, may be this information will be usefull for new users facing the same problem.
     
Loading...
Similar Threads - Phone recognized computer
  1. khatauli
    Replies:
    0
    Views:
    44
  2. sammiller
    Replies:
    0
    Views:
    118
  3. Snakeyeskm
    Replies:
    6
    Views:
    191
  4. Bradleyr1000
    Replies:
    2
    Views:
    175
  5. DroidRick
    Replies:
    15
    Views:
    560
  6. Lav Leon Hudak
    Replies:
    6
    Views:
    1,320
  7. Thomas Miller
    Replies:
    3
    Views:
    2,704
  8. MWX
    Replies:
    0
    Views:
    616
  9. bigvictorio_
    Replies:
    1
    Views:
    499
  10. Jcanotorr
    Replies:
    1
    Views:
    597

Share This Page

Loading...