1. Check out our companion app, Forums for Android! Download from Google Play

Phone not working following root/unroot and hard keys not working properly - please help

Discussion in 'Android Devices' started by julespilot, Nov 20, 2011.

  1. julespilot

    julespilot New Member
    Thread Starter

    Nov 20, 2011
    Hoping someone can help. Yesterday I used the methodology on galaxys2root.com to recover my soft bricked phone (after using a jig) and it worked great, took me back to stock. I was thinking that I wanted a rooted android version 2.3.5, so I flashed this kernel: full Wipe package has: PDA: XXKI3| Modem/phone: XXKI3| CSC: OXAKI3 ... from xda-developers … unfortunately it changed the way the buttons work (back button no longer worked, had to keep hitting home to go back) and I didn’t like it (I didn’t realise that this was not for the AT&T version of the galaxy s2, rather the international version) … anyway, I tried to go back to stock AT&T version using the same methodology that had worked earlier, figured I’d stick with 2.3.4 and then use Max's/zedomax's root methodology (same website) and put CWM back , had to use my jig to get into download mode as the up/down/on buttons now just re-boot the phone. I managed to get the stock version on there, the back button now works, but the up/down/on buttons still don’t work properly, they just re-boot the phone instead of putting it into download mode or factory menus … any chance you have a fix for this?

    Another major problem is that the phone calls, rings and connects, but the caller can't hear me and I can't hear them, so it's absolutely useless as a phone … please help. thanks.

    Additional issue ... I can't seem to mount my SD card any more either ... guess I just qualified as a royal noob idiot ... appreciate any help. For what it's worth, I can use Odin, but haven't yet managed to get Heimdall to run, so an Odin kernal that fixes everything would be awesome.

    UPDATE: ... managed to resolve phone functionality and button issues by flashing a stock version of 2.3.5 ...


  2. rbstimers

    rbstimers New Member

    Dec 3, 2011
    Wow! i can not thank you enough! you saved me big time! i'm beside myself! For anyone else who comes along search for "androidadvices Samsung Galaxy S2 i777 2.3.5" on Google to find a source

    it was easy and worked perfectly! I now know the difference between a galaxy 2s international and a galaxy 2s at&t

Share This Page