1. Download our Official Android App: Forums for Android!

Support Phone provided wifi hotspot unreliable

Discussion in 'Android Devices' started by kye, Sep 18, 2011.

  1. kye

    kye Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Sep 18, 2011

    Sep 18, 2011
    5
    0
    5
    The phone provided Wifi-hotspot works, but only for seconds.

    Other devices are able to connect to the SGS2 hotspot, they are able to retrieve a couple of KB data, like opening a first small web page.
    But shortly afterwards, the other device reports that the hotspot has been disconnected.

    I've tried to rule out every possible cause that could disturb the connection.
    I've uninstalled every app that has the slightest chance of messing with the Wifi connections, and tried to enable/disable background data.
    No change.

    For testing, I took the same SIM card, inserted it into another Android phone (HTC Desire Z), set up the hotspot using the exact same settings, and things work just fine.

    This is very frustrating, because everything else on the SGS2 works great. I need it to work on my SGS2, because I need it to work with 3G when I travel to the US (my desire z doesn't support US 3G frequencies).
    I had recently switched to the SGS2 for this very purpose.

    I don't know what else to try?
    Any ideas?

    It's a SGS2 provided by Vodafone Germany, no apparent branding, besides some apps preinstalled.
    GT-I9100, Android 2.3.3, baseband I9100BUKG1, kernel 2.6.35.7-I9100BUKG2-CL342890 root@DELL102 #2
    Build GINGERBREAD.BUKG2

    Thanks a lot
    Kye
     

    Advertisement

  2. kye

    kye Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Sep 18, 2011

    Sep 18, 2011
    5
    0
    5
    FYI:

    Whenever the other device reports that it disconnected from the SGS2 hotspot, the SGS2 probably notices problems, too.

    Because if I go back to SGS2 settings, and choose to disable the wifi hotspot, it does this:
    - it clears the checkbox (no longer checked)
    - the text shown in the menu below "wifi hotspot" changes to "Error"
    - but the blue notification icon in the toplevel status bar remains visible!

    In order to remove the wifi notification icon, I must enable the wifi hotspot once again, and disable it once again.

    This is just an additional annoyance. Disabling/reabling doesn't help with my other problems.

    The Wifi Hotspot is unreliable after seconds.

    I've continue to uninstall even more apps - still same problems.
     
  3. kye

    kye Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Sep 18, 2011

    Sep 18, 2011
    5
    0
    5
    After more testing, it seems the problem is specific to Wifi connections between a hotspot provided by the Samsung phone, and the Nokia Symbian phones I have tested.

    Samsung SGS2 Wifi hotspot (Android 2.3.3)
    - other Android phone: works
    - Linux computer: works
    - ipad: works
    - Nokia Symbian S60V3 devices: failure
    (connect ok, data transmission failure shortly after)
    (tested with two devices, Nokia E71 and Nokia X6, both fail in the same way)

    HTC Desire Z Wifi hotspot (Cyanogenmod Android 2.3.3)
    - all clients can transfer data just fine, including the Nokia Symbian

    Why would the Samsung hotspot fail only with specific clients, and why would other Devices with similar Android release work fine?
     

Share This Page

Loading...