1. Are you ready for the Galaxy S20? Here is everything we know so far!

phone says Contacts Sync-ed but has zero

Discussion in 'Android Devices' started by coyote2, Apr 3, 2019.

  1. coyote2

    coyote2 Newbie
    Thread Starter

    While helping my dad (which entailed adding his google account to my phone) I mistakenly let my phone sync his contacts, so to get rid of them I got rid of all my phone's contacts*.

    Then I turned on Contact Sync for the one google account I want contacts from, and it says it Sync-ed, but when I open Contacts on the phone I still have zero instead of the hundred+ contacts I've confirmed are in the Google Account.

    Incidentally, the Contacts I need to Sync onto the phone are *not* from the phone's primary google account. They are instead from the google account I use gmail with (a work-associated Google Aps account).

    *I don't recall exactly the steps I googled to do so, I think I turned off Contact sync on my phone's google accounts then dumped data on some setting screen.

    Android 6.0.1
    ZTE Z718TL
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    well you can have both google account(gmail accounts) on your phone that way you have both contacts. if you are still logged in with your primary gmail account, your contacts should still be there.
     
  3. svim

    svim Extreme Android User

    Try setting up the Contacts app on that phone all over again, from a 'clean start'. Go into the Settings >> Accounts menu and be sure any Google accounts that are there have the syncing for the Contacts entry disabled. Now go into the Settings >> Apps menu, find the Contacts app entry, tap on 'Force stop' and then find the 'Clear data' button and tap on that. Clearing data will remove the app's cache and all its previous settings/configuration files, basically returning the app to its original, first time used state. You might also want to check the app's Permissions options to confirm the necessary items are selected. (i.e. Contacts, Phone, SMS, etc.)
    Now go back into Settings >> Accounts, open the Google account you want to sync with, and enable the Contacts entry. Start up the Contacts app and see if the correct contact entries will start importing.
     
    ocnbrze likes this.
  4. coyote2

    coyote2 Newbie
    Thread Starter

    Thank you very much for the reply, svim, to help this Android noob! That certainly sounded like the right next step, but it didn't work* (I still/again have zero Contacts now that I re-enabled the Contact app).

    *Even after I retried the process after turning on *all* the Contact App's permissions (including Calendar, Location, and Read Email Attachment).

    I noticed something odd. Before trying this process the Contact Sync for the desired google account /said/ last sync was the current time (whenever it tried, including when I manually invoked "Sync Now"); now it just keeps (after every Sync) saying "Last synced 3/31/19 11:21 AM" (5 days ago).

    p.s. If the next step would be to remove/re-add all the account(s), in what order do I add the (particularly Primary, not the one whose Contacts I want on the phone) accounts so Primary remains Primary? (Weeks ago I added an account and the Primary account lost it's primacy.)
     
    #4 coyote2, Apr 4, 2019
    Last edited: Apr 4, 2019
  5. PitCarver

    PitCarver Android Expert

    Before you start manually adding your contacts, be sure to check the settings in the contacts app, itself. Look for something like "contacts to display".
    They might be there but a setting might not be displaying them.
     
    ocnbrze likes this.
  6. coyote2

    coyote2 Newbie
    Thread Starter

    Yikes, I never let myself imagine I'd need to do that!

    Thanks very much for this, PitCarver! I see everything from all my accounts is set to display.


    While in Settings, I noticed "Import from storage"; I suppose that might work. Maybe it would then sync new contact changes in the account? (Sounds implausible now that I typed that(!).
     
  7. PitCarver

    PitCarver Android Expert

    I'd be willing to bet that would restore if you had previously saved your contacts in a vcf document. That's how I always back up mine.
     
  8. coyote2

    coyote2 Newbie
    Thread Starter

    Thank you very much for your reply, PitCarver. I didn't disagree with your bet that manually importing (a CSV file didn't work, as you said I needed to use a VCF file) using a saved file would work (if by that one means get the Contacts in the file onto the phone).

    But I didn't think that would fix Sync, and now that I tried it I found it didn't fix Sync. In other words I just put all the contacts (from a VCF file saved on my PC) on my phone, added a contact on my PC, did a Sync on my phone, and the new contact didn't get onto my phone (which still says "Last synced 3/31/19 11:21 AM").
     
    ocnbrze likes this.
  9. coyote2

    coyote2 Newbie
    Thread Starter

    OK I fixed it by deleting the account and re-adding it. (By "fixed it" I of course mean that now the phone syncs changes to the account's contacts.)

    But then (since the contact account is the phone's secondary, and IIRC the last account added becomes primary) I also deleted and re-added the primary account. (Last time this secondary/primary thing came up I tried to switch the primary assignment by googling countless relevant pages, but I could never find the right setting screen in Android 6.0.1 to do so.) Is there an easier way to make an account primary, please?
     

ZTE Z837VL Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...
Similar Threads - phone says Contacts
  1. Milo Williamson
    Replies:
    3
    Views:
    227
  2. Nomad of Norad
    Replies:
    2
    Views:
    263
  3. MACo852
    Replies:
    6
    Views:
    412
  4. CharlesLewis
    Replies:
    3
    Views:
    359
  5. Wax Bean Tycoon
    Replies:
    3
    Views:
    314
  6. jo69
    Replies:
    19
    Views:
    567
  7. behrprofl
    Replies:
    2
    Views:
    966
  8. billdz
    Replies:
    3
    Views:
    2,421
  9. sesami230r
    Replies:
    2
    Views:
    1,514

Share This Page

Loading...