1. Are you ready for the Galaxy S20? Here is everything we know so far!

Phone stuck at blue screens (Use the Emergency recovery function..." or Download mode (Odin))

Discussion in 'Android Help' started by eclaircissement, Sep 8, 2019.

  1. eclaircissement

    Thread Starter

    I have a Samsung Galaxy A3 (SM-A320FL). For the past several hours, I've been trying to flash stock rom through Odin. I have no idea why, but all attempts failed. After the first or second attempt, I tried to reboot the phone, but it got stuck at a black screen with a message saying "Device storage corrupt, the data partition has been corrupted", asking me to factory reset. There was a reset button, which eventually brought me to the same screen after pressing it.

    I tried following other people's directions by reinstalling Samsung drivers (drivers were most likely not the problem since my phone got detected by Odin), factory resetting via twrp, which couldn't be done because it failed to mount /data. I couldn't even repair /data BEFORE flashing stock rom, that's why I tried flashing stock rom in the first place.

    After all of that, my last resort was trying to flash a few more times, once putting in AP file only and once only BL and AP. I probably tried flashing too many times because I can't even enter twrp since turning off the phone quickly leads you to a blue screen with an error sign and the text "An error has occured while updating the device software. Use the Emergency recovery function in the Smart Switch PC software." I tried installing Smart Switch and connecting it with my phone, but it doesn't support my phone. Though I don't think it would have saved me.

    So, am I a murderer? Is there any other way to save my phone or can I schedule a funeral?

    1. Download the Forums for Android™ app!


  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    wow that sucks......so do you still have access to twrp? how did this happen in the first place?

    just remember that all is not lost if you still have access to twrp.
    GameTheory likes this.
  3. eclaircissement

    Thread Starter

    I thought my phone had problems that were related to rooting (which was probably not the case), so I tried flashing stock rom, as some people have suggested me to do this. I might have selected the wrong type of stock rom (wrong region perhaps?) and flashed it too many times. I didn't think flashing it for ~6 times would ruin my phone, but it did.

    Like I already said, I can't access twrp. I can access download mode though.

    My phone is officially bricked.
    #3 eclaircissement, Sep 16, 2019
    Last edited: Sep 16, 2019
  4. GameTheory

    GameTheory Android Expert

    Yes, and I'm charging you with homicide in the first degree. Punishable by forcing you to use iPhones. :p

    All jokes aside, is your phone still recognized by ADB, and is the bootloader unlocked with access to fastboot?

    Reason I ask is because with fastboot there's still a chance to save your phone. It would allow you to flash twrp recovery which you can then use to flash a rom to get booting.
    ocnbrze likes this.
  5. eclaircissement

    Thread Starter

    Oh please, no, you don't have to be so cruel!

    I'll try to see if what you said works tomorrow after work. Thanks for giving me some hope!
    ocnbrze and GameTheory like this.
  6. eclaircissement

    Thread Starter

    Sorry for the long delay! I just tried to see if my phone is still recognizable by adb. It is not. Should I still try flashing stock rom (the right version/region this time)?

Share This Page