1. Check out our companion app, Forums for Android! Download from Google Play

Support Phone thinks it is charging

Discussion in 'Android Devices' started by champions, Nov 22, 2011.

  1. champions

    champions Member
    Thread Starter

    Nov 5, 2011
    Hey all, my phone thinks it is charging, but it isn't plugged in. I noticed because it would make the "just plugged in" beep, but constantly. The little lightning bolt is in the battery bar indicating charging. The beeping has stopped, but the charging light is still annoying me. Also not sure if it really is charging if plugged in.

    Also very hard to turn on now. When I try to power it on I just get the battery status screen. If I plug it in and then try to turn it on sometimes it will turn on.

    Anybody heard of this?

    I have pulled the battery, but that didn't help.



  2. yahhboy

    yahhboy Well-Known Member

    Sep 3, 2011

    Take it and get an exchange. You sir, have a lemon
  3. det1726

    det1726 Well-Known Member

    Apr 9, 2011
    PC Server and Parts, List hard drives on Ebay
    Canton, MI.
    This happened to me once. I powered off the phone then pulled the battery and used my screen cloth to wipe it and the battery compartment down then put it back in turned the phone on and have not had this issue again.
  4. marixxaa

    marixxaa Well-Known Member

    Jul 12, 2011
    Chili's To-Go Specialist; Full-time Student
    Los Angeles, CA
    My mom has been having the same issue for about 2 months now. Its getting really annoying!!! Today the worst thing happpened, it wont go past the "Samsung" after the "Metro PCS Unlimit yourself" jingle, its just stuck there. If you push the volume though it sounds like if your putting the volume up or down, and something her phone even rings when we call it. hoping someone can help me with this
  5. mlbrundi92

    mlbrundi92 New Member

    Dec 11, 2011
    I just had this problem myself and tried almost everything suggested online to no avail (clean miniUSB port, take out battery etc, etc). Only had Admire for barely two months. Anyway, problem started suddenly and went on for several days- constantly beeping and saying it was charging when not plugged in. Called Samsung and they said before exchanging the phone to perform a FACTORY DATA RESET. Said it may or may not work depending on what caused your problem. This will reset phone to the original settings when you got the phone. You will need to reload all applications you initially loaded when you got the phone. THIS TOTALLY HAS CLEARED UP MY PROBLEM! Phone is great now. Here’s what I THINK happened with me: I was totally paranoid about letting my phone charge down and was constantly charging my phone – at home, in the car to and from work; and at work! Crazy. Also, I was using 2 other chargers that DIDN’T come with my phone. Suggest only using the Charger that comes with your phone. This is just my guess after discussing with Samsung. Samsung tech was great by the way.
    Here’s instructions:
    1. Remove SD card first. To do this: Be at your main screen. Press MENU key (bottom left key); hit SETTINGS, then STORAGE, then UNMOUNT SD CARD, then OK. Remove your SD card (open the access “door” on bottom left side of phone (says MICRO on it) – to remove card push it IN and it will pop OUT! J)
    2. Make sure you have your CONTACTS backed up (like into Yahoo or Gmail where you can sync them back later). Make sure you back up whatever else you need. Didn’t have a lot on my phone, but I WROTE DOWN APPS AND PHONE SETTINGS: wanted to remember to set back the way I had them. It will be important for you to remember to after the reset to reload an ANTIVIRUS app and a TASK KILLER app!
    3. Perform Factory Data Reset: press MENU key, then SETTINGS; PRIVACY; FACTORY DATA RESET. I think it then says “are you sure” – answer yes and follow any prompts. Didn’t take that long. Phone will do its thing resetting.
    4. Once your phone is back on – remount SD CARD. Follow instructions as in #1 above, except it will now say to MOUNT SD CARD or something like that.
    5. Remember to reload an ANTIVIRUS app and a TASK KILLER app, any other apps; to resync your Contacts and reset your phone settings to the way you prefer. I was told if you purchased apps they will still be available for you to reload – didn’t have any bought apps myself so can’t confirm.
    I sure hopes this helps at least someone, because I thought I was going to lose my mind there for several days! I’m happy I tried this before going through all the trouble of returning/exchanging my phone. Good luck!
  6. ibsky

    ibsky New Member

    Sep 5, 2012
    FYI: There is another thread on this topic at "Samsung Admire indicates "being charged" even though it is unplugged from the charger"

    I too have a Samsung SCH-R720 from MetroPCS that constantly beeps because the phone thinks it is charging even though the charger is unplugged. The white light in the charging icon goes on and off with the the annoying beep.

    Others alluded that the problem is the center prong of the micro-USB connector touching the bottom. I used a toothpick to bend the prong up a bit and but that did not fully solve the problem. I inserted a micro-USB connector without connecting the other end to 110v but the darn annonying beep still happened.

    At this point I am not sure of the solution but am a bit leery about the Reset solution.

    David W. Caulkett
  7. cholo4390

    cholo4390 New Member

    Jan 30, 2012
    hello everyone i just have the same problem with a few clients Admire that was having the same issue, the problem was the phone usb port middle pin that was touching the bottom metal just try to see if you can lift a little bit just a little bit; do it gently or you can broke the pin, hope this help you

    ps; you can use the usb charger just plug in and lift a little bit
  8. chancelarose

    chancelarose New Member

    Oct 25, 2012
    Port Huron
    I also had the same problem with my Samsung SCH-R720 :mad:
    I try doing the 'Factory Reset'. That had no effect, so don't even try it.
    Trying to lift the prong doesn't work either.

    Solution: Try using something to push the prong into the phone and that should work. But BE CAREFUL!! You don't want to ruin your phone!
    That is what I did and my phone is working just as it should :D
  9. rhino889a

    rhino889a Well-Known Member

    May 30, 2012
    Somewhere in the Internet
    I cleanded my connections with rubbing alchohol. I am always outside and dusty. Alot of dirt had been rubbed onto the connecter pins. I think the dirt may contain metals. So buildup may cause small arching in the connections.
  10. lionrain

    lionrain Well-Known Member

    Dec 13, 2010
    I had this exact problem my admire, after a couple of resets, it had just run its course. It just went away, maybe it will do the same for you.

Share This Page