1. Download our Official Android App: Forums for Android!

Support Phone will not turn on

Discussion in 'Android Devices' started by mdc7213, Aug 7, 2013.

  1. mdc7213

    mdc7213 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 7, 2013

    Aug 7, 2013
    3
    0
    5
    I have 2 Premias and they both have failed within the past week. I have tried using different chargers I had laying around, bought brand new chargers, still nothing. One I can take out the battery and plug it in to wall charger and it tries to boot but just gets stuck at the Huawei screen. When I try to press power button it flashes 3 times red. I've only had these phones 45 days and they started randomly powering off and on after 2 weeks. Any suggestions?
     

    Advertisement

  2. Tokenpoke

    Tokenpoke Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    3,110
    Joined:
    Feb 10, 2011

    Feb 10, 2011
    3,110
    1,157
    313
    Male
    Arborist (tree man)
    Miami, FL
    Have you rooted?
    Have you tried getting into stock recovery?
     
  3. mdc7213

    mdc7213 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 7, 2013

    Aug 7, 2013
    3
    0
    5
    I have not rooted the phones and I don't know how to get into stock recovery, I'm a newb
     
  4. henrytamayo

    henrytamayo Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    206
    Joined:
    Mar 25, 2013

    Mar 25, 2013
    206
    41
    43
    Male
    hold power and both volume buttons when turning on your phone thats how you get into recovery
     
    mdc7213 likes this.
  5. henrytamayo

    henrytamayo Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    206
    Joined:
    Mar 25, 2013

    Mar 25, 2013
    206
    41
    43
    Male
    but i suggest you take them back to metro
     
    mdc7213 likes this.
  6. mdc7213

    mdc7213 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 7, 2013

    Aug 7, 2013
    3
    0
    5
    Yes I have tried this and it did not work. I'm taking them both back and trying to resolve it that way.
     
  7. Tokenpoke

    Tokenpoke Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    3,110
    Joined:
    Feb 10, 2011

    Feb 10, 2011
    3,110
    1,157
    313
    Male
    Arborist (tree man)
    Miami, FL
    I'm becoming more convinced that there is a batch of bad processors out there.
    I've run across two more non rooted phones that randomly reboot and one that mysteriously stopped working after rapidly overheating while running a psx emu
     
  8. coozfactory

    coozfactory Lurker
    Rank:
    None
    Points:
    6
    Posts:
    3
    Joined:
    Apr 17, 2013

    Apr 17, 2013
    3
    1
    6
    I've had issues with my battery only after rooting.

    Scenario: phone plugged onto charger, in standby mode (on but the screen is off and I'm not actively using it). The battery didn't charge overnight and instead drained. Took battery out for a few minutes and put it back on the charger - same issue. I couldn't even get it to boot into CWM recovery. I have to leave it on the charger for like 15 minutes before trying to boot into recovery, and even then the battery reads either 0% or 1%.

    Plugged it into a USB charger (came with the phone) and same problem. Left it on awhile and was able to finally boot into recovery with battery at 11%. But the phone wouldn't start from the power button without going into recovery first. As soon as I reboot from recovery, it works and charges normally.

    Any suggestions?
     
  9. Pidasso

    Pidasso Newbie
    Rank:
    None
    Points:
    16
    Posts:
    45
    Joined:
    Aug 12, 2011

    Aug 12, 2011
    45
    1
    16
    Rooted it immediately and removed all the bloatware possible and it worked flawlessly until about the 27th day. Then it shut off, i went to restart and got the red light blinking three times and then nothing. I left it off and connected to the nearest charger (my pc) after about 30 min IRS booted into recovery on its own, I forget exactly what option i chose, something similar to (reboot to system) sorry I am new and don't have all the correct terms etched into memory yet. Anyway it started and seemed normal until it completely quit the next day, no lights, nothing...well except for a faint bzzz vibration if you r&r the battery then hold the power button for 3,4 maybe 5 seconds...took it back to metro and they sent me home with a new one free of charge since it was under 30 days and i had the option of a full refund for any reason. There was somebody else in the store with another dead premia ..to me it looks like they are having a hardware issue. I was also informed id this one fails after my 30 day mark i will be charged to replace it..even though its still under warranty....won't worry about it until there is a failure.
    Please excuse multiple errors I this post, i have always had a qwerty slide out keyboard and have two thumb typing down to a science..this Swype and on screen is still frustrating ..better but still 1\8 of my two thumb speed plus wayyy more errors to edit
     

Share This Page

Loading...