1. Are you ready for the Galaxy S20? Here is everything we know so far!

Phone won't charge after 2.2 update...

Discussion in 'Android Devices' started by Elisha63, Aug 3, 2010.

  1. Elisha63

    Elisha63 Lurker
    Thread Starter

    I haven't seen this issue reported anywhere else so here it goes...

    I just updated my phone to froyo last night and had no apparent issues. When I woke up I noticed that despite charging the phone overnight the battery was dead. I was able to start the phone up with the charger plugged in. This is when I found out that the battery won't receive a charge. I have tried using the standard plug as well as plugging the usb cable into the computer; no dice. The lightning bolt on the top right of the screen is there, but the green slice on the battery that constantly recycles is stuck. I tried a master reset on the phone and that didn't work either.

    Anyone else encounter this issue? Any ideas how to fix it? I bought my phone at Best Buy, and of course they are all sold out in the area, so it will be a major pain getting a replacement (I'm within the 30 day window). I'd appreciate any ideas.

    1. Download the Forums for Android™ app!


  2. mkampy

    mkampy Android Enthusiast

    I had a completely opposite issue, I plugged in the charger to dl update, and when it was done it was fully charged ( it was in mid to low 90's when I started)

    But it is charging for me at the moment.
  3. teky

    teky Android Enthusiast

    Ignoring the battery icon, is the LED indicator coming on (the amber one) to show it's charging?
  4. Elisha63

    Elisha63 Lurker
    Thread Starter

    Yes, the amber light is on.
  5. teky

    teky Android Enthusiast

  6. Elisha63

    Elisha63 Lurker
    Thread Starter

    Thanks for the heads-up I'll check it out.
  7. Elisha63

    Elisha63 Lurker
    Thread Starter

    Still not charging... I wonder if the battery went?
  8. angelpire

    angelpire Lurker

    I'm having the same problem. At first it wasn't even saying it was charging at all and the lightening bolt wasn't showing up on my battery icon. I removed the battery and now after putting it back in, it says that it is charging, and the lightning bolt is showing up on my battery icon, however, it doesn't appear that it is actually charging (Still stuck at 5%.) the only running service I have is the keyboard. When I unplugged it to see what was using up all the battery, it says the Display at 62%, Android system at 26%, Standby 6%, Mediaserver 4%(I assume this is my multimedia station stuff, but don't really know) and Android OS 3%.

    I've never rooted my phone, and don't have a task killer app installed, which others have indicated may be the cause of the problem on other forums.


    It seems to be charging now. If it keeps a charge, I'll let you all know. If it doesn't, I'll try some of the tips in that post you linked to Teky.
  9. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Welcome to the forum, wish the circumstance was happier.

    We've seen a few possible causes for this:

    1. Bad usb cable or charging port might be going bad. Surprising as it sounds, people have usb cables fail more often than one might think and because we're always doing something on our funny-acting Android phones, we always want to trust the cable. It's always a great place to start, though.

    2. The fact that it started to somewhat act right after a battery pull indicates a process might be stuck. This link gives the full procedure to deal with that - it's not 100% guarantee, but it's worked for an overwhelming percentage of these cases:


    3. Take this as parallel in importance with the one above: you may have done an app update recently and it's gone rogue, for whatever reason. I've had that happen myself. Truth is that Android is running far more processes/services than the simple tools will ever suggest to you. For example, for a non-radio-related app, I had my phone go nuts in power consumption because in the background it was trying to validate a 4G connection MANY times per minute (I don't _have_ 4G!) and wifi was cycling on/off in less than a second. Sometimes, finding and re-installing the bad app can help - sometimes you have to go to the How-to-fix-Froyo advice (and sometimes even then installing apps one by one from the Market).

    4. You could have a corrupted SD card directory, and you can fix that on your PC (Win or OS X) - surprising that the SD card could affect you that way, but not if you have an app (such as your media player) that's actually getting a little lost trying to access something on the card.

    That's all I've got off the top of my head - post back your observations.

    PS - Not knowing your usage or background - are you a Facebook user? Many have reported trouble related to that.
  10. sagedil

    sagedil Android Expert

    Fwiw, and I know.it won't really help. Had exact same problem when I dated to .3. Charging just stopped working. Have 4 spare batteries and 2 wall chargers so no real issue.

    Did the .3 to .6 update and problem fixed itself. Strange. But thought I would share.

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date

Share This Page