1. Check out our companion app, Forums for Android! Download from Google Play

Support Phone won't power on, but it can charge.

Discussion in 'Android Devices' started by mightybryan, Dec 25, 2012.

  1. mightybryan

    mightybryan New Member
    Thread Starter

    Aug 4, 2011
    Hello fellow XDA members.

    I've been with my beloved Nexus S for a little over a year now. We've been through thick and thin. Until now.

    My power button is broken (along with a lot of other nexus s users that I found out by research), but I was able to bare with it by maneuvers with my software (volume rocker wake). It would act as if it's being pressed down constantly, so it would automatically power on when a battery is inserted.

    However, this situation is different. I've done research on this one too, and it also seems common. While using my phone as normal (around 20% battery), the screen just turned black and the phone crashed. Seemed like a common kernel issue. So I battery pull, and the phone won't power on.The charging animation still appears if I connect it to a charger or USB.

    As I woke up for work the next morning, I brought my phone along with me. It turned on at a random time while it was in my hand, as it would always do if I were to insert a battery. The phone worked for about a week until the same problem happened again.

    I've tried rebooting it with ADB, but it's not recognized. I've tried inserting the battery while it's connected to the charger. Nope. Simultaneous button presses, pounding the power button, you name it. I've also tried a different battery, so I know it's not a battery issue.

    I have suspicion it has to due with Jellybean, as several other users experience a problem similar to mine, but much more severe (no charging animation).

    I'm running Pacman Rom v 18 with Marmite 7.0 Kernel.

    Please, for the love of the Lord, can someone please aid me in finding a solution or inform me of a known one?



  2. Thats

    Thats That guy is This

    Feb 19, 2010
    Air Force
    Fargo, ND
    Welcome to AndroidForums Bryan, Sorry to hear about your phone. So is your power button completely shut into the phone, so the phone believes that the button is always being held on? Is that correct?

    Also: Merry Christmas! I'm glad you came here, we'll be able to jumpstart that baby back (HOPEFULLY :) )

Share This Page