1. Download our Official Android App: Forums for Android!

General Phone won't rotate to landscape

Discussion in 'Android Devices' started by RickDD, Dec 18, 2009.

  1. RickDD

    RickDD Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 13, 2009

    Dec 13, 2009
    2
    0
    5
    I've had my Eris for a week now, first it quit playing videos, and won't animate weather radar, now it won't rotate to landscape mode, this makes typing with my fat fingers tough, anybody have any cures or solutions ??

    Rick
     

    Advertisement

  2. thelion

    thelion Member
    Rank:
    None
    Points:
    15
    Posts:
    63
    Joined:
    Nov 28, 2009

    Nov 28, 2009
    63
    0
    15
    Funny, mine rotates to landscape when I don't want it to. And yes, my G sensor is calibrated. Especially with Handcent, it rotates to landscape and WILL NOT rotate back.

    I am really starting to regret this phone. The Droid had issues but at least it rotated properly.
     
  3. jjr1968

    jjr1968 Member
    Rank:
    None
    Points:
    16
    Posts:
    48
    Joined:
    Dec 15, 2009

    Dec 15, 2009
    48
    6
    16
    mine rotated fine at first, then once it didn't, somehow, the setting was "unchecked". I didn't touch any settings. Once I "checked" the option, it hasn't been a problem.
     
  4. Jon_E

    Jon_E Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 3, 2010

    Mar 3, 2010
    3
    0
    5
    My phone will not rotate to landscape mode, either. It used to work, but it stopped for no reason. I've tried recalibrating and turning off the phone. No dice. This has to be an Android bug. I've seen this question several places on the web with no definitive answer on how to fix it.
     
  5. Rubik76

    Rubik76 Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    546
    Joined:
    Feb 10, 2010

    Feb 10, 2010
    546
    158
    93
    Make sure that, when you calibrate the G-Sensor, the phone is laying flat on a level surface (e.g. on a table, camera lens touching the table top).

    G-Sensor calibration is Settings > Sound and Display > Bottom of the list

    It may take a second or two for the display to swap between portrait and landscape at times.
     
  6. Jon_E

    Jon_E Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 3, 2010

    Mar 3, 2010
    3
    0
    5
    Thanks for the reply, but I've recalibrated the phone precisely that way several times to no avail. It is stuck in portrait mode. (Yes, my trackball is on the right hand side, and yes, I waited a full minute).

    The phone is an HTC Eris w/ Android 1.5.
     
  7. Jon_E

    Jon_E Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 3, 2010

    Mar 3, 2010
    3
    0
    5
    I feel kinda stupid for not finding this earlier, but here is the fix:

    Settings -> Sound & Display -> Orientation (about halfway down)

    Checked, it will auto-rotate to landscape.
    Unchecked, it will stay in portrait.

    I don't ever remember changing this setting, but there it is. Works fine now, and I like my Android again.
     
  8. davros

    davros Android Enthusiast
    Rank:
    None
    Points:
    58
    Posts:
    486
    Joined:
    Jan 3, 2010

    Jan 3, 2010
    486
    15
    58
    Mr Mom, and when I do work, Screen Printer
    Central Mass
    Sense UI will never rotate btw
     

Share This Page

Loading...