1. Are you ready for the Galaxy S20? Here is everything we know so far!

phone won't switch to wifi [solved]

Discussion in 'Android Devices' started by jaliy, Aug 11, 2012.

  1. jaliy

    jaliy Android Expert
    Thread Starter

    sometimes i look at my phone and turn the screen on to find that it's still on 3g when i am at home. once the screen is on, then it turns wifi on. it happens quite a bit actually.

    does the phone only switch to wifi when it's not in sleep mode?

    update. as it turns out, that place had another wifi called dlink, which is exactly the same as my home wifi. therefore, the phone tried to connect to that, failed cause of password, so it will not connect to my home wifi again. if i change the ssid of my home wifi, it will auto connect
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hawker

    Hawker Android Expert

    Perfectly normal. It proves to you that it is behaving like it should and that it IS switching to wifi. Your policy is set to "only when plugged in"
    If you don't want this to happen, set your wifi policy of keep wifi on during sleep to "always"
     
  3. jaliy

    jaliy Android Expert
    Thread Starter

    My wifi is set to always by default
    I dont want to rack up data usage at home when i have wifi
    How do i fix this
     
  4. Hawker

    Hawker Android Expert

    Even if you set it to only when plugged in, you wouldn't rack up data usage when your screen is off and you are still in range of your router as the wifi connection would take priority for any background activity requiring data.

    Not sure why your icons switch over if your policy is set to always. I can only think it might have lost wifi signal temporarily.
     
  5. jaliy

    jaliy Android Expert
    Thread Starter

    I once woke up and found 3g stayed on all night even tho wifi is available
    Only when i press the home button i see the wifi icon appear and it says connected to wifi
     
  6. jaliy

    jaliy Android Expert
    Thread Starter

    i just did another test.

    i rebooted my router and purposely let me phone go into sleep mode. when the router is back on, i press the home button and i see the 3g icon is still on. then i see the wifi with my network showing "authenticating..." and then "aquirring IP address..." then "connected to wifi"

    so if i don't wake up the phone, i will be on 3g for as long as the phone is in sleep mode. however once i establish the connection, it will stay on wifi even in sleep mode.
     
  7. Hawker

    Hawker Android Expert

    Not necessarily. As you say you have the "always" option set in the wifi advanced settings then It just proves that your phone has dropped wifi connection and during this time it did not request any external data.

    Your phone is set for wifi to sleep when screen is off...somewhere. you must have some 3rd party app (eg. Juice defender) that is putting wifi to sleep.

    Even so you will not be using any data during this time as long a your router is on and you are still within range. The only time data will take a hit is if you actually turn off wifi on your phone, or turn off your router.
     
  8. jaliy

    jaliy Android Expert
    Thread Starter

    i'll say this again. MY PHONE IS SET TO ALWAYS KEEP WIFI ON DURING SLEEP. so my wifi stays on AFTER IT'S CONNECTED. the problem is wifi will not connect WHILE IN SLEEP MODE.

    I REPEAT. WIFI IS ALWAYS CONNECTED IN SLEEP MODE. BUT IT WON'T RECONNECT DURING SLEEP MODE
     
  9. Hawker

    Hawker Android Expert

    I am fully aware of what you have set it to. I EVEN MENTIONED IT IN MY PREVIOUS POST. (I can write in caps too!!) :) You do not understand what i am trying to say to you. I think another app is putting it to sleep and your phone did not request any data prior to you turning your screen back on. How do you know it didn't connect in sleep? It may have done so several times during sleep, and that it just so happened it was in sleep mode prior to when you turned your screen back on.

    If you don't have juice defender or similar, Another thing to consider is do you have power saving mode enabled? This might be putting wifi to sleep particularly if you have defined custom settings and your battery is below a certain level.

    If you don't have any of these things set, then i don't know I'm sorry.
     
  10. jaliy

    jaliy Android Expert
    Thread Starter

    Because i open the wifi list before going to sleep mode so i could see what's going on
    When i wake up the phone, i see it authenticating, aquirring ip address and connecting
    Would be pretty hard for wifi to connect in sleep mode without an ip
    And no i dont have juice dedender or power saving options
     
  11. Hawker

    Hawker Android Expert

    That's because your connection had been dropped and your phone is instigating the reconnection process automatically. This is what would happen when sleeping and an app requests data.

    Something is putting your wifi into sleep. If your sure it's nothing on your phone that is doing this then i suggest to have a look at your router settings. Perhaps there is a some sort of connection dropout timeout in it's settings
     
  12. jaliy

    jaliy Android Expert
    Thread Starter

    so u saying my wifi is trying to connect in sleep mode but some app is not letting it by using data?

    first of all there's no app that would do this other than a brief gps location lock. i've seen facebook using data to get my location. but like i said, i've done a few tests where i reboot router and wait for 1 min, 3 min, 5 min and each time i find it trying to connect just as i wake up the phone

    if something is trying to use data on purpose, it would be a hellla coincidence that it happens right before i wake up the phone everytime. i've left the phone in sleep mode all night for 6 hours and it wouldn't connect
     
  13. ironass

    ironass Extreme Android User

    Power Saving mode on the wireless router can cause this behaviour. I know that some Netgear routers, for instance, have this... as well as other models.
     
  14. jaliy

    jaliy Android Expert
    Thread Starter

    my router does not have power saving mode and the transmition power is set to high
    my pc would connect automatically after the router reboot so it's definitely the phone not connecting

    also, i did another test by purposely keeping the phone awake before and during the router reboot. the wifi connects almost instantly after the router is back online and it never disconnect for some mystic app requiring data so it's definitely the sleep mode causing this
     
  15. Hawker

    Hawker Android Expert

    When your wifi is sleeping on your phone, you will basically see the 3g icon on your status bar, as when you wake up your phone it will take a second or two to get the connection set back up.

    So in this sleep state, when a background app requests data (eg. Sync, weather etc) if you could see the screen this is what you would see...your phone re-establishing the wifi connection in order to send/receive the data.

    When you turn your screen back on, all you are seeing is your phone reconnecting to your router.

    now I only see this happening if i set my sleep policy to "only when plugged in". I've not seen this happen on "always"

    So like i said, if your adamant some setting or app on your phone is not setting your phones wifi to sleep, then start looking at your router.

    As long as you are in range of your router even in sleep state you won't incur any data as wifi will automatically reconnect.
     
  16. jaliy

    jaliy Android Expert
    Thread Starter

    i did another test by purposely keeping the phone awake before and during the router reboot. the wifi connects almost instantly after the router is back online and it never disconnect for some mystic app requiring data so it's definitely the sleep mode causing this
     
  17. Hawker

    Hawker Android Expert

    It's not going to disconnect if a "mystic" app requests data. On the contrary, it would enforce a reconnection if it happened to be in sleep mode at the time.
     
  18. jaliy

    jaliy Android Expert
    Thread Starter

    the reconnection failed in sleep mode. that's all there is to it. not sure why u r making this complicated.

    once connected, it will stay connected in sleep mode
    once disconnected, it will stay disconnected until wake up
     
  19. Hawker

    Hawker Android Expert

    But it is not failing. In Your first post you said you see it's in data mode temporarily when you switch the screen on after which the wifi gets turned on. Why do you consider this to be failing?
     
  20. jaliy

    jaliy Android Expert
    Thread Starter

    i never said tempprarily. i said data was always on and stayed on even when i enter wifi range in my home. wifi is suppose to replace data when in range. but since it was in sleep mode, it did not switch
     
  21. Hawker

    Hawker Android Expert

    You didn't say data always stays on even in wifi range. You said once the screen is turned on it turns wifi on. Ergo "temporarily"
     
  22. jaliy

    jaliy Android Expert
    Thread Starter

    yes i did. go read my first post. i said 3g is still on when i go home.
     
  23. Hawker

    Hawker Android Expert

    So when exactly do you see wifi turning back on in your statement in post 1?
     
  24. jaliy

    jaliy Android Expert
    Thread Starter

    when i turn the screen on or wake up the phone
     
  25. Hawker

    Hawker Android Expert

    so you got nothing to worry about then.
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...