1. Check out our companion app, Forums for Android! Download from Google Play

Support Phone won't turn on

Discussion in 'Android Devices' started by ChopaH, Nov 8, 2010.

  1. ChopaH

    ChopaH Member
    Thread Starter

    Nov 8, 2010
    I tried rooting my phone and I think I did it unsuccesfully even though I had super user privilages. I then tried unrooting it last night and when rebooting after the process was finished the phone wouldn't turn on. I tried a battery pull and I when I pressed the power button it would vibrate but nothing comes on the screen. And when its plugged into the computer it comes up as an uknown device. Please help!


  2. NoShftShck16

    NoShftShck16 Well-Known Member

    Mar 16, 2010
    Marketing Analyst/Web Developer/Social Media Analy
    How did you root it? You did unrEVOked right? You may, and I don't want to scare you, have hard bricked your phone...

    Someone who knows how to use a terminal and is familiar with hard rooting process (not the one click root) might be able to do something.

    If not, and you did actually brick your phone beyond repair.

    Here is what I did when I bricked my WinMo. Note: I am telling about my actions, I am not giving advice, just stating what I did and what happened. I am not condoning this type of unethical behavior by any means. What you do is your choice.

    I bricked several Omnia's in my day. But the first major brick was around the time of a Verizon update. Much like the one coming to the Incredible soon. After the update came I went to Verizon and stated that during the update something happened to my phone. I followed all directions but halfway through an error popped up and my phone will no long turn on. No questions asked I had brand new (the only non-refurb phone I got as replacements) Omnia in my hands.
  3. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Aug 5, 2010
    If your phone vibrates once when turning on, that means your phone is turning on but you can't see anything because when you tried to unroot you loaded a kernel that is not supported on your phone. Your phone is most likely fine.

    Follow this thread, start at post #19
    and post #21 has the instructions to get it working (ignore the thing about the RUU)

    P.S. next time do more research on the topic before you mess with a $600 device. A simple search on this forum would of prevented this.

Share This Page