1. Are you ready for the Galaxy S20? Here is everything we know so far!

Plants vs Zombies on SGSII

Discussion in 'Android Devices' started by heshanj, Jun 13, 2011.

  1. heshanj

    heshanj Android Expert
    Thread Starter

    hey guys.. i recently installed plants vs zombies (HD v1.0) on galaxy S2.. it just doesnt work. its the real deal, the 73mb download size. it installs fine.. after this, i run it and i get a black screen, which goes back to the home screen after about 2 seconds. run it again, and it freezes for about 5 seconds before returning to home screen.. please help, as im a big fan of this game! thanks

    btw, im running on KE7 firmware
     

    Advertisement

  2. brad1601

    brad1601 Newbie

    I DL mine from the amazon store and its working fine... sounds like a faulty apk file or something.
     
  3. NZtechfreak

    NZtechfreak Android Expert

    Amazon App Store version running fine for me too.
     
    heshanj likes this.
  4. heshanj

    heshanj Android Expert
    Thread Starter

    is that the HD v1.0 or is there a non-HD one? coz i read that the HD version requires Tegra 2? wondering if that is the problem..
     
  5. adamantell

    adamantell Well-Known Member

    I can't find it in the market? To even download too try
     
  6. eclap

    eclap Member

    If it requires tegra just use chainfire polygon. I'm running the hd version no problem, I have chainfire installed though...
     
    heshanj likes this.
  7. heshanj

    heshanj Android Expert
    Thread Starter

    yeah. but my phone isnt rooted, so i cannt run chainfire.. not until i get down to rooting it at least.. n actually, i double checked my installed version.. it says plants vs zombies v1.0. no HD mentioned anywhere.. just a black screen when i run it and dumps me back on the home screen in a couple of seconds.. no idea wats wrong
     
  8. eclap

    eclap Member

    Mine is the hd but it also only says 1.0.0, no hd...
     
  9. heshanj

    heshanj Android Expert
    Thread Starter

    well then im completely lost! haha. i guess i'll keep trying.. if anyone knows wat could be wrong, plz let me know :)
     
  10. Shocky

    Shocky On Probation

    Try removing the amazon app store and try the game again.
     
    heshanj likes this.
  11. buddygeorge

    buddygeorge Lurker

    Same thing is with me. mine also displays 1.0.0. Specially worried now that Plants vs Zombies 2 is gonna be released soon.
     
  12. dbgt

    dbgt Lurker

    Hi! i had the same problem as you, but i found another version that is 43 mb... and it installed fine, i dont know if its the same version though
     
  13. eclap

    eclap Member

    What is stopping you from rooting btw?
     
  14. heshanj

    heshanj Android Expert
    Thread Starter

    yeah, i found that too. its not the 'official' version, apparently, n the text on that is like.. super small, i couldnt read wat it was saying. lol. maybe i'll go back to that if this doesnt work

    haha yeah, nothing really.. just want to read up about it n make sure i understand the whole thing completely. im totally new to android


    thanks, i will try this and let u know
    EDIT: it worked! i didnt realise it was being blocked. thanks a lot. i guess i dont need the amazon app store anyway, i dont think it works outside the US?
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...