1. Download our Official Android App: Forums for Android!

Support Play store apps not donwloading

Discussion in 'Android Help' started by Mfracher, Feb 19, 2016.

  1. Mfracher

    Mfracher Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    34
    Joined:
    Feb 5, 2016

    Feb 5, 2016
    34
    3
    36
    Male
    I have installed on play store (Using my PC). They are flagged installed, but they are no where to be found on my Android. e.g. Adobe , Google Doc
    LG l33l (Sunset) 5.0 ? with 52% free memory
    Mike
     

    Advertisement

  2. AZgl1500

    AZgl1500 Extreme Android User
    Rank:
    None
    Points:
    618
    Posts:
    6,396
    Joined:
    Feb 3, 2011

    Feb 3, 2011
    6,396
    3,141
    618
    Male
    Retired and loving it.
    Oklahoma grasslands
    If you have had more than one device registered to your PC, it is being sent to the wrong one.

    Been there, done that.....
    Some Play Store apps downloaders will show you a list of devices, most don't... they just pick the 1st one in the list, and it is usually the 1st one you registered on that phone number.

    So, I find the app on the PC, and then I use the Android device to pull up Play Store, find the same app name, and then download it. works every time that way.
     
  3. Mfracher

    Mfracher Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    34
    Joined:
    Feb 5, 2016

    Feb 5, 2016
    34
    3
    36
    Male
    Resolved. Play Store Support (telephone) was fantastic. Tried several data and cache clearing steps. Play store App on the Android would not load. Did several other things with there help. Still not working. The phone is new so the dreaded Factory Refresh was not out of the question. Went to Supper and came back to begin planning the reset and
    All was Good and missing downloads appeared.
     
  4. roadrunner9501

    Rank:
    None
    Points:
    15
    Posts:
    8
    Joined:
    Apr 3, 2011

    Apr 3, 2011
    8
    0
    15
    Male
    truck driver
    Norfolk, VA
    my primary issue is it does not allow me to install games, i just keep getting an error message that says that it can't install to USB storage or SD card. (Error code - 18) however it had no problem installing TurboTax app...hmmm...very confused i can also update apps without a problem so far...i've never had this problem til recently
     

Share This Page

Loading...