1. Are you ready for the Galaxy S20? Here is everything we know so far!

Play Store problems. Help!

Discussion in 'Android Apps & Games' started by BillBadger, Dec 17, 2018.

  1. BillBadger

    BillBadger Lurker
    Thread Starter

    Everything was working fine on my tablet (running android 5.0.1) until a couple of weeks ago when the Play Store locked up while in the process of updating gmail. In the end I had to power off and have made several further attempts but made no progress.

    I tried all the advice on the net which basically seems to consist of variations on clearing data and cache for Play Store and Play Store services but that didn't help. I then tried uninstalling PlayStore updates and was able to update one app (not gmail) but then I seemed to be back where I started in that I was unable to update (or uninstall) and apps. Current version of PlayStore is now 5.1.11 but it doesn't update.

    Lastly, I downloaded the current version of Play Store as an apk but that just hangs during the installation process and after several minutes reports: App not installed. It's like I'm suddenly unable to install, update or uninstall anything all of a sudden. I don't have any anti-virus apps installed or anything like that.

    I'm not sure what else I can do and really need some advice as to how I can fix the problem.

    Would appreciate any help.
     


  2. lvt

    lvt Android Expert

    Do you still have enough of space?
     
  3. BillBadger

    BillBadger Lurker
    Thread Starter

    Storage under Settings says: Available space: 5.63GB
     
  4. lvt

    lvt Android Expert

    So maybe you are encountering a compatibility issue. A recent update made your Playstore app someshat incompatible with your device.

    You can either backup your data and make a factory reset or try all the APKs until you find the one that works for you.
     
  5. BillBadger

    BillBadger Lurker
    Thread Starter

    I uninstalled updates for the Play Store. I'm now way back (and apparently stuck on) 5.1.11
     
  6. lvt

    lvt Android Expert

    If you have problem with Playstore not installing apps, there is an old trick, logout of your current Google account, use another account to see if it works. If it does, you can switch back to your main account. Always works for me on my old phones running JB and Lollipop.
     
    Milo Willamson likes this.
  7. Milo Willamson

    Milo Willamson Android Expert

    ^
    []
    Right as rain. :) Just log out and log back in with your old account that you use, that is why I never bothered with gmail with psn :)
     
  8. BillBadger

    BillBadger Lurker
    Thread Starter

    I tried that and it's made no difference.

    I just tried updating Google Play Music from the Play Store. Downloaded no problem but then just hangs during installation. After about 10 mins returns an message saying Error: Unknown error code during application installation. "-504". 504 usually suggests a gateway timeout I believe but I tried powering my router off and on and also connecting to my neighbour's wifi and it made no difference - Error 504 each time.
     
  9. Milo Willamson

    Milo Willamson Android Expert

     
  10. Dannydet

    Dannydet Extreme Android User

    Try a factory reset
     
  11. svim

    svim Extreme Android User

    Looking at a semi-retired phone running KitKat and another phone running Nougat, the version numbers for the Play Store apps on both are 12.x.x and Play Store Services 14.x.x. My point being if the Play Store app on my old KitKat phone is at ver. 12, it's odd that same app on your Lollipop tablet is still at version 5. Have you been restricting updates in general on your tablet, or allowing them only selectively?
    If yes, that could be a factor as to why that Play Store update failed -- it's not just a matter of that app failing to update itself but there are issues with all the other apps/services that have also been prevented from updating.
    If no and you have been allowing any updates this entire time, it's odd that Play Store app is still at such an old version. Which model tablet do you have?
     
  12. BillBadger

    BillBadger Lurker
    Thread Starter

    The only reason that it's old is because I tried uninstalling all the updates to it when it stopped working. It was the latest version prior to that. Since the updates were uninstalled it's made no attempt to update itself.
     
  13. svim

    svim Extreme Android User

    Ahhh, that does clear up things.
    You might want to try what @Dannydet suggested, a Factory Reset first, but be absolutely sure you have all your saved data and files safely backed up before doing so.
    But again, what model tablet do you have?
    As a last resort you might have to just re-flash with a stock ROM to restore it back into fully functional condition.
     
    Dannydet likes this.

Play Store

Play Store Forum

com.android.vending

READ MORE
Last Updated
Rating
Installs
Loading...

Share This Page

Loading...