1. Download our Official Android App: Forums for Android!

Support Play store stuck on 'download pending' : how to fix it?

Discussion in 'Android Help' started by cdl, Aug 1, 2016.

  1. cdl

    cdl Android Enthusiast
    Thread Starter
    Feb 4, 2010

    Feb 4, 2010
    I have a Sony Z3 dual sim (D6633) running stock KitKat, rooted. I am posting here, and not in Sony's forum, as I understand this is a generic issue which can happen to any phone, and is not Z3-specific.

    I cannot download anything from the play store; the screen is always stuck at 'download pending'. I had this this morning, and deleted all data (settings -> app for google play services, google play, download manager, and download media). It worked this morning, but now I have the same problem and redoing those steps doesn't help. I do have internet access and have tried connected to 4G and to two separate wifi networks.

    I also tried uninstalling Google Play's updates, then re-updating the app, as suggested here: https://support.google.com/googlepl...&ref_topic=6046226#ts=6241336,6241346,6241382
    but to no avail.

    I did a factory reset of the phone just yesterday because of this issue + because some process was stuck in a loop and overheated my phone. I wouldn't want to reset the phone every day!

    Any suggestions? What causes this and why?


    PS Incidentally, this proves we don't need a new smartphone every 6 months - we just need smartphones which work and are stable. But this is not what the industry wants, of course.


Share This Page