1. Download our Official Android App: Forums for Android!

General Play Store Won't Work on WiFi

Discussion in 'Android Devices' started by Todd Kageals, Mar 10, 2016.

  1. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    Guys,

    I picked up a GS7E a couple of nights ago. It's working great but there is one issue. The Google Play Store will not download ANYTHING over wi-fi. It does just fine over 3/4G but not on wi-fi. It will load web pages through Chrome on wi-fi. The issue appears contained only to the Play Store and only on Wi-Fi (at work and at home). Anybody have any idea what is goin on here?

    Thanks,

    Todd
     

    Advertisement

  2. rkkeller

    rkkeller Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    588
    Joined:
    Oct 25, 2010

    Oct 25, 2010
    588
    105
    93
    The Dog Pound.
    What error does it give or what is happening?

    Do you have Verizon? There are some issues reported about this.
     
  3. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    Yes. I do have Verizon. I have also just noticed that one of my two email accounts does the same thing (updates over cellular but won't connect over Wi-Fi). My other email account works just fine on Wi-Fi.
     
  4. svim

    svim Android Expert
    Rank:
     #28
    Points:
    708
    Posts:
    4,829
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    4,829
    4,074
    708
    Illinois
    Regarding Verizon, just to confirm are you referring to Verizon as just your cellular phone service, or both your cellular and your home Internet? Also, have your tried using WiFi at a some other location and you're still having this issue with just Google Play and that one mail account? That might help determine if your problem is related to your phone or to your home WiFi connectivity.
     
    #4 svim, Mar 10, 2016
    Last edited: Mar 10, 2016
  5. Snakeyeskm

    Snakeyeskm Android Expert
    Rank:
     #59
    Points:
    293
    Posts:
    1,741
    Joined:
    Apr 8, 2014

    Apr 8, 2014
    1,741
    920
    293
    Male
    Investment Banking
    US
    Try the following: –
    Go to settings and tap on Wi-Fi.
    In Wi-Fi window tap on MORE.
    In the drop down menu tap on Smart Network Switch.
    Set it to Off.
     
  6. mzdeez10

    mzdeez10 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    4
    2
    16
    Female
    I am having the exact same issue. My service is through AT&T, so it's not a Verizon issue. Also, I had smart network switch off. Any other ideas?
     
  7. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    Verizon in my cellular provider. Cox is my home internet provider. I'd ignore the part about one of my email account being effected (that might be blocked at work). I'll have to try wifi at another location. I have not had the opportunity to do that yet. I don't remember having this issue with my S5.
     
  8. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    Well....glad it's not just me. I'm not even sure who to call for support (Google, Verizon, Samsung, Cox, ?)
     
    mzdeez10 likes this.
  9. svim

    svim Android Expert
    Rank:
     #28
    Points:
    708
    Posts:
    4,829
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    4,829
    4,074
    708
    Illinois
    Oops, never mind my previous response. I didn't catch that you are having this issue at home and at work. Sounds like an issue with either your phone's WiFi or the Google Play app itself. If Snakeyeskm suggestion doesn't work, try going into your Settings >> Application manager and doing a 'Force stop' and 'Clear cache' on the Google Play Store app.

    You might also want to boot your S7 up in Safe Mode. That might at least eliminate the chance something you've installed recently is causing the problem.
    http://www.technipages.com/galaxy-s7-turn-safe-mode
     
    mzdeez10 likes this.
  10. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    I already tried clearing the data and cache. No effect. I'll try safe mode to see if it makes a difference.
     
  11. mzdeez10

    mzdeez10 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    4
    2
    16
    Female
    I tried the force stop, cleared data, cleared cache, uninstalled updates. I just don't know what else to try. I haven't done the safe mode, only because I haven't installed anything new.
     
  12. svim

    svim Android Expert
    Rank:
     #28
    Points:
    708
    Posts:
    4,829
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    4,829
    4,074
    708
    Illinois
    This suggestion is something that's a doesn't have a lot of chance of being a solution to your sporadic WiFi problem but have you tried clearing the system cache partition? As WiFi is more of a system function than a general app function maybe there's just a corrupted file in the system cache partition that needs to be clear out manually.
    http://recomhub.com/blog/how-to-clear-cache-on-galaxy-s7-and-galaxy-s7-edge/
     
    KOLIO likes this.
  13. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    More info: Played around at home for a while. Did a wifi speed test on the phone and got really good results (around 60mbs or whatever the unit is). Downloaded a couple of apps from the Samsung app store or whatever they call it and got superfast downloads. Tried the play store and it WILL NOT WORK THROUGH WIFI. Works fine if I download through the cellular network. I can't have all my apps updating through the cell network! Any way to uninstall/reinstall the play store app?
     
  14. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    Maybe related....The youtube app does not appear to be working on wi fi either:thinking: YouTube runs just fine (very fast) through my home wifi on my Surface tablet but the phone will not load videos when it's on wifi.

    Who would one call for support on this? It's not my ISP as all that stuff works fine on other devices. Google, Samsung, or Verizon?
     
  15. yankies90

    yankies90 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    40
    Joined:
    Jun 3, 2010

    Jun 3, 2010
    40
    1
    16
    Alright I had the same issue. It seems like I found a temporary solution to this problem.
    One thing you can do is to download DNSet app and use this after you turn on your wifi.

    The other option is to tweak your wifi. My router supports "guest wifi" function, and my gs7 works great on guest wifi.

    This problem seems to be from DNS problem of either lollipop or system webview app.
    I do not know when they are going to release an update for this but this is a big problem.
    So try to call samsung support and let them know of this issue.
     
    svim likes this.
  16. mzdeez10

    mzdeez10 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    4
    2
    16
    Female
    My coworker suggested we try deleting our Google account and readding it. I did it at work, but had to wait until i got home to test it. Just updated 36 apps! So...hopefully, maybe that resolved the problem.
     
    rdginto and KOLIO like this.
  17. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    I tried deleting my Google account and just creating a new account when the phone asked. Did a factory reset on the phone, new Google account and still have the same issue.....wtf?
     
  18. mzdeez10

    mzdeez10 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    4
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    4
    2
    16
    Female
    Deleted the account, rebooted phone & readded. I hope it works for you. I feel your frustrations.
     
  19. Snakeyeskm

    Snakeyeskm Android Expert
    Rank:
     #59
    Points:
    293
    Posts:
    1,741
    Joined:
    Apr 8, 2014

    Apr 8, 2014
    1,741
    920
    293
    Male
    Investment Banking
    US
    Try this long shot: –
    in Application manager go to Google play store and delete the data, Force Stop, and then disable. Restart the phone and enable the play store.
     
    seVer likes this.
  20. Todd Kageals

    Todd Kageals Newbie
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    So...I tried:
    2 Factory Resets
    Deleted my Google Account and added a new one.
    Tried all kinds of network settings I found on-line.

    Finally got it resolved by turning on the guest network on my router at home. YouTube and the Play Store now fly....like 10 second app downloads and videos that startup right away. I don't have enough understanding of networks to figure out why it works but it does. I tried switching back to the secured network and it went back to not working. The secure network works for other apps on the S7 and on all my other devices (iPad, surface pro tablet, wife's iPhone, Android Tablet, desktop PC). For example, YouTube will not load videos (but it does load descriptions) on the S7 when on the secured network. Put the S7 on the guest network and it loads videos just fine. However, the surface pro and all of the other devices we have in the house will load videos through YouTube on the secured network just fine. Same behavior with the PlayStore. I assume it's something about the encryption used in my secured network setup? I don't know....at least my apps will update now!
     
    tube517 and svim like this.
  21. Justin0000

    Justin0000 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 12, 2016

    Mar 12, 2016
    1
    0
    5
    I had a similar problem with my Galaxy S7. I found that the google play store was insistent on using ipv6 to communicate, even though I do not have the network to support it. My isp is not a adopter of ipv6, so far. I am not exactly certain what change I made on the wireless router fixed this issue, but its one of two. I dropped the security down to WPA1 (TKIP+AES) from WPA2/1 , and I disabled WMM extensions on the radio. I also made certain pfsense had ipv6 completely disabled. Strangest thing is everything else worked fine, just google play store. I'm leaning towards the WMM. Later.

    Justin
     
  22. mrbigglesworth

    Rank:
    None
    Points:
    6
    Posts:
    9
    Joined:
    Jan 15, 2012

    Jan 15, 2012
    9
    3
    6
    I have been having issues with WiFi with my AT&T internet service. I can use my tablet and streaming devices with no issue but when I try to use my S7 it just wont work.

    One thing that helped which is not ideal is to turn off Bluetooth. Once I did that, WiFi all the sudden started to work. It seems that there might be an issue with Bluetooth interfering with the signal. Hope this works for others too!!
     
    MeatLoafT likes this.
  23. Snakeyeskm

    Snakeyeskm Android Expert
    Rank:
     #59
    Points:
    293
    Posts:
    1,741
    Joined:
    Apr 8, 2014

    Apr 8, 2014
    1,741
    920
    293
    Male
    Investment Banking
    US
    If you are having interference/slowdown on your Wi-Fi when enabling Bluetooth try switching to your router from G mode to N mode. The difference in frequency transmission might help.
     
    MeatLoafT likes this.
  24. bhl62

    bhl62 Member
    Rank:
     #375
    Points:
    28
    Posts:
    83
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    83
    15
    28
    Thanks for the clue.

    My TPLink router had IPv6 disabled and WMM is permanently checked (grayed out). My phone always shows an IPv4 address along with a IPv6 address that appears to be link-local, when connected to my router (Wifi->More->Advanced->IP address at the end of the page). It wouldn't work in that state since Play store services are apparently trying to use the link-local v6 address which cannot be routed.

    On an open network which does work, there is only a single IPv4 address listed, and no v6 link local address, so that lack of confusion would explain why those networks work.

    My ISP (Comcast) does support IPv6, so I enabled IPv6 on the router. Once it picked up a v6 address and the right DNS, etc from the ISP, my S7 Edge now shows an additional two valid v6 addresses in addition to the v4 and v6 link-local addresses, and now works at full speed without any VPN workarounds.

    So, it appears that a combination of multiple adapters (physical/virtual?) in the phone and newer high-end routers that support IPv6 is the root of the problem. There also appear to be two diametrically opposite ways to workaround it:
    1. If your ISP does not support IPv6, disable it on your router and make sure your phone only shows a single v4 address, and no link-local v6 addresses.
    2. If your ISP does support IPv6, enable IPv6 on your router and make sure you are getting valid IPv6 addresses on your phone.
    The real solution is that Samsung/Google need to fix the services so they don't pick up link-local IPv6 addresses and get the phone into this state in the first place.

    Hope this helps.
     
    Luv2Drum and Jinxii like this.
  25. Luv2Drum

    Luv2Drum Lurker
    Rank:
    None
    Points:
    16
    Posts:
    1
    Joined:
    Mar 15, 2016

    Mar 15, 2016
    1
    1
    16
    Male
    bhl62,

    Thanks! That's the answer for me. I tried everything else and that finally solved the problem.

    One more thing to add, At&t DOES support IPv6 and it WAS turned on by default on my Arris NVG589 residential gateway so I did the following:

    Went into router's settings and turned IPv6 off and saved configuration.
    Result: still could not get Play Store to update.
    Turned IPv6 back on and saved configuration.
    Result: It works!!!

    So, for those having this problem, if you see that IPv6 is on, don't just assume that it is not the problem. Go ahead and give this a try.
     
    KOLIO likes this.

Samsung Galaxy S7

The Samsung Galaxy S7 was launched in 2016 and was one of two devices in the lineup. The device features a 5.1-inch display with a resolution of 2560 x 1440, 4GB of RAM, 32GB of storage, and a 12MP rear camera.

Share This Page

Loading...