1. Download our Official Android App: Forums for Android!

Root PLEASE HELP display is draining battery

Discussion in 'Android Devices' started by ianandersen, Jul 15, 2011.

  1. ianandersen

    ianandersen Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jun 7, 2011

    Jun 7, 2011
    5
    0
    5
    Hi,

    I've done some considerable searching and can't seem to find an answer to my problem. My battery breakdown has been extremely skewed ever since I upgraded to a rooted, odexed gingerbread 2 days ago. I have an evo 4g

    Display 74%
    Standby 8%
    Idle 6%
    Android system 5%

    This is causing my phone to run really hot (100F +) without doing a single task (in the awake state on home screen) and the battery is draining faster than i thought possible. I thought it might be because i had old firmware but updated to the latest radio, wimax, and pri this morning. It only seems to have made it worse.

    Any help would be appreciated!!
     

    Advertisement

  2. lesawag

    lesawag Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    268
    Joined:
    Nov 16, 2010

    Nov 16, 2010
    268
    26
    43
    Maintaining peace in my world
    Austin Texas
    First what are you using for a wallpaper? If its a live wallpaper,get rid of it. The other thing I and my daughter have noticed, since we flashed certain roms is, for some reason the automatic brightness is turning it self up many times a day. What is your brightness set to now? Check it a couple of times a day. What do you have your screen turning off at? 15 sec. Might be good for you. What is your up time and awake time on your evo? They should not be the same. Other people here will step in and give ideas too. Goodluck
    If all else fails, I'd flash a different Rom. Not all Roms play nice on every phone. Lots to choose from.
     
  3. ianandersen

    ianandersen Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jun 7, 2011

    Jun 7, 2011
    5
    0
    5
    Thanks for the reply!!

    Funny you should mention that.. Finally gave in; wiped phone and installed a new ROM (fresh evo)

    And actually my up and awake time are the same.. what does that mean and how can I fix it?
     
  4. lesawag

    lesawag Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    268
    Joined:
    Nov 16, 2010

    Nov 16, 2010
    268
    26
    43
    Maintaining peace in my world
    Austin Texas
    It means your phone is not sleeping. That is the main reason your battery isn't lasting. Sounds like you have a rougue app. Running wild. Try going to the market and downloading spare parts. It may give you a pretty good idea what app. Etc is running wild. Read the instructions for it. I seem to remember you need to let it run a few hours to really see what's going on. Have you downloaded anything about the same time these issues started. If you did and can remember what it was delete it and pull the battery. If nothing else start removing apps. One by one. Glad I could help. ;)
    I think I had a brain freeze...just reading spare parts and I'm not sure that's the app. I was thinking of...lol. long day...hang on ill check
    Ok, yes, Spare parts...lol
     
    ianandersen and ocnbrze like this.
  5. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
    None
    Points:
    1,923
    Posts:
    23,595
    Joined:
    May 13, 2010

    May 13, 2010
    23,595
    14,436
    1,923
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    yep spare parts is what you want. check what your partial wakes are. it should list any apps holding a wake lock. also try wiping dalvik cache and cache and see if that helps. any time i get glitches, bugs, errors or something acting weird, i always try that first before doing anything else. more times then not, it seems to work.
     
  6. Granite1

    Granite1 Zercron Encrusted Tweezer
    Rank:
    None
    Points:
    833
    Posts:
    7,159
    Joined:
    Dec 27, 2010

    Dec 27, 2010
    7,159
    7,180
    833
    Male
    Highway Construction Inspection
    Pittsburgh, PA
    It could be the pri. If all else fails we may need to downgrade your pri to 1.77.
    Check spare parts then try a few different roms. If nothing fixes your issue post back here we'll get you going. ;)
     
    ianandersen likes this.
  7. ianandersen

    ianandersen Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jun 7, 2011

    Jun 7, 2011
    5
    0
    5
    Thanks guys.. forums are the way to go for tech help.

    Spare parts wasn't turning anything up and I was having trouble downgrading the PRI so I switched over to CM7. I heard a lot of good things about it and it seems to be playing a lot more nicely with my phone.. No more up=awake so that's a good sign. Display is also sucking less battery.

    I appreciate all the advice!
     
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
    None
    Points:
    1,923
    Posts:
    23,595
    Joined:
    May 13, 2010

    May 13, 2010
    23,595
    14,436
    1,923
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    also i would recommend that you try the timat kernel. it with cm7 has given me the best battery life so far. i was easily getting 18-35 hrs on one charge with moderate to heavy usage.
     
Tags:

Share This Page

Loading...