1. Download our Official Android App: Forums for Android!

Please Help! - Galaxy S7 (SM-G930W8) not working post root and factory firmware reset

Discussion in 'Android Devices' started by tedmihu, Aug 31, 2017.

  1. tedmihu

    tedmihu Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Aug 31, 2017

    Aug 31, 2017
    1
    0
    15
    The past few hours have been a nightmare. I was trying to root my Galaxy S7 (SM-G930W8) so I could uninstall some of the bloatware and install some apks.

    I first went here to try and root my phone. I couldn't find the samsung usb driver but I figured since my phone could connect to my computer and it recognizes it perfectly, it should be fine, so I skipped that step. Through some searches I came across this guide which seems a lot more thorough, so I compared the two guides and decided to follow the latter. That being said I downloaded the version of Odin in the first guide as it seemed less risky to do a one-click root than something more advanced, and since they were both using Odin, I figured there's no harm. Running through the steps I hit "start" in Odin and it started working, but it said "reset" when I clicked start, so I thought that was odd. A few auto-restarts later and it said "pass" but when it started to boot up there was a "recovery is not seandroid enforcing" message in red at the top left.

    At this point I thought maybe it worked, and the second guide told me to look for SuperSU in the apps, but it wasn't there. What's more is the software update no longer worked, and my device status was custom... basically the worst of both worlds. At this point I figured what's best is to find a stock firmware from Samsung. No such luck, even chatting with live tech support, it seems this is only done through kies, smart switch, or the phone itself. I did find something on here which after a painfully throttled 2 hour download, gave me a version of odin they wanted me to use, along with the firmware for my specific model. I went through their instructions word for word, and it seemed to have worked. I booted up my phone, and the status said "official", so I figured it worked.

    Not wanting to have all that time go to waste, I tried doing the 2nd guide, this one again, being really careful not to miss any steps. Same red error message, same custom status. I now have the Samsung firmware so I went back to that, and again the status said official, but now I'm having a whole bunch of issues. The keyboard sometimes doesn't come up, I can't type on it when it does, it comes up really late, the shift key flickers, sometimes it will type one character in, then as soon as I type another, it replaces it, so I can't actually type a string of characters together. The manual software update says failed processing after it tries to register the device. I heard that maybe updating through kies might work, except now I can't get the phone to connect to kies, even after running through the troubleshooter and restarting my computer.

    I'm at a loss. I would love to have a rooted version of the phone but at this point just a functioning factory reset would be heavenly. Any help would be kindly appreciated!
     

    Advertisement

Samsung Galaxy S7

The Samsung Galaxy S7 was launched in 2016 and was one of two devices in the lineup. The device features a 5.1-inch display with a resolution of 2560 x 1440, 4GB of RAM, 32GB of storage, and a 12MP rear camera.

Share This Page

Loading...