1. Check out our companion app, Forums for Android! Download from Google Play

Root please help - trying to root on a Mac

Discussion in 'Android Devices' started by oaklandj, May 26, 2012.

  1. oaklandj

    oaklandj New Member
    Thread Starter

    May 26, 2012
    I've been struggling for the past 4 hours to root my Sensation 4G. I know virtually nothing about phones, but I'm not stupid and I'm good at reading. That said, particularities with my phone or incomplete/outdated instructions have left me in a dead end.

    I was able to successfully unlock the bootloader using HTC's instructions. All that seems to have done is wipe everything I'd ever installed on my phone and return me to a blank slate. Still no root, still S-ON.

    I tried in vain every rooting protocol possible that said it was OSX compliant. Nothing. Nowhere.

    Then I spent over an hour installing a VM with Linux/Ubuntu on it. I tried REvoutionary.io and it would run but stall immediately at "Waiting for device..."

    I tried USB debugging and in charge-only mode. Nothing. Tried in Hboot mode and Fastboot USB modes. Nothing. Still "waiting for device..."

    I read that HTC Drivers aren't necessary for Linux with Revolutionary.io. There is surprisingly almost no documentation on a step-by-step basis for using Revolutionary.io on Linux.

    Can anyone help?


  2. scotty85

    scotty85 Well-Known Member

    Jul 25, 2010
    Best bet is to just borrow a windows PC and run revolutionary. Its a small download,as are the drivers,and takes literally minutes to run.

    Htcdev unlock sucks. To achieve the sensations awesome potential,you really need to be s-off and superCIDed.
    oaklandj likes this.

Share This Page