1. Download our Official Android App: Forums for Android!

Support Please help with strange reset problem

Discussion in 'Android Devices' started by azhk, Aug 15, 2011.

  1. azhk

    azhk Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 15, 2011

    Aug 15, 2011
    1
    0
    5
    Guys, hi

    I have a Samsung Galaxy S on Android 2.2. Lately I've been having this strange problem. About once in 5 days, touch buttons became illuminated themselves. When that happen, I couldn't unlock the phone nor bring on the power switch. After that, the phone turned itself off or sometimes I had to take out the battery. When it turned on again, all my settings were reset to default and couldn't receive calls anymore!

    This happened to me like 4 times within this month. I've tried resetting to factory default but with no avail. I don't know if it's a software or hardware problem or whether I should return it for repair (I'm still on warranty). Is this familiar to any of you? Can you please give me some suggestions what to do?
     

    Advertisement

  2. Martimus

    Martimus One bite at a time...
    Rank:
    None
    Points:
    843
    Posts:
    19,535
    Joined:
    Jul 9, 2010

    Jul 9, 2010
    19,535
    4,045
    843
    Male
    Engineer
    'neath a cactus
    Welcome to the Android Forums!

    Moving your thread to the Samsung Galaxy S forum...
     
  3. biyectivo

    biyectivo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 14, 2011

    Aug 14, 2011
    3
    0
    5
    I am having EXACTLY the same problem. To give more details, this started out of the blue and now it is happening at least once a day. It does not depend on the power level, it does not depend on certain programs running, it seems completely at random.

    Exactly what happens is the following:
    1) Both Back and Menu buttons become lit, and screen is off.
    2) There is no way to un-lit them but a) let the battery run dry or b) power off with the power button.
    3) After powering on, the following happens:


    • All settings in the Settings menu revert to default. This includes (for example) APN, so in my case, the APN disappear and I have no data services. Hopefully I can go to the APN Menu and click on Restore Default APN, which brings 3G/HDSPA back.
    • Custom pages in the Home screen get lost and 8 pages appear by default, with items in page 1 and 2. I guess this also depends by carrier, in my case two widgets (search and network info) appear in the first one along with four icons, and three icons in the second one.
    Quick access icons (the four quick access icons on the bottom toolbar) get reset to default.
    • No applications are uninstalled, settings for applications remain, everything looks "good".
    • The power button, when long-pressing it, brings the turn off menu, but instead of having four options (Power off, Data Network, Flight Mode, ) it only shows Power Off as option. I was NOT able to restore this to the default behavior using the solution shown in other forums (e.g. by opening the dial pad, pressing the code *#*#7594#*#*, enabling the tick box on the menu that pops up, powering off, powering on again, typing the same code and unticking the box.)
    • The only way to restore everything to normal is hard-reset. However after very few hours/days it happens all over again.

    Any ideas on how to tackle this would be GREATLY appreciated. This is Android 2.2.1 (Froyo) with Samsung Galaxy S model GT-19000T and kernel version 2.6.32.9, on Mexico Telcel. Not sure what is the info from the above poster.
     

Share This Page

Loading...