1. Are you ready for the Galaxy S20? Here is everything we know so far!

Please Help

Discussion in 'Android Devices' started by FerpectOval, Nov 1, 2010.

  1. FerpectOval

    FerpectOval Lurker
    Thread Starter

    In flashing a ROM i somehow replaced my recovery .img with the boot.img, and so now my ROM is stuck in the boot screen loop, and whenever I try to go to the recovery screen, it tries to boot the ROM, throwing it back into the loop.

    Since it is not booting, I can't access it using adb, and anything I try and do in fastboot says "remote not allow". Is there any hope or did I essentially brick my beloved eris?

    1. Download the Forums for Android™ app!


  2. dragonbro

    dragonbro Android Enthusiast

    Did you perform a nand backup prior? Can you flash back to that?
  3. FerpectOval

    FerpectOval Lurker
    Thread Starter

    I did not =/ I have and SD card adapter, so I'm going to try and see if I can replace the files on there and see if that works?
  4. erisuser1

    erisuser1 Android Expert

    Now you understand the importance of Nandroid backups.

    You don't need to use an SD card adapter - the Amon_RA recovery boot has a menu item called "USB-MS toggle" - which will allow you to manipulate the SD card from the PC over the USB cable.

    Just be sure to observe the following protocol:

    1) Boot into Amon_RA
    2) Plug the phone into the USB cable to the PC
    3) Wait a little bit, and then choose the "USB-MS toggle" menu item in Amon_RA

    The SD card should appear on your PC as E:, F:, G: (or similar)

    4) Manipulate the E: (F:, G:, whatever) drive as you see fit
    4.5) Wait a few minutes.

    5) Be absolutely sure to use the "Safely Eject Hardware" Control on the PC - and see a "safe to remove" message before you do anything further.

    (Make sure the file explorer is not focused "inside" the SD card E: (G:, H:, etc) drive, or this will prevent the "Safely Eject Hardware" control from working.

    6) Press the trackball button again to turn of the USB-MS toggle in Amon_RA

    If you do not correctly use the "Safely Eject Hardware" control on the PC, you will risk truncating or corrupting files that you transfer to the SD card. Be sure to pay attention carefully and perform the connection-use-disconnection sequence exactly as given above.
  5. scary alien

    scary alien not really so scary
    VIP Member


    I was waiting for you to reply...;) I didn't chime-in with any replies since the OP mentioned in his first post that he messed-up his recovery image "with the boot.img".

    Could it really be that he is simply not booting into recovery correctly or can you actually do what he indicated (and can you actually install two boot images (i.e., actually get a boot image written to recovery to boot-up through the recovery sequence))?

    I'm thinking that your reply would have addressed this had he actually done that...
  6. FerpectOval

    FerpectOval Lurker
    Thread Starter

    Thanks for your help guys. I was entering recovery correctly, there just was no recovery image, as i stated before. I finally managed to flash the boot image correctly through fastboot, and just now re-flashed the recovery image, so all is well. There were no boot images, the boot.img was on the recovery partition, not the boot partition, which was the source of the problem.
  7. scary alien

    scary alien not really so scary
    VIP Member

    I was just curious as to how you did this...:eek: :D (if you want to share...;)).
  8. FerpectOval

    FerpectOval Lurker
    Thread Starter

    well when you go go this:
    adb push recovery.img /sdcard
    adb push flash_image /system/bin
    adb shell chmod 755 /system/bin/flash_image
    adb shell flash_image recovery /sdcard/recovery.img

    replace recovery, with boot.img

    and to fix it i had to fastboot oem boot boot.img and it loaded the ROM correctly.
  9. scary alien

    scary alien not really so scary
    VIP Member

    Ah, thank you for the follow-up...not too many people report using adb to flash things nowadays... I didn't want to assume since you didn't say how in the first post. At least you were savvy-enough to right yourself.

  10. erisuser1

    erisuser1 Android Expert

    You were lucky you had the S-OFF bootloader already on the phone when you borked the recovery partition - otherwise the fastboot booting trick would not have worked.

    Glad things worked out for you.

    BTW, "flash_image" is included in Amon_RA (at /sbin/flash_image) - so long as you have an intact (custom) recovery, you can perform the same "flash_image" steps from within Amon_RA by connecting to the Amon_RA recovery boot via adb (just like the live OS) - in that case the version of the bootloader is irrelevant. You can also use the USB-MS toggle to transfer files to/from the SD card, and "md5sum" is present as a built-in command in the Amon_RA command shell, so you can verify file download integrity after things have been transferred to the SD card.

    There are three entry points to controlling the phone - (1) the Engineering (S-OFF) bootloader, (2) a custom recovery, or (3) a bootable OS with root toolkits.

    Don't leave home without at least one of them!


HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page