Root Pls help! Damagecontrol rom flash ha gone v. Wrong!


Hi guys, firstly thanks for reading this post. I will say before I proceed that this was my first root/flash experience and it didn't go well.

I was using this guide here [Complete Guide] How To Flash A Custom ROM To Your Android Phone With ROM Manager + Full Backup & Restore | Android News, Reviews, Applications, Games, Phones, Devices, Tips, Hacks, Videos, Podcasts - Android Police

And for the Root part I used Instant Root Acess which worked great! gained root access and downloaded a couple of rott access requiring apps to confirm.

Problem arose when I started using the market app ROM Manager. Firstly, when trying to flash the cusom recovery image, Pressing the appropriate menu button brought up a sub menu where i confirmed my phone type but then nothing, the app just stopped. I waited 30 secs or so, TasKilled it and tried again, same thing.

I then took a phonecall which lasted 15 mins or so and came off it to find the custome recover image had now installed in the background, resul I thought.

so I had the DamageControl v ROM in the root of my sd and attempted to flash it. Again the same thing, I could navigate the menus but at the point I expected it to stat working, nothing. Tried several times.

I then entered clockworkmod recovery by holding power and home with the intention of manually doing a nandroid backup and flashing the ROM that way but found it boot straight into the menu i was expected to see (as per the screenshots in the guide) ie DamageCont ROM was installing but to my absolute horror it appeared to have skipped the nandroid backup and wipe stages.

It proceeded to first boot and after 40 mins of crossing my fingers and holding my breath I gave up.

So now my phone wont go past the "HERO" load screen. I can go back into recovery but there is no Nandroid to recover to. I have tried using the wipe data/factory reset option followed by a re-install of the damage control rom hoping this ould give a clean install and work and it appears to have installed just fine howver the phone still wont boot (been giving it a good 30 mins, even once overnight)

Any help would be really appreciated, I am a bit of a noob, but I love my hero and im absolutely gutted!


Well-Known Member
I would try to flash another ROM if that one isn't working. (Such as Villain)

Boot into recovery and enable USB/MS and transfer another rom to your SD card, then do a full wipe and flash it and reboot.

If that works then you can try the Damagecontrol one again, maybe download it again in case it's corrupt or something?

Maybe not the ideal solution but at least you should be able to get a working system again if that rom isn't working.

Oh and you should manually make a nandroid backup just in case something goes wrong.


Thread starter
Thanks for the reply James, really appreciate it.

Yeah I was hoping since the phone still turns on and I can access recovery all was not lost but i'm finding things very confusing.

All I really want is a working system so will try flashing another rom. Did try and find a stock gsm 1.5 ROM but had no luck so think i'll go with SenseHero 1.6, unless you can recommend anything thats more tried and tested and likely to get me a working system.

Sorry for the obvious questions but in the partitions menu what do i need mounted and what unmounted for this to work (options are system, data, cache, sdcard, sd-ext, usb storage)

Also Im not sure what the toggle signature verification and toggle script asserts do, dont want them to be the cause of any more heart ache.

To do a FULL WIPE as u say is that just both wipe data/factory rest and wipe cache options?

Thanks again for all your help


Well-Known Member
I use Villain (linked in above post) which I find to be a great rom, but it's up to you of course.

Oh yeh I forgot you have a different recovery. On mine you just select enable usb and that allows you to transfer files to the sdcard. If there isn't an option like that, then from what you've said I would assume you need to mount the 'sdcard' option.

In terms of the other options I can't say I'm too sure what they are, I would just leave them on whatever they were on, it shouldn't effect anything.

Full wipe, yeh do wipe data/factory reset and also cache. And also ext partition if you have one (if not don't worry about it).

Hope you get it sorted! :)


4 8 15 16 23 42
Don't try to flash damagecontrol! That firmware is for the American Sprint (CDMA) phones only, and you're just asking to brick your phone by trying to use it on a European (GSM) phone. Just be glad you did no permanent damage.

Avoid anything Sprint/CDMA related in the future.

I wouldn't use the Clockworld recovery menu either, for the same reason. Amon Ra is the one for GSM phones. I would switch that as soon as possible. It is possible to do this without having access to the normal phone, but you'd have to set up ADB access.


Thread starter
WOW! i guess I dodged a bullet there! Thanks so much for your help guys.

Now successfully running SenseHero 2.2 and first impressions are v good. To be honest I'm glad to just have a working system now, last night I feared the worst.