1. Download our Official Android App: Forums for Android!

Support POP3 mail will not send over mobile network (but works when connected to wireless)

Discussion in 'Android Devices' started by brixtonia, Jul 23, 2011.

  1. brixtonia

    brixtonia Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    7
    0
    5
    Hello. I have a new Samsung Galaxy Sii on the 3 network. My POP3 email is provided by Plus.net.

    I set up the email account details online using Samsung's "Configure phone" utility. The same settings have worked for me on various other phones including the Nokia N97.

    When I try to send POP3 emails via the mobile network they will stay in my outbox until the phone connects to the wireless network and then sends them. I receive POP3 emails without any problems when on both wireless or mobile network.

    When I check outgoing server settings I receive the message : "Checking outgoing serve settings" followed by "Setup could not finish - unable to connect to server." When I check incoming server settings I have no problem.

    I have no problem with internet access over the mobile network.
    My APN type is "internet + mms".

    Both 3 and Samsung recommended a hard reset but that did nothing.

    Does anyone have any sage advice which might help get my outgoing email working over the mobile network?

    Thank you!
     

    Advertisement

  2. ironass

    ironass Android Expert
    Rank:
     #20
    Points:
    1,343
    Posts:
    11,441
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,441
    5,653
    1,343
    Male
    Keeping one step ahead of the tax man.
    Cotswolds, England
    Just checking the obvious...

    Settings > Accounts and sync > Background data (ticked) Auto sync (ticked).

    Settings > Wireless and network > Mobile networks > Use packet data (ticked).
     
  3. brixtonia

    brixtonia Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    7
    0
    5
    Thanks for your reply. Yes all three are ticked.
     
  4. ironass

    ironass Android Expert
    Rank:
     #20
    Points:
    1,343
    Posts:
    11,441
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,441
    5,653
    1,343
    Male
    Keeping one step ahead of the tax man.
    Cotswolds, England
    As you have nothing to lose at this stage... you could try downloading K-9 Mail, free from the Market, and see if that resolves your problem.
     
  5. jspx1

    jspx1 Newbie
    Rank:
    None
    Points:
    36
    Posts:
    21
    Joined:
    May 26, 2011

    May 26, 2011
    21
    8
    36
    UK
    I think it could be a smtp issue. How have you configured the plus.net smtp settings ? Any authentication required or SSL ports required? or do Plus.net allow smtp access from outside their network.
    I think the phone waits until it connects to your wireless network before sending because you are already verified by plus.net on your land line, but that's not the case when you try to connect to their mail sending server from your phone on 3g.
    You could also consider using Google or Windows live SMTP settings for outgoing mail if you have an account with them.

    Form the Plus.net site.
    Incoming (POP3) Server mail.plus.net
    Outgoing (SMTP) Server relay.plus.net
     
  6. brixtonia

    brixtonia Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    7
    0
    5
    Thanks for the reply.

    I'm actually an old free-online customer so my settings are different to the standard plus.net ones. But they have worked on several previous phones.

    Authentication is required but not SSL.

    Would like to avoid using a different account to send with as I use the email account for business and it doesn't look very professional.
     
  7. Mutant04

    Mutant04 Member
    Rank:
    None
    Points:
    16
    Posts:
    68
    Joined:
    May 20, 2011

    May 20, 2011
    68
    6
    16
    I to have had problems with sending email using my mobile network, and the description in the first post sounds the same, I too am with 3 although I'm not with Plusnet.

    From my understanding to be able to send an email you have to go through 3's own SMTP.

    I've set my outgoing settings as follows:

    SMTP server: smtp-mbb.three.co.uk
    Security type: None
    Port: 25
    Require to sign in : unticked.

    This seems to work fine.

    Just a little note my incoming settings are for my actual email setting (ie in you case Plusnet email settings).

    I hope this helps.
     
    brixtonia likes this.
  8. Jigsy

    Jigsy Member
    Rank:
    None
    Points:
    16
    Posts:
    40
    Joined:
    Dec 16, 2009

    Dec 16, 2009
    40
    8
    16
    West Mids, UK
    I to had problems with my old Hero phone and also with my new Samsung S2. Like Mutant04 has said you need to check what outgoing port (smtp) Plus.net use? I think when you set up an email account on the S2 the smtp port defaults to a different port number. After doing some research I also changed my port to 25 after reading Virgin Media FAQ page, having an old email address from the days when Virgin were NTL. That sorted my problems out for me. I hope you sort your's out.

    Regards

    Jigsy
     
  9. brixtonia

    brixtonia Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    7
    0
    5
    Thanks. This has partly solved the problem in that the emails now leave my outbox - but none of them have actually turned up with the recipient!
     
  10. brixtonia

    brixtonia Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    7
    0
    5
    Cheers Jigsy. My settings are on 25.
    This is doing my head in!
     
  11. brixtonia

    brixtonia Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    7
    0
    5
    Just an update. This worked in that my emails left the outbox - unfortunately delivery took about 7hrs!

    I am still keen to try to make it work with my previously functional free-online.net smtp settings if anyone has any ideas.
     
  12. Mutant04

    Mutant04 Member
    Rank:
    None
    Points:
    16
    Posts:
    68
    Joined:
    May 20, 2011

    May 20, 2011
    68
    6
    16
    That seems rather a long time for delivery. I've tried mine again with the settings I gave. I sent an email to my google mail account, another to my father's Yahoo account and an email to my mate.The Yahoo email even had an attachment of a spreadsheet.
    All sent straight away (left the outbox)
    I got a pretty much instant (under 30 seconds) notification from my googlemail account, and on checking with my father and mate the email had come through straight away.

    so I can't understand why its taking so long to delivery??? I have a mate whose a bit more techie than me on stuff like this so I see what I can find out.
    I know at first when I couldn't get it working it was very annoying and how it drives you nuts, so I hope you can get it sorted.

    regards
    Mutant04
     
  13. brixtonia

    brixtonia Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Jul 23, 2011

    Jul 23, 2011
    7
    0
    5
    Cheers Mutant04. Just tested it again and this time it went straight through. Looks like you solved my problem. Cheers.
     
  14. Andy Watson

    Andy Watson Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 1, 2012

    Mar 1, 2012
    1
    0
    5
    Mutant4

    You rock! I've been trying all day to get my outgoing server to work, your solution worked! I had to reboot my Android to get the message to arrive immediately. Why don't the suppliers ever tell us this stuff?

    Many many thanks
     
  15. InputDynamics

    InputDynamics Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 7, 2012

    Mar 7, 2012
    3
    0
    5
    I have a Samsung Galaxy S on 3 (Android 2.3.5) and if I use port 26 in the Outgoing Server Settings I can use the SMTP server of my account.

    Hope this helps
     
  16. redrover

    redrover Member
    Rank:
    None
    Points:
    16
    Posts:
    54
    Joined:
    May 4, 2010

    May 4, 2010
    54
    3
    16
    Check out your smtp port (port 25) some phone line service providers would rather you use port 587
     
  17. InputDynamics

    InputDynamics Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 7, 2012

    Mar 7, 2012
    3
    0
    5
    Thanks,

    I tried port 587 but I get the "Unable to connect server" message.

    I then re-entered port 26 that worked yesterday but today it gives me the above error message as well.

    I give up. Mutant04 method seems to be the only one working reliably on 3. Thank you

    Gio
     
  18. InputDynamics

    InputDynamics Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Mar 7, 2012

    Mar 7, 2012
    3
    0
    5
    and port 587 does not work in my case.

    I have just re-tested

    Sorry, the reason why Port 26 wasn't working this morning was that there was an outage on the SMTP server (Murphy's law. First time has happened or at least first time I've noticed this!) and didn't have anything to do with Android or Galaxy or 3.

    So using Port 26 in the SMTP settings appears to be still an option to send emails through your account rather than through 3 SMTP servers.

    Apparently using Port 26 instead of 25 might be a work-around for other ISPs as well (Orange, BT...

    G
     

Share This Page

Loading...